summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/fail2ban/ChangeLog7
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.8.1.ebuild51
-rw-r--r--net-analyzer/fail2ban/files/digest-fail2ban-0.8.13
3 files changed, 60 insertions, 1 deletions
diff --git a/net-analyzer/fail2ban/ChangeLog b/net-analyzer/fail2ban/ChangeLog
index 561e497d6b74..fd095faf8136 100644
--- a/net-analyzer/fail2ban/ChangeLog
+++ b/net-analyzer/fail2ban/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/fail2ban
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/ChangeLog,v 1.34 2007/07/05 22:49:55 falco Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/ChangeLog,v 1.35 2007/08/31 15:06:17 falco Exp $
+
+*fail2ban-0.8.1 (31 Aug 2007)
+
+ 31 Aug 2007; Raphael Marichez <falco@gentoo.org> +fail2ban-0.8.1.ebuild:
+ Version bump, bug 190852. And adding virtual/mta runtime dependency.
05 Jul 2007; Raphael Marichez <falco@gentoo.org> fail2ban-0.8.0.ebuild,
fail2ban-0.8.0-r1.ebuild:
diff --git a/net-analyzer/fail2ban/fail2ban-0.8.1.ebuild b/net-analyzer/fail2ban/fail2ban-0.8.1.ebuild
new file mode 100644
index 000000000000..155499d76e3c
--- /dev/null
+++ b/net-analyzer/fail2ban/fail2ban-0.8.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.8.1.ebuild,v 1.1 2007/08/31 15:06:17 falco Exp $
+
+inherit distutils
+
+DESCRIPTION="Bans IP that make too many password failures"
+HOMEPAGE="http://fail2ban.sourceforge.net/"
+SRC_URI="mirror://sourceforge/fail2ban/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.4"
+RDEPEND="${DEPEND}
+ virtual/mta"
+
+src_install() {
+ distutils_src_install
+
+ newconfd files/gentoo-confd fail2ban
+ newinitd files/gentoo-initd fail2ban
+ dodoc CHANGELOG README TODO || die "dodoc failed"
+ doman man/*.1 || die "doman failed"
+}
+
+pkg_postinst() {
+ if has_version '<net-analyzer/fail2ban-0.7' ; then
+ elog
+ elog "Configuration files are now in /etc/fail2ban/"
+ elog "You probably have to manually update your configuration"
+ elog "files before restarting Fail2ban!"
+ elog
+ elog "Fail2ban is not installed under /usr/lib anymore. The"
+ elog "new location is under /usr/share."
+ elog
+ elog "You are upgrading from version 0.6.x, please see:"
+ elog "http://www.fail2ban.org/wiki/index.php/HOWTO_Upgrade_from_0.6_to_0.8"
+ fi
+}
+
+pkg_setup() {
+ if ! built_with_use dev-lang/python readline ; then
+ echo
+ eerror "dev-lang/python is missing readline support. Please add"
+ eerror "'readline' to your USE flags, and re-emerge dev-lang/python."
+ die "dev-lang/python needs readline support"
+ fi
+}
diff --git a/net-analyzer/fail2ban/files/digest-fail2ban-0.8.1 b/net-analyzer/fail2ban/files/digest-fail2ban-0.8.1
new file mode 100644
index 000000000000..3c93902081e4
--- /dev/null
+++ b/net-analyzer/fail2ban/files/digest-fail2ban-0.8.1
@@ -0,0 +1,3 @@
+MD5 91e45125924e7978949fdab2e32b71a1 fail2ban-0.8.1.tar.bz2 58321
+RMD160 7f695e2efc4af3fe21657a4d1613cd7beeb623ad fail2ban-0.8.1.tar.bz2 58321
+SHA256 3c3adc67c5f2b4fc72c9ea22e52c4cdfd9f901f6c238616416444560f56f6403 fail2ban-0.8.1.tar.bz2 58321