summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail-filter/amavisd-new/ChangeLog9
-rw-r--r--mail-filter/amavisd-new/amavisd-new-2.4.4.ebuild180
-rw-r--r--mail-filter/amavisd-new/files/amavisd-new-2.4.4-amavisd.conf-gentoo.patch115
-rw-r--r--mail-filter/amavisd-new/files/digest-amavisd-new-2.4.43
4 files changed, 306 insertions, 1 deletions
diff --git a/mail-filter/amavisd-new/ChangeLog b/mail-filter/amavisd-new/ChangeLog
index b2e895dcd62d..fef96b850104 100644
--- a/mail-filter/amavisd-new/ChangeLog
+++ b/mail-filter/amavisd-new/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for mail-filter/amavisd-new
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/amavisd-new/ChangeLog,v 1.97 2006/12/10 20:48:12 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/amavisd-new/ChangeLog,v 1.98 2006/12/18 17:00:35 ticho Exp $
+
+*amavisd-new-2.4.4 (18 Dec 2006)
+
+ 18 Dec 2006; Andrej Kacian <ticho@gentoo.org>
+ +files/amavisd-new-2.4.4-amavisd.conf-gentoo.patch,
+ +amavisd-new-2.4.4.ebuild:
+ Version bump. Bug #156576, by Janne Pikkarainen <jaba at mikrobitti.fi>.
10 Dec 2006; Andrej Kacian <ticho@gentoo.org> amavisd-new-2.3.3-r2.ebuild,
amavisd-new-2.4.1.ebuild, amavisd-new-2.4.2.ebuild,
diff --git a/mail-filter/amavisd-new/amavisd-new-2.4.4.ebuild b/mail-filter/amavisd-new/amavisd-new-2.4.4.ebuild
new file mode 100644
index 000000000000..d8327434fa71
--- /dev/null
+++ b/mail-filter/amavisd-new/amavisd-new-2.4.4.ebuild
@@ -0,0 +1,180 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/amavisd-new/amavisd-new-2.4.4.ebuild,v 1.1 2006/12/18 17:00:35 ticho Exp $
+
+inherit eutils
+
+DESCRIPTION="High-performance interface between the MTA and content checkers."
+HOMEPAGE="http://www.ijs.si/software/amavisd/"
+SRC_URI="http://www.ijs.si/software/amavisd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ldap mysql postgres milter"
+
+DEPEND=">=sys-apps/sed-4
+ >=dev-lang/perl-5.8.2"
+
+RDEPEND="${DEPEND}
+ >=sys-apps/coreutils-5.0-r3
+ app-arch/gzip
+ app-arch/bzip2
+ app-arch/arc
+ app-arch/cabextract
+ app-arch/freeze
+ app-arch/lha
+ app-arch/unarj
+ app-arch/unrar
+ app-arch/zoo
+ dev-perl/Archive-Tar
+ >=dev-perl/Archive-Zip-1.14
+ >=dev-perl/Compress-Zlib-1.35
+ dev-perl/Convert-TNEF
+ >=dev-perl/Convert-UUlib-1.051
+ virtual/perl-MIME-Base64
+ >=dev-perl/MIME-tools-5.415
+ >=dev-perl/MailTools-1.58
+ >=dev-perl/net-server-0.91
+ >=virtual/perl-libnet-1.16
+ dev-perl/IO-stringy
+ >=virtual/perl-Time-HiRes-1.49
+ dev-perl/Unix-Syslog
+ >=sys-libs/db-3.1
+ dev-perl/BerkeleyDB
+ virtual/mta
+ ldap? ( >=dev-perl/perl-ldap-0.33 )
+ mysql? ( dev-perl/DBD-mysql )
+ postgres? ( dev-perl/DBD-Pg )
+ milter? ( >=mail-mta/sendmail-8.12 )"
+
+AMAVIS_ROOT="/var/amavis"
+
+pkg_preinst() {
+ enewgroup amavis
+ enewuser amavis -1 -1 ${AMAVIS_ROOT} amavis
+}
+
+src_unpack() {
+ if $(has_version "<mail-filter/spamassassin-3") ; then
+ echo
+ ewarn "WARNING: Amavisd-new will not work with SpamAssassin older than 3.0.0."
+ ewarn " Consider upgrading your SpamAssassin installation."
+ ebeep 3
+ epause
+ fi
+ unpack ${A}
+ cd ${S}
+ if $(has_version mail-mta/courier) ; then
+ einfo "Patching with courier support."
+ epatch "amavisd-new-courier.patch" || die "patch failed"
+ fi
+
+ if $(has_version virtual/qmail) ; then
+ einfo "Patching with qmail qmqp support."
+ epatch "amavisd-new-qmqpqq.patch" || die "patch failed"
+
+ einfo "Patching with qmail lf bug workaround."
+ epatch "${FILESDIR}/${P%.*}-qmail-lf-workaround.patch" || die "patch failed"
+ fi
+
+ epatch "${FILESDIR}/${P}-amavisd.conf-gentoo.patch" || die "patch failed"
+}
+
+src_compile() {
+ if use milter ; then
+ cd "${S}/helper-progs"
+
+ econf --with-runtime-dir=${AMAVIS_ROOT} \
+ --with-sockname=${AMAVIS_ROOT}/amavisd.sock \
+ --with-user=amavis || die "helper-progs econf failed"
+ emake || die "helper-progs compile problem"
+
+ cd "${S}"
+ fi
+}
+
+src_install() {
+ dosbin amavisd amavisd-agent amavisd-nanny amavisd-release
+
+ dobin p0f-analyzer.pl
+
+ insinto /etc
+ insopts -m0640
+ newins amavisd.conf-sample amavisd.conf
+ dosed "s:^#\\?\\\$MYHOME[^;]*;:\$MYHOME = '$AMAVIS_ROOT';:" \
+ /etc/amavisd.conf
+ if [ "$(dnsdomainname)" = "(none)" ] ; then
+ dosed "s:^#\\?\\\$mydomain[^;]*;:\$mydomain = '$(hostname)';:" \
+ /etc/amavisd.conf
+ else
+ dosed "s:^#\\?\\\$mydomain[^;]*;:\$mydomain = '$(dnsdomainname)';:" \
+ /etc/amavisd.conf
+ fi
+
+ newinitd "${FILESDIR}/amavisd.rc6" amavisd
+ dosed "s:/var/run/amavis/:$AMAVIS_ROOT/:g" /etc/init.d/amavisd
+
+ keepdir ${AMAVIS_ROOT}
+ keepdir ${AMAVIS_ROOT}/db
+ keepdir ${AMAVIS_ROOT}/quarantine
+ keepdir ${AMAVIS_ROOT}/tmp
+
+ if $(has_version net-nds/openldap ) ; then
+ einfo "Adding ${P} schema to openldap schema dir."
+ dodir /etc/openldap/schema
+ insinto /etc/openldap/schema
+ insopts -o root -g root -m 644
+ newins LDAP.schema ${PN}.schema || die
+ newins LDAP.schema ${PN}.schema.default || die
+ fi
+
+ newdoc test-messages/README README.samples
+ dodoc AAAREADME.first INSTALL LICENSE MANIFEST RELEASE_NOTES \
+ README_FILES/* test-messages/sample* amavisd.conf-default amavisd-agent
+
+ if use milter ; then
+ cd "${S}/helper-progs"
+ einstall
+ fi
+
+ for i in whitelist blacklist spam_lovers; do
+ if [ ! -f ${D}/${AMAVIS_ROOT}/${i} ]; then
+ touch ${D}/${AMAVIS_ROOT}/${i}
+ fi
+ done
+
+ if $(has_version mail-filter/razor) ; then
+ if [ ! -f ${AMAVIS_ROOT}/.razor/razor-agent.conf ] ; then
+ einfo "Setting up initial razor config files..."
+
+ razor-admin -create -home=${D}/${AMAVIS_ROOT}/.razor
+ sed -i -e "s:debuglevel\([ ]*\)= .:debuglevel\1= 0:g" \
+ ${D}/${AMAVIS_ROOT}/.razor/razor-agent.conf
+ else
+ einfo "Copying existing razor config files..."
+ insinto ${AMAVIS_ROOT}/.razor
+ doins ${AMAVIS_ROOT}/.razor/*.{conf,lst}
+ fi
+ fi
+
+ find ${D}/${AMAVIS_ROOT} -name "*" -type d -exec chmod 0750 \{\} \;
+ find ${D}/${AMAVIS_ROOT} -name "*" -type f -exec chmod 0640 \{\} \;
+}
+
+pkg_postinst() {
+ if ! $(has_version mail-filter/spamassassin) ; then
+ echo
+ einfo "Amavisd-new no longer requires SpamAssassin, but no anti-spam checking"
+ einfo "will be performed without it. Since you do not have SpamAssassin installed,"
+ einfo "all spam checks have been disabled. To enable them, install SpamAssassin"
+ einfo "and comment out the line containing: "
+ einfo "@bypass_spam_checks_maps = (1); in /etc/amavisd.conf."
+ fi
+ echo
+ ewarn "Adjusting permissions for /etc/amavisd.conf (0 for world, owner root:amavis)"
+ echo
+ chmod o-rwx /etc/amavisd.conf
+ chown root:amavis /etc/amavisd.conf
+ chown -R amavis:amavis ${AMAVIS_ROOT}
+}
diff --git a/mail-filter/amavisd-new/files/amavisd-new-2.4.4-amavisd.conf-gentoo.patch b/mail-filter/amavisd-new/files/amavisd-new-2.4.4-amavisd.conf-gentoo.patch
new file mode 100644
index 000000000000..02b1e4e17549
--- /dev/null
+++ b/mail-filter/amavisd-new/files/amavisd-new-2.4.4-amavisd.conf-gentoo.patch
@@ -0,0 +1,115 @@
+--- amavisd.conf-sample.orig 2006-12-18 17:14:43.000000000 +0100
++++ amavisd.conf-sample 2006-12-18 17:19:46.000000000 +0100
+@@ -74,14 +74,14 @@
+
+ # Set the user and group to which the daemon will change if started as root
+ # (otherwise just keeps the UID unchanged, and these settings have no effect):
+-$daemon_user = 'vscan'; # (no default; customary: vscan or amavis), -u
+-$daemon_group = 'vscan'; # (no default; customary: vscan or amavis), -g
++$daemon_user = 'amavis'; # (no default; customary: vscan or amavis), -u
++$daemon_group = 'amavis'; # (no default; customary: vscan or amavis), -g
+
+ # Runtime working directory (cwd), and a place where
+ # temporary directories for unpacking mail are created.
+ # (no trailing slash, may be a scratch file system)
+-$TEMPBASE = $MYHOME; # (must be set if other config vars use is), -T
+-#$TEMPBASE = "$MYHOME/tmp"; # prefer to keep home dir /var/amavis clean?
++#$TEMPBASE = $MYHOME; # (must be set if other config vars use is), -T
++$TEMPBASE = "$MYHOME/tmp"; # prefer to keep home dir /var/amavis clean?
+
+ #$db_home = "$MYHOME/db"; # DB databases directory, default "$MYHOME/db", -D
+
+@@ -492,22 +492,43 @@
+ # default setting of an associative array %final_destiny_by_ccat which is
+ # backwards compatible and contains references to these traditional variables:
+ #
+-$final_virus_destiny = D_DISCARD; # (defaults to D_DISCARD)
+-$final_banned_destiny = D_BOUNCE; # (defaults to D_BOUNCE)
+-$final_spam_destiny = D_BOUNCE; # (defaults to D_BOUNCE)
+-$final_bad_header_destiny = D_PASS; # (defaults to D_PASS)
++#$final_virus_destiny = D_DISCARD; # (defaults to D_DISCARD)
++#$final_banned_destiny = D_BOUNCE; # (defaults to D_BOUNCE)
++#$final_spam_destiny = D_BOUNCE; # (defaults to D_BOUNCE)
++#$final_bad_header_destiny = D_PASS; # (defaults to D_PASS)
++
++########
++#
++# Please think about what you are doing when you set these options.
++# If necessary, question your origanization's e-mail policies:
++#
++# D_BOUNCE contributes to the overall spread of virii and spam on the
++# internet. Both the envelope and header from addresses can be forged
++# accurately with no effort, causing the bounces to go to innocent parties,
++# whose addresses have been forged.
++#
++# D_DISCARD breaks internet mail specifications. However, with a
++# properly implemented Quaratine system, the concern for breaking the
++# specification is addressed to some extent.
++#
++# D_PASS is the safest way to handle e-mails. You must implement
++# client-side filtering to handle this method.
++#
++# -Cory Visi <merlin@gentoo.org> 07/28/04
++#
++#######
+
+ # to explicitly list all (or most) possible contents category (ccat) keys:
+-#%final_destiny_by_ccat = (
+-# CC_VIRUS, D_DISCARD,
+-# CC_BANNED, D_BOUNCE,
+-# CC_UNCHECKED, D_PASS,
+-# CC_SPAM, D_BOUNCE,
+-# CC_BADH, D_PASS,
+-# CC_OVERSIZED, D_BOUNCE,
+-# CC_CLEAN, D_PASS,
+-# CC_CATCHALL, D_PASS,
+-#);
++%final_destiny_by_ccat = (
++ CC_VIRUS, D_DISCARD,
++ CC_BANNED, D_BOUNCE,
++ CC_UNCHECKED, D_PASS,
++ CC_SPAM, D_DISCARD,
++ CC_BADH, D_PASS,
++ CC_OVERSIZED, D_BOUNCE,
++ CC_CLEAN, D_PASS,
++ CC_CATCHALL, D_PASS,
++);
+
+ # to rely on a catchall ccat key and only list exceptions (alternative 1):
+ #%final_destiny_by_ccat = (
+@@ -689,7 +710,7 @@
+ # or a directory (no trailing slash)
+ # (the default value is undef, meaning no quarantine)
+ #
+-$QUARANTINEDIR = '/var/virusmails'; # -Q
++$QUARANTINEDIR = "$MYHOME/quarantine";
+
+ #$quarantine_subdir_levels = 1; # add level of subdirs to disperse quarantine
+
+@@ -1658,7 +1679,7 @@
+ # NOTE: if $daemon_chroot_dir is nonempty, the directories will be
+ # relative to the chroot directory specified;
+
+-$path = '/usr/local/sbin:/usr/local/bin:/usr/sbin:/sbin:/usr/bin:/bin';
++$path = '/usr/local/sbin:/usr/local/bin:/usr/sbin:/sbin:/usr/bin:/bin:/opt/bin';
+
+ # For external programs specify one string or a search list of strings (first
+ # match wins). The string (or: each string in a list) may be an absolute path,
+@@ -2124,7 +2145,7 @@
+
+ ### http://www.nai.com/
+ ['NAI McAfee AntiVirus (uvscan)', 'uvscan',
+- '--secure -rv --mime --summary --noboot - {}', [0], [13],
++ '--secure -rv --mime --summary --noboot --mailbox --program --timeout 180 - {}', [0], [13],
+ qr/(?x) Found (?:
+ \ the\ (.+)\ (?:virus|trojan) |
+ \ (?:virus|trojan)\ or\ variant\ ([^ ]+) |
+@@ -2246,7 +2267,7 @@
+
+ ### http://www.f-prot.com/ - backs up F-Prot Daemon
+ ['FRISK F-Prot Antivirus', ['f-prot','f-prot.sh'],
+- '-dumb -archive -packed {}', [0,8], [3,6], # or: [0], [3,6,8],
++ '-dumb -ai -archive -packed -server {}', [0,8], [3,6], # or: [0], [3,6,8],
+ qr/(?:Infection:|security risk named) (.+)|\s+contains\s+(.+)$/ ],
+
+ ### http://www.trendmicro.com/ - backs up Trophie
diff --git a/mail-filter/amavisd-new/files/digest-amavisd-new-2.4.4 b/mail-filter/amavisd-new/files/digest-amavisd-new-2.4.4
new file mode 100644
index 000000000000..7af62ef9a7db
--- /dev/null
+++ b/mail-filter/amavisd-new/files/digest-amavisd-new-2.4.4
@@ -0,0 +1,3 @@
+MD5 08b009ca24dc3676293fc6b80db250a3 amavisd-new-2.4.4.tar.gz 887625
+RMD160 3d6ac62f57b68440a7ca3766ff374f4763db6bbf amavisd-new-2.4.4.tar.gz 887625
+SHA256 b3a11ff3813e8b6c7cdf48c852c7bc672b2c0c6115d1b1dba896cd6358b67889 amavisd-new-2.4.4.tar.gz 887625