summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-scheme/gauche-gtk/ChangeLog6
-rw-r--r--dev-scheme/gauche-gtk/files/digest-gauche-gtk-0.4.12
-rw-r--r--dev-scheme/gauche-gtk/files/gauche-gtk-0.4.1-gtk+-2.8.diff23
-rw-r--r--dev-scheme/gauche-gtk/gauche-gtk-0.4.1.ebuild69
4 files changed, 70 insertions, 30 deletions
diff --git a/dev-scheme/gauche-gtk/ChangeLog b/dev-scheme/gauche-gtk/ChangeLog
index e919c5bc8da4..0e8d184c98f3 100644
--- a/dev-scheme/gauche-gtk/ChangeLog
+++ b/dev-scheme/gauche-gtk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-scheme/gauche-gtk
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gauche-gtk/ChangeLog,v 1.8 2006/04/22 15:16:35 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gauche-gtk/ChangeLog,v 1.9 2006/10/30 10:29:13 hattya Exp $
+
+ 30 Oct 2006; Akinori Hattori <hattya@gentoo.org>
+ +files/gauche-gtk-0.4.1-gtk+-2.8.diff, gauche-gtk-0.4.1.ebuild:
+ fix compilation problem with gtk+ v2.8.
22 Apr 2006; Akinori Hattori <hattya@gentoo.org> -gauche-gtk-0.3.1.ebuild,
-gauche-gtk-0.3.2.ebuild, -gauche-gtk-0.4.ebuild:
diff --git a/dev-scheme/gauche-gtk/files/digest-gauche-gtk-0.4.1 b/dev-scheme/gauche-gtk/files/digest-gauche-gtk-0.4.1
index 92895dc34aec..b33ec17bd66f 100644
--- a/dev-scheme/gauche-gtk/files/digest-gauche-gtk-0.4.1
+++ b/dev-scheme/gauche-gtk/files/digest-gauche-gtk-0.4.1
@@ -1 +1,3 @@
MD5 18356efab446b9524be8371a3b852a6a Gauche-gtk-0.4.1.tgz 324945
+RMD160 8ee51c2444505dfe6bc70d18f244c510f0c2bcfc Gauche-gtk-0.4.1.tgz 324945
+SHA256 5f600214b04ce4090ca6aa63f9344a0c6ec9a2462e4106b53a7a44514d4a73db Gauche-gtk-0.4.1.tgz 324945
diff --git a/dev-scheme/gauche-gtk/files/gauche-gtk-0.4.1-gtk+-2.8.diff b/dev-scheme/gauche-gtk/files/gauche-gtk-0.4.1-gtk+-2.8.diff
new file mode 100644
index 000000000000..9734da949518
--- /dev/null
+++ b/dev-scheme/gauche-gtk/files/gauche-gtk-0.4.1-gtk+-2.8.diff
@@ -0,0 +1,23 @@
+diff -urN Gauche-gtk-0.4.1.orig/src/gtktexttag.stub Gauche-gtk-0.4.1/src/gtktexttag.stub
+--- Gauche-gtk-0.4.1.orig/src/gtktexttag.stub 2004-06-27 12:59:26.000000000 +0900
++++ Gauche-gtk-0.4.1/src/gtktexttag.stub 2006-10-30 17:53:25.039657000 +0900
+@@ -36,7 +36,6 @@
+ (language-set :type <uint>)
+ (pad1 :type <uint>)
+ (pad2 :type <uint>)
+- (pad3 :type <uint>)
+ )
+ (allocator (c "Scm_GtkObjectAllocate"))
+ )
+diff -urN Gauche-gtk-0.4.1.orig/src/gtktoolbar.stub Gauche-gtk-0.4.1/src/gtktoolbar.stub
+--- Gauche-gtk-0.4.1.orig/src/gtktoolbar.stub 2004-06-27 12:59:26.000000000 +0900
++++ Gauche-gtk-0.4.1/src/gtktoolbar.stub 2006-10-30 18:16:32.889657000 +0900
+@@ -51,8 +51,6 @@
+ (tooltips :type <gtk-tooltips>)
+ (button-maxw :type <int>)
+ (button-maxh :type <int>)
+- (style-set-connection :type <uint>)
+- (icon-size-connection :type <uint>)
+ (style-set :type <uint>)
+ (icon-size-set :type <uint>)
+ )
diff --git a/dev-scheme/gauche-gtk/gauche-gtk-0.4.1.ebuild b/dev-scheme/gauche-gtk/gauche-gtk-0.4.1.ebuild
index 51945d743988..7c844a1ea76c 100644
--- a/dev-scheme/gauche-gtk/gauche-gtk-0.4.1.ebuild
+++ b/dev-scheme/gauche-gtk/gauche-gtk-0.4.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gauche-gtk/gauche-gtk-0.4.1.ebuild,v 1.5 2006/04/22 15:15:01 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gauche-gtk/gauche-gtk-0.4.1.ebuild,v 1.6 2006/10/30 10:29:13 hattya Exp $
inherit eutils flag-o-matic
-IUSE="glgd nls opengl"
+IUSE="examples glgd nls opengl"
MY_P="${P/g/G}"
@@ -12,11 +12,10 @@ DESCRIPTION="GTK2 binding for Gauche"
HOMEPAGE="http://gauche.sf.net/"
SRC_URI="mirror://sourceforge/gauche/${MY_P}.tgz"
-RESTRICT="nomirror"
LICENSE="BSD"
KEYWORDS="~ppc x86"
SLOT="0"
-S="${WORKDIR}/${MY_P}"
+S=${WORKDIR}/${MY_P}
DEPEND="${RDEPEND}
dev-util/pkgconfig"
@@ -24,9 +23,20 @@ RDEPEND=">=x11-libs/gtk+-2
>=dev-lang/gauche-0.7.4.1
opengl? ( >=x11-libs/gtkglext-0.6.0 )"
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ if has_version '>=x11-libs/gtk+-2.8'; then
+ epatch "${FILESDIR}"/${P}-gtk+-2.8.diff
+ fi
+
+}
+
src_compile() {
- local myconf myflags
+ local myconf
if use opengl; then
if use glgd; then
@@ -42,44 +52,45 @@ src_compile() {
strip-flags
- myflags=${CFLAGS}
- unset CFLAGS CXXFLAGS
-
econf ${myconf} || die
- emake OPTFLAGS="${myflags}" || die
+ emake || die
}
-src_install() {
+src_test() {
- dodir $(gauche-config --syslibdir)
- dodir $(gauche-config --sysincdir)
- dodir $(gauche-config --sysarchdir)
+ return
- make DESTDIR=${D} install || die
+}
+
+src_install() {
+
+ emake DESTDIR="${D}" install || die
dodoc ChangeLog README
+ if use examples; then
+ docinto examples
- docinto examples
- for f in examples/*; do
- [ -f ${f} ] && dodoc ${f}
- done
+ for f in examples/*; do
+ [ -f ${f} ] && dodoc ${f}
+ done
- docinto examples/gtk-tutorial
- dodoc examples/gtk-tutorial/*
+ docinto examples/gtk-tutorial
+ dodoc examples/gtk-tutorial/*
- if use opengl; then
- docinto examples/gtkglext
- dodoc examples/gtkglext/*
+ if use opengl; then
+ docinto examples/gtkglext
+ dodoc examples/gtkglext/*
- if use glgd; then
- docinto examples/glgd
- dodoc examples/glgd/*
+ if use glgd; then
+ docinto examples/glgd
+ dodoc examples/glgd/*
- docinto
- newdoc glgd/README README.glgd
- newdoc glgd/README.eucjp README.eucjp.glgd
+ docinto
+ newdoc glgd/README README.glgd
+ newdoc glgd/README.eucjp README.eucjp.glgd
+ fi
fi
fi