summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-drivers/xf86-input-evdev/ChangeLog8
-rw-r--r--x11-drivers/xf86-input-evdev/files/xf86-input-evdev-1.1.2-mips-syscalls.patch24
-rw-r--r--x11-drivers/xf86-input-evdev/xf86-input-evdev-1.1.2-r1.ebuild4
3 files changed, 33 insertions, 3 deletions
diff --git a/x11-drivers/xf86-input-evdev/ChangeLog b/x11-drivers/xf86-input-evdev/ChangeLog
index 74b3af684e49..4ef9d71475fd 100644
--- a/x11-drivers/xf86-input-evdev/ChangeLog
+++ b/x11-drivers/xf86-input-evdev/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-input-evdev
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/ChangeLog,v 1.21 2006/05/20 08:14:51 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/ChangeLog,v 1.22 2006/06/22 21:50:01 geoman Exp $
+
+ 22 Jun 2006; Stephen P. Becker <geoman@gentoo.org>
+ +files/xf86-input-evdev-1.1.2-mips-syscalls.patch,
+ xf86-input-evdev-1.1.2-r1.ebuild:
+ add a patch to fix build error due to lack of mips define in
+ src/inotify-syscalls.h
*xf86-input-evdev-1.1.2-r1 (20 May 2006)
diff --git a/x11-drivers/xf86-input-evdev/files/xf86-input-evdev-1.1.2-mips-syscalls.patch b/x11-drivers/xf86-input-evdev/files/xf86-input-evdev-1.1.2-mips-syscalls.patch
new file mode 100644
index 000000000000..d1a6498e8fc7
--- /dev/null
+++ b/x11-drivers/xf86-input-evdev/files/xf86-input-evdev-1.1.2-mips-syscalls.patch
@@ -0,0 +1,24 @@
+diff -Naurp xf86-input-evdev-1.1.2.orig/src/inotify-syscalls.h xf86-input-evdev-1.1.2/src/inotify-syscalls.h
+--- xf86-input-evdev-1.1.2.orig/src/inotify-syscalls.h 2006-06-22 13:24:32.000000000 -0400
++++ xf86-input-evdev-1.1.2/src/inotify-syscalls.h 2006-06-22 13:44:19.000000000 -0400
+@@ -43,6 +43,20 @@
+ # define __NR_inotify_init 269
+ # define __NR_inotify_add_watch 270
+ # define __NR_inotify_rm_watch 271
++#elif defined (__mips__)
++# if _MIPS_SIM == _MIPS_SIM_ABI32
++# define __NR_inotify_init 4284
++# define __NR_inotify_add_watch 4285
++# define __NR_inotify_rm_watch 4286
++# elif _MIPS_SIM == _MIPS_SIM_NABI32
++# define __NR_inotify_init 6247
++# define __NR_inotify_add_watch 6248
++# define __NR_inotify_rm_watch 6249
++# elif _MIPS_SIM == _MIPS_SIM_ABI64
++# define __NR_inotify_init 5243
++# define __NR_inotify_add_watch 5244
++# define __NR_inotify_rm_watch 5245
++# endif
+ #else
+ # error "Unsupported architecture!"
+ #endif
diff --git a/x11-drivers/xf86-input-evdev/xf86-input-evdev-1.1.2-r1.ebuild b/x11-drivers/xf86-input-evdev/xf86-input-evdev-1.1.2-r1.ebuild
index 36982ea28bb9..957712ab1d89 100644
--- a/x11-drivers/xf86-input-evdev/xf86-input-evdev-1.1.2-r1.ebuild
+++ b/x11-drivers/xf86-input-evdev/xf86-input-evdev-1.1.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/xf86-input-evdev-1.1.2-r1.ebuild,v 1.1 2006/05/20 08:14:51 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/xf86-input-evdev-1.1.2-r1.ebuild,v 1.2 2006/06/22 21:50:01 geoman Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -15,4 +15,4 @@ DEPEND="${RDEPEND}
x11-proto/randrproto
x11-proto/xproto"
-PATCHES="${FILESDIR}/${PV}-CVS-20060520.patch"
+PATCHES="${FILESDIR}/${PV}-CVS-20060520.patch ${PN}-${PV}-mips-syscalls.patch"