summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/linuxsampler/ChangeLog10
-rw-r--r--media-sound/linuxsampler/files/digest-linuxsampler-0.3.32
-rw-r--r--media-sound/linuxsampler/files/linuxsampler-0.3.3-gcc4.patch25
-rw-r--r--media-sound/linuxsampler/linuxsampler-0.3.3.ebuild12
4 files changed, 45 insertions, 4 deletions
diff --git a/media-sound/linuxsampler/ChangeLog b/media-sound/linuxsampler/ChangeLog
index 4d8ed36b608d..4989527a407a 100644
--- a/media-sound/linuxsampler/ChangeLog
+++ b/media-sound/linuxsampler/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/linuxsampler
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/linuxsampler/ChangeLog,v 1.6 2005/09/10 15:54:21 flameeyes Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/linuxsampler/ChangeLog,v 1.7 2006/11/26 17:40:59 flameeyes Exp $
+
+ 26 Nov 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/linuxsampler-0.3.3-gcc4.patch, -linuxsampler-0.3.1.ebuild,
+ -linuxsampler-0.3.2.ebuild, linuxsampler-0.3.3.ebuild:
+ Add patch to fix ASM building with GCC 4.1. Thanks to Ben Cranston for
+ reporting and Danny van Dyk (kugelfang) for the patch.
10 Sep 2005; Diego Pettenò <flameeyes@gentoo.org>
linuxsampler-0.3.1.ebuild, linuxsampler-0.3.2.ebuild,
diff --git a/media-sound/linuxsampler/files/digest-linuxsampler-0.3.3 b/media-sound/linuxsampler/files/digest-linuxsampler-0.3.3
index 2752679518fe..edd56a36c329 100644
--- a/media-sound/linuxsampler/files/digest-linuxsampler-0.3.3
+++ b/media-sound/linuxsampler/files/digest-linuxsampler-0.3.3
@@ -1 +1,3 @@
MD5 8c7d4c97dd731774279006699ee1b10b linuxsampler-0.3.3.tar.bz2 450888
+RMD160 a23b6c1977073b417aab0e73defe57b107f6b858 linuxsampler-0.3.3.tar.bz2 450888
+SHA256 5aa9a5b0f13acee85ad7029e474b73081ac1c267f31085edcdd542f0c5193208 linuxsampler-0.3.3.tar.bz2 450888
diff --git a/media-sound/linuxsampler/files/linuxsampler-0.3.3-gcc4.patch b/media-sound/linuxsampler/files/linuxsampler-0.3.3-gcc4.patch
new file mode 100644
index 000000000000..2c823a04d61f
--- /dev/null
+++ b/media-sound/linuxsampler/files/linuxsampler-0.3.3-gcc4.patch
@@ -0,0 +1,25 @@
+Gentoo Bug #136666
+
+As input argument #3 is used as an address, fill it in with an address.
+
+Danny van Dyk <kugelfang@gentoo.org>
+--- src/engines/common/Resampler.h.orig 2006-11-26 17:57:48.000000000 +0100
++++ src/engines/common/Resampler.h 2006-11-26 17:58:08.000000000 +0100
+@@ -96,7 +96,7 @@
+ "movswl 6(%0,%%edi,2), %%edx # load sample 3\n\t"
+ "cvtsi2ss %%edx, %%xmm2 # convert to float\n\t"
+ "shufps $0x1b, %%xmm2, %%xmm2 # swap to correct order\n\t"
+- :: "r" (pSrc), "r" (Pos), "m" (__4f)
++ :: "r" (pSrc), "r" (Pos), "m" (&__4f)
+ : "%eax", "%edx", "%edi"
+ );
+ }
+@@ -137,7 +137,7 @@
+ "movswl 14(%0, %%edi,4), %%edx # load sample 3 (right)\n\t"
+ "cvtsi2ss %%edx, %%xmm3 # convert to float\n\t"
+ "shufps $0x1b, %%xmm3, %%xmm3 # swap to correct order\n\t"
+- :: "r" (pSrc), "r" (Pos), "m" (__4f)
++ :: "r" (pSrc), "r" (Pos), "m" (&__4f)
+ : "%eax", "%edx", "%edi"
+ );
+ }
diff --git a/media-sound/linuxsampler/linuxsampler-0.3.3.ebuild b/media-sound/linuxsampler/linuxsampler-0.3.3.ebuild
index d4f0d988cd4f..8d3a3730c4b4 100644
--- a/media-sound/linuxsampler/linuxsampler-0.3.3.ebuild
+++ b/media-sound/linuxsampler/linuxsampler-0.3.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/linuxsampler/linuxsampler-0.3.3.ebuild,v 1.2 2005/09/10 15:54:21 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/linuxsampler/linuxsampler-0.3.3.ebuild,v 1.3 2006/11/26 17:40:59 flameeyes Exp $
inherit eutils
@@ -19,8 +19,16 @@ RDEPEND="
DEPEND="${RDEPEND}"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-gcc4.patch"
+}
+
src_compile() {
econf || die "./configure failed"
+ ewarn "QA Warning: ${CATEGORY}/${PF} is forcing a non-parallel make."
emake -j1 || die "make failed"
}