summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-26 09:19:56 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-26 09:19:56 +0000
commite51201af111da3a7b18946f90d62cfc32651ab05 (patch)
tree85716666f1f9e4ebf2c1d41445b125fa1b75ea16 /xfce-extra
parentRequire <zlib-1.2.4, bug #311241 thank Kristian for report. (diff)
downloadgentoo-2-e51201af111da3a7b18946f90d62cfc32651ab05.tar.gz
gentoo-2-e51201af111da3a7b18946f90d62cfc32651ab05.tar.bz2
gentoo-2-e51201af111da3a7b18946f90d62cfc32651ab05.zip
Fix building with libpng14.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/thunar-vfs/ChangeLog6
-rw-r--r--xfce-extra/thunar-vfs/files/thunar-vfs-libpng14.patch11
-rw-r--r--xfce-extra/thunar-vfs/thunar-vfs-0_p20100324.ebuild4
3 files changed, 19 insertions, 2 deletions
diff --git a/xfce-extra/thunar-vfs/ChangeLog b/xfce-extra/thunar-vfs/ChangeLog
index 39611ea54a74..a00cdfb80893 100644
--- a/xfce-extra/thunar-vfs/ChangeLog
+++ b/xfce-extra/thunar-vfs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for xfce-extra/thunar-vfs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/thunar-vfs/ChangeLog,v 1.2 2010/03/25 11:31:34 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/thunar-vfs/ChangeLog,v 1.3 2010/03/26 09:19:56 ssuominen Exp $
+
+ 26 Mar 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +files/thunar-vfs-libpng14.patch, thunar-vfs-0_p20100324.ebuild:
+ Fix building with libpng14.
*thunar-vfs-0_p20100324 (24 Mar 2010)
diff --git a/xfce-extra/thunar-vfs/files/thunar-vfs-libpng14.patch b/xfce-extra/thunar-vfs/files/thunar-vfs-libpng14.patch
new file mode 100644
index 000000000000..63a6659ca7ae
--- /dev/null
+++ b/xfce-extra/thunar-vfs/files/thunar-vfs-libpng14.patch
@@ -0,0 +1,11 @@
+--- thunar-vfs/thunar-vfs-thumb.c
++++ thunar-vfs/thunar-vfs-thumb.c
+@@ -1169,7 +1169,7 @@
+ goto done0;
+
+ /* verify the png signature */
+- if (G_LIKELY (png_check_sig ((png_bytep) signature, sizeof (signature))))
++ if (G_LIKELY (!png_sig_cmp ((png_bytep) signature, 0, sizeof (signature))))
+ rewind (fp);
+ else
+ goto done0;
diff --git a/xfce-extra/thunar-vfs/thunar-vfs-0_p20100324.ebuild b/xfce-extra/thunar-vfs/thunar-vfs-0_p20100324.ebuild
index 022c2ed3d383..e6f0ebbe0b3a 100644
--- a/xfce-extra/thunar-vfs/thunar-vfs-0_p20100324.ebuild
+++ b/xfce-extra/thunar-vfs/thunar-vfs-0_p20100324.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/thunar-vfs/thunar-vfs-0_p20100324.ebuild,v 1.3 2010/03/25 11:32:47 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/thunar-vfs/thunar-vfs-0_p20100324.ebuild,v 1.4 2010/03/26 09:19:56 ssuominen Exp $
EAPI=2
EAUTORECONF=yes
@@ -53,6 +53,8 @@ pkg_setup() {
else
XFCONF="${XFCONF} --with-volume-manager=none"
fi
+
+ PATCHES=( "${FILESDIR}/${PN}-libpng14.patch" )
}
src_prepare() {