summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-04-14 21:48:33 +0000
committerMichał Górny <mgorny@gentoo.org>2015-04-14 21:48:33 +0000
commitc396258ae0439da93b57c1153d570937068b49a0 (patch)
tree76bcaba781089aaae371e8d14ca71fa0b61cd98e /xfce-extra
parentRemove old. (diff)
downloadgentoo-2-c396258ae0439da93b57c1153d570937068b49a0.tar.gz
gentoo-2-c396258ae0439da93b57c1153d570937068b49a0.tar.bz2
gentoo-2-c396258ae0439da93b57c1153d570937068b49a0.zip
Version bump. Fixes remembering 'Automatically Choose Network Device' option, bug #532194.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-netspeed-plugin/ChangeLog12
-rw-r--r--xfce-extra/xfce4-netspeed-plugin/xfce4-netspeed-plugin-0.3.1.ebuild36
2 files changed, 45 insertions, 3 deletions
diff --git a/xfce-extra/xfce4-netspeed-plugin/ChangeLog b/xfce-extra/xfce4-netspeed-plugin/ChangeLog
index b7f32ef4dc44..04c98cd226ab 100644
--- a/xfce-extra/xfce4-netspeed-plugin/ChangeLog
+++ b/xfce-extra/xfce4-netspeed-plugin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for xfce-extra/xfce4-netspeed-plugin
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-netspeed-plugin/ChangeLog,v 1.12 2013/02/20 11:40:20 ssuominen Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-netspeed-plugin/ChangeLog,v 1.13 2015/04/14 21:48:33 mgorny Exp $
+
+*xfce4-netspeed-plugin-0.3.1 (14 Apr 2015)
+
+ 14 Apr 2015; Michał Górny <mgorny@gentoo.org>
+ +xfce4-netspeed-plugin-0.3.1.ebuild:
+ Version bump. Fixes remembering 'Automatically Choose Network Device' option,
+ bug #532194.
20 Feb 2013; Samuli Suominen <ssuominen@gentoo.org>
-xfce4-netspeed-plugin-0.1.ebuild:
@@ -56,4 +63,3 @@
25 Nov 2011; Samuli Suominen <ssuominen@gentoo.org>
+xfce4-netspeed-plugin-0.1.ebuild:
Initial commit.
-
diff --git a/xfce-extra/xfce4-netspeed-plugin/xfce4-netspeed-plugin-0.3.1.ebuild b/xfce-extra/xfce4-netspeed-plugin/xfce4-netspeed-plugin-0.3.1.ebuild
new file mode 100644
index 000000000000..bcbc7dc37ec6
--- /dev/null
+++ b/xfce-extra/xfce4-netspeed-plugin/xfce4-netspeed-plugin-0.3.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-netspeed-plugin/xfce4-netspeed-plugin-0.3.1.ebuild,v 1.1 2015/04/14 21:48:33 mgorny Exp $
+
+EAPI=5
+inherit multilib xfconf
+
+DESCRIPTION="A network transfer rate monitoring panel plug-in, inspired by Gnome's Netspeed applet"
+HOMEPAGE="http://code.google.com/p/xfce4-netspeed-plugin/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2:=
+ >=gnome-base/libgtop-2:=
+ x11-libs/gtk+:2=
+ >=xfce-base/libxfce4ui-4.8:=
+ >=xfce-base/libxfce4util-4.8:=
+ >=xfce-base/xfce4-panel-4.8:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ XFCONF=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ )
+
+ DOCS=( AUTHORS README )
+}