summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-10-28 15:09:53 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-10-28 15:09:53 +0000
commitb313be51a2cafbfd934c10cb6df15e975fe50800 (patch)
treeff8338e57f3aa6015bf662277b1915a3cdd49f22 /xfce-extra
parentFix variable name (diff)
downloadgentoo-2-b313be51a2cafbfd934c10cb6df15e975fe50800.tar.gz
gentoo-2-b313be51a2cafbfd934c10cb6df15e975fe50800.tar.bz2
gentoo-2-b313be51a2cafbfd934c10cb6df15e975fe50800.zip
Version bump.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-volumed/ChangeLog8
-rw-r--r--xfce-extra/xfce4-volumed/files/xfce4-volumed-0.1.5-libnotify.patch15
-rw-r--r--xfce-extra/xfce4-volumed/xfce4-volumed-0.1.5.ebuild31
3 files changed, 53 insertions, 1 deletions
diff --git a/xfce-extra/xfce4-volumed/ChangeLog b/xfce-extra/xfce4-volumed/ChangeLog
index 8516fcda5e05..0781c06676c7 100644
--- a/xfce-extra/xfce4-volumed/ChangeLog
+++ b/xfce-extra/xfce4-volumed/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/xfce4-volumed
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-volumed/ChangeLog,v 1.3 2009/10/03 14:53:04 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-volumed/ChangeLog,v 1.4 2009/10/28 15:09:52 ssuominen Exp $
+
+*xfce4-volumed-0.1.5 (28 Oct 2009)
+
+ 28 Oct 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-volumed-0.1.5.ebuild, +files/xfce4-volumed-0.1.5-libnotify.patch:
+ Version bump.
03 Oct 2009; Samuli Suominen <ssuominen@gentoo.org>
xfce4-volumed-0.1.4.ebuild:
diff --git a/xfce-extra/xfce4-volumed/files/xfce4-volumed-0.1.5-libnotify.patch b/xfce-extra/xfce4-volumed/files/xfce4-volumed-0.1.5-libnotify.patch
new file mode 100644
index 000000000000..05291b8ead6c
--- /dev/null
+++ b/xfce-extra/xfce4-volumed/files/xfce4-volumed-0.1.5-libnotify.patch
@@ -0,0 +1,15 @@
+diff -ur xfce4-volumed-0.1.5.orig/src/main.c xfce4-volumed-0.1.5/src/main.c
+--- xfce4-volumed-0.1.5.orig/src/main.c 2009-10-28 01:29:01.000000000 +0200
++++ xfce4-volumed-0.1.5/src/main.c 2009-10-28 18:08:00.000000000 +0200
+@@ -111,8 +111,10 @@
+ i->keyMute = NULL;
+ #endif
+ i->kss = NULL;
++ #ifdef HAVE_LIBNOTIFY
+ i->sync_notifications = FALSE;
+- i->notification = NULL;
++ i->notification = NULL;
++ #endif
+ }
+
+ gint
diff --git a/xfce-extra/xfce4-volumed/xfce4-volumed-0.1.5.ebuild b/xfce-extra/xfce4-volumed/xfce4-volumed-0.1.5.ebuild
new file mode 100644
index 000000000000..d8c2281347cd
--- /dev/null
+++ b/xfce-extra/xfce4-volumed/xfce4-volumed-0.1.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-volumed/xfce4-volumed-0.1.5.ebuild,v 1.1 2009/10/28 15:09:52 ssuominen Exp $
+
+EAPI=2
+inherit xfconf
+
+DESCRIPTION="Daemon to control volume up/down and mute keys"
+HOMEPAGE="https://launchpad.net/xfce4-volumed"
+SRC_URI="mirror://xfce/src/apps/${PN}/0.1/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug libnotify"
+
+RDEPEND="xfce-base/xfconf
+ >=x11-libs/xcb-util-0.3.5
+ media-libs/gstreamer:0.10
+ media-libs/gst-plugins-base:0.10
+ libnotify? ( x11-libs/libnotify )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ XFCONF="--disable-dependency-tracking
+ $(use_enable debug)
+ $(use_with libnotify)"
+ DOCS="AUTHORS ChangeLog README THANKS"
+ PATCHES=( "${FILESDIR}/${P}-libnotify.patch" )
+}