summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-02-15 13:10:38 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-02-15 13:10:38 +0000
commitaab97427fc6470ff0bebadebb3386de184d26a57 (patch)
treef69451a1cfc43963c8f937227f083d2bb66cc41b /xfce-extra
parentadded missing ~x86-interix keywords (diff)
downloadgentoo-2-aab97427fc6470ff0bebadebb3386de184d26a57.tar.gz
gentoo-2-aab97427fc6470ff0bebadebb3386de184d26a57.tar.bz2
gentoo-2-aab97427fc6470ff0bebadebb3386de184d26a57.zip
Port xfce4-xkb-plugin to libxklavier-5.0 API.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-xkb-plugin/ChangeLog7
-rw-r--r--xfce-extra/xfce4-xkb-plugin/files/xfce4-xkb-plugin-0.5.3.3-libxklavier-5.patch30
-rw-r--r--xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.5.3.3-r1.ebuild9
3 files changed, 43 insertions, 3 deletions
diff --git a/xfce-extra/xfce4-xkb-plugin/ChangeLog b/xfce-extra/xfce4-xkb-plugin/ChangeLog
index e2e274b567be..d21fb932d8b2 100644
--- a/xfce-extra/xfce4-xkb-plugin/ChangeLog
+++ b/xfce-extra/xfce4-xkb-plugin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-extra/xfce4-xkb-plugin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-xkb-plugin/ChangeLog,v 1.18 2010/01/18 00:34:55 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-xkb-plugin/ChangeLog,v 1.19 2010/02/15 13:10:37 ssuominen Exp $
+
+ 15 Feb 2010; Samuli Suominen <ssuominen@gentoo.org>
+ xfce4-xkb-plugin-0.5.3.3-r1.ebuild,
+ +files/xfce4-xkb-plugin-0.5.3.3-libxklavier-5.patch:
+ Port xfce4-xkb-plugin to libxklavier-5.0 API.
18 Jan 2010; Jeroen Roovers <jer@gentoo.org>
xfce4-xkb-plugin-0.5.3.3-r1.ebuild:
diff --git a/xfce-extra/xfce4-xkb-plugin/files/xfce4-xkb-plugin-0.5.3.3-libxklavier-5.patch b/xfce-extra/xfce4-xkb-plugin/files/xfce4-xkb-plugin-0.5.3.3-libxklavier-5.patch
new file mode 100644
index 000000000000..521f55d82f40
--- /dev/null
+++ b/xfce-extra/xfce4-xkb-plugin/files/xfce4-xkb-plugin-0.5.3.3-libxklavier-5.patch
@@ -0,0 +1,30 @@
+diff -ur xfce4-xkb-plugin-0.5.3.3.orig/panel-plugin/xkb-config.c xfce4-xkb-plugin-0.5.3.3/panel-plugin/xkb-config.c
+--- xfce4-xkb-plugin-0.5.3.3.orig/panel-plugin/xkb-config.c 2009-03-06 15:16:03.000000000 +0200
++++ xfce4-xkb-plugin-0.5.3.3/panel-plugin/xkb-config.c 2010-02-15 15:15:21.000000000 +0200
+@@ -150,7 +150,7 @@
+ config->application_map = g_hash_table_new (g_direct_hash, NULL);
+
+ registry = xkl_config_registry_get_instance (config->engine);
+- xkl_config_registry_load (registry);
++ xkl_config_registry_load (registry, FALSE);
+
+ config_item = xkl_config_item_new ();
+
+@@ -214,7 +214,7 @@
+
+ gdk_window_remove_filter (NULL, (GdkFilterFunc) handle_xevent, NULL);
+
+- xkl_engine_stop_listen (config->engine);
++ xkl_engine_stop_listen (config->engine, XKLL_TRACK_KEYBOARD_STATE);
+ }
+
+ gint
+@@ -547,7 +547,7 @@
+ if (!config) return NULL;
+
+ registry = xkl_config_registry_get_instance (config->engine);
+- xkl_config_registry_load (registry);
++ xkl_config_registry_load (registry, FALSE);
+
+ return registry;
+ }
diff --git a/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.5.3.3-r1.ebuild b/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.5.3.3-r1.ebuild
index 780f1f319bab..7aeec207379f 100644
--- a/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.5.3.3-r1.ebuild
+++ b/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.5.3.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.5.3.3-r1.ebuild,v 1.10 2010/01/18 00:34:55 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.5.3.3-r1.ebuild,v 1.11 2010/02/15 13:10:37 ssuominen Exp $
EAPI=2
inherit xfconf
@@ -30,5 +30,10 @@ pkg_setup() {
DOCS="AUTHORS ChangeLog README"
XFCONF="--disable-dependency-tracking
$(use_enable debug)"
- PATCHES=( "${FILESDIR}/${P}-libxklavier.patch" )
+
+ if has_version ">=x11-libs/libxklavier-5"; then
+ PATCHES=( "${FILESDIR}/${P}-libxklavier-5.patch" )
+ else
+ PATCHES=( "${FILESDIR}/${P}-libxklavier.patch" )
+ fi
}