summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-12-02 17:08:37 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-12-02 17:08:37 +0000
commit9d64d7641c49fdc6acdeda9b4afa0fe219f144c9 (patch)
tree094b28a84e06f34c6830a856415ca186dd626067 /xfce-extra
parentfixed #339497, doesnt respect LDFLAGS (diff)
downloadgentoo-2-9d64d7641c49fdc6acdeda9b4afa0fe219f144c9.tar.gz
gentoo-2-9d64d7641c49fdc6acdeda9b4afa0fe219f144c9.tar.bz2
gentoo-2-9d64d7641c49fdc6acdeda9b4afa0fe219f144c9.zip
Upstream patch to fix loading of icons with path (#6895).
(Portage version: 2.2.0_alpha6/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-notifyd/ChangeLog9
-rw-r--r--xfce-extra/xfce4-notifyd/files/xfce4-notifyd-0.2.0-load_icon_with_path.patch34
-rw-r--r--xfce-extra/xfce4-notifyd/xfce4-notifyd-0.2.0-r1.ebuild39
3 files changed, 81 insertions, 1 deletions
diff --git a/xfce-extra/xfce4-notifyd/ChangeLog b/xfce-extra/xfce4-notifyd/ChangeLog
index 3cf042b605fa..38f04714d5ef 100644
--- a/xfce-extra/xfce4-notifyd/ChangeLog
+++ b/xfce-extra/xfce4-notifyd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for xfce-extra/xfce4-notifyd
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-notifyd/ChangeLog,v 1.6 2010/11/28 11:30:40 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-notifyd/ChangeLog,v 1.7 2010/12/02 17:08:36 ssuominen Exp $
+
+*xfce4-notifyd-0.2.0-r1 (02 Dec 2010)
+
+ 02 Dec 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-notifyd-0.2.0-r1.ebuild,
+ +files/xfce4-notifyd-0.2.0-load_icon_with_path.patch:
+ Upstream patch to fix loading of icons with path (#6895).
*xfce4-notifyd-0.2.0 (28 Nov 2010)
diff --git a/xfce-extra/xfce4-notifyd/files/xfce4-notifyd-0.2.0-load_icon_with_path.patch b/xfce-extra/xfce4-notifyd/files/xfce4-notifyd-0.2.0-load_icon_with_path.patch
new file mode 100644
index 000000000000..b8ba67a42238
--- /dev/null
+++ b/xfce-extra/xfce4-notifyd/files/xfce4-notifyd-0.2.0-load_icon_with_path.patch
@@ -0,0 +1,34 @@
+From 2529fb74ca78c52e8c66620e10ad275373d988bb Mon Sep 17 00:00:00 2001
+From: Yves-Alexis Perez <corsac@debian.org>
+Date: Mon, 29 Nov 2010 22:39:20 +0000
+Subject: Fix icon loading with path (bug #6895).
+
+---
+diff --git a/xfce4-notifyd/xfce-notify-window.c b/xfce4-notifyd/xfce-notify-window.c
+index d10ef1c..a7c7289 100644
+--- a/xfce4-notifyd/xfce-notify-window.c
++++ b/xfce4-notifyd/xfce-notify-window.c
+@@ -1041,7 +1041,11 @@ xfce_notify_window_set_icon_name(XfceNotifyWindow *window,
+ GdkPixbuf *pix;
+
+ gtk_icon_size_lookup(GTK_ICON_SIZE_DIALOG, &w, &h);
+- pix = gtk_icon_theme_load_icon(gtk_icon_theme_get_default(),
++
++ if(g_path_is_absolute(icon_name))
++ pix = gdk_pixbuf_new_from_file_at_size(icon_name, w, h, NULL);
++ else
++ pix = gtk_icon_theme_load_icon(gtk_icon_theme_get_default(),
+ icon_name,
+ w,
+ GTK_ICON_LOOKUP_FORCE_SIZE,
+@@ -1056,7 +1060,7 @@ xfce_notify_window_set_icon_name(XfceNotifyWindow *window,
+ }
+
+ if(!icon_set) {
+- gtk_image_set_from_pixbuf(GTK_IMAGE(window->icon), NULL);
++ gtk_image_clear(GTK_IMAGE(window->icon));
+ gtk_widget_hide(window->icon_box);
+ }
+
+--
+cgit v0.8.3.4
diff --git a/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.2.0-r1.ebuild b/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..ca2cfd471c28
--- /dev/null
+++ b/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.2.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.2.0-r1.ebuild,v 1.1 2010/12/02 17:08:36 ssuominen Exp $
+
+EAPI=3
+inherit xfconf
+
+DESCRIPTION="A simple notification daemon for Xfce4"
+HOMEPAGE="http://goodies.xfce.org/projects/applications/xfce4-notifyd"
+SRC_URI="mirror://xfce/src/apps/${PN}/0.2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="xfce-base/libxfce4util
+ xfce-base/libxfce4ui
+ xfce-base/xfconf
+ >=x11-libs/gtk+-2.14:2
+ >=sys-apps/dbus-1.4.0
+ >=dev-libs/dbus-glib-0.88
+ !<x11-libs/libnotify-0.4.5
+ !x11-misc/notification-daemon"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+pkg_setup() {
+ PATCHES=( "${FILESDIR}"/${P}-load_icon_with_path.patch )
+
+ XFCONF=(
+ --disable-dependency-tracking
+ $(xfconf_use_debug)
+ )
+
+ DOCS="AUTHORS NEWS README TODO"
+}