summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-06-13 03:13:11 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-06-13 03:13:11 +0000
commit873ca42ef0207bf3d9ae668a9bc3619db59dca42 (patch)
tree5bb561a86ff3b03bb81321997a959899eb7f6117 /xfce-extra
parentAdd upstream patch for buggy chsh behavior, bug 271521 (diff)
downloadgentoo-2-873ca42ef0207bf3d9ae668a9bc3619db59dca42.tar.gz
gentoo-2-873ca42ef0207bf3d9ae668a9bc3619db59dca42.tar.bz2
gentoo-2-873ca42ef0207bf3d9ae668a9bc3619db59dca42.zip
Add small patch to fix exo-mount on localized systems, patch from ALTLinux, bug 271441
(Portage version: 2.1.6.13/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/exo/ChangeLog10
-rw-r--r--xfce-extra/exo/exo-0.3.101-r1.ebuild (renamed from xfce-extra/exo/exo-0.3.101.ebuild)4
-rw-r--r--xfce-extra/exo/files/exo-0.3.101-iocharset.patch79
3 files changed, 91 insertions, 2 deletions
diff --git a/xfce-extra/exo/ChangeLog b/xfce-extra/exo/ChangeLog
index bce1602300ef..9489fb60527c 100644
--- a/xfce-extra/exo/ChangeLog
+++ b/xfce-extra/exo/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for xfce-extra/exo
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/exo/ChangeLog,v 1.85 2009/06/10 07:27:09 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/exo/ChangeLog,v 1.86 2009/06/13 03:13:10 darkside Exp $
+
+*exo-0.3.101-r1 (13 Jun 2009)
+
+ 13 Jun 2009; Jeremy Olexa <darkside@gentoo.org>
+ +files/exo-0.3.101-iocharset.patch, -exo-0.3.101.ebuild,
+ +exo-0.3.101-r1.ebuild:
+ Add small patch to fix exo-mount on localized systems, patch from ALTLinux,
+ bug 271441
10 Jun 2009; Christian Faulhammer <fauli@gentoo.org> exo-0.3.101.ebuild:
stable x86, bug 265587
diff --git a/xfce-extra/exo/exo-0.3.101.ebuild b/xfce-extra/exo/exo-0.3.101-r1.ebuild
index 53e590d1710b..db5d5b160c0b 100644
--- a/xfce-extra/exo/exo-0.3.101.ebuild
+++ b/xfce-extra/exo/exo-0.3.101-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/exo/exo-0.3.101.ebuild,v 1.4 2009/06/10 07:27:09 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/exo/exo-0.3.101-r1.ebuild,v 1.1 2009/06/13 03:13:10 darkside Exp $
EAPI="1"
@@ -26,6 +26,8 @@ DEPEND="${RDEPEND}
dev-util/intltool
doc? ( dev-util/gtk-doc )"
+XFCE4_PATCHES="${FILESDIR}/exo-0.3.101-iocharset.patch"
+
pkg_setup() {
XFCE_CONFIG+=" $(use_enable doc gtk-doc) $(use_enable hal)
$(use_enable libnotify notifications) $(use_enable python)"
diff --git a/xfce-extra/exo/files/exo-0.3.101-iocharset.patch b/xfce-extra/exo/files/exo-0.3.101-iocharset.patch
new file mode 100644
index 000000000000..a667f116652b
--- /dev/null
+++ b/xfce-extra/exo/files/exo-0.3.101-iocharset.patch
@@ -0,0 +1,79 @@
+diff --git a/exo-mount/exo-mount-hal.c b/exo-mount/exo-mount-hal.c
+index 791a536..4b130c3 100644
+--- a/exo-mount/exo-mount-hal.c
++++ b/exo-mount/exo-mount-hal.c
+@@ -34,6 +34,8 @@
+ #include <unistd.h>
+ #endif
+
++#include <langinfo.h>
++
+ #include <libhal-storage.h>
+
+ #include <exo-hal/exo-hal.h>
+@@ -616,6 +618,30 @@ oom: g_set_error (error, G_FILE_ERROR, G_FILE_ERROR_NOMEM, g_strerror (ENOMEM))
+
+
+ /**
++ * exo_mount_hal_iocharset:
++ *
++ * Determines the preferred iocharset for filesystems
++ * that support it.
++ *
++ * Return value: iocharset string or %NULL if none.
++ **/
++static const gchar*
++exo_mount_hal_iocharset ()
++{
++ const gchar* cs = g_getenv("EXO_MOUNT_IOCHARSET");
++ if (cs != NULL)
++ return cs;
++
++ const char* codeset = nl_langinfo (CODESET);
++ if (codeset && !strcmp (codeset, "UTF-8"))
++ return "utf8";
++
++ return NULL;
++}
++
++
++
++/**
+ * exo_mount_hal_device_mount:
+ * @device : an #ExoMountHalDevice.
+ * @error : return location for errors or %NULL.
+@@ -676,6 +702,12 @@ exo_mount_hal_device_mount (ExoMountHalDevice *device,
+ /* however this one is FreeBSD specific */
+ options[n++] = g_strdup ("longnames");
+ }
++ else if (strcmp (device->fsoptions[m], "iocharset=") == 0)
++ {
++ const gchar* iocharset = exo_mount_hal_iocharset();
++ if (iocharset != NULL)
++ options[n++] = g_strdup_printf ("iocharset=%s", iocharset);
++ }
+ }
+ }
+
+diff --git a/exo-mount/main.c b/exo-mount/main.c
+index 80eae1d..f442019 100644
+--- a/exo-mount/main.c
++++ b/exo-mount/main.c
+@@ -39,6 +39,8 @@
+ #include <string.h>
+ #endif
+
++#include <locale.h>
++
+ #include <glib/gstdio.h>
+
+ #include <exo-hal/exo-hal.h>
+@@ -97,6 +99,8 @@ main (int argc, char **argv)
+ /* initialize the i18n support */
+ xfce_textdomain (GETTEXT_PACKAGE, PACKAGE_LOCALE_DIR, "UTF-8");
+
++ setlocale(LC_CTYPE, "");
++
+ /* initialize GTK+ */
+ if (!gtk_init_with_args (&argc, &argv, "Xfce mount", entries, GETTEXT_PACKAGE, &err))
+ {