summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-12-07 15:43:53 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-12-07 15:43:53 +0000
commit82de52c41b0ac6e3983326cf74e990451c49483b (patch)
tree7010fe82518d9ff477757c334f79e8dab46b1771 /xfce-extra
parentinclude the USE=debug punt in the changelog message (diff)
downloadgentoo-2-82de52c41b0ac6e3983326cf74e990451c49483b.tar.gz
gentoo-2-82de52c41b0ac6e3983326cf74e990451c49483b.tar.bz2
gentoo-2-82de52c41b0ac6e3983326cf74e990451c49483b.zip
Explicitely link against -lm (as reported by Jeremy Olexa). Remove USE="debug" because the package is still using libxfcegui4 and doesn't pass with -DXFCE_DISABLE_DEPRECATED flag.
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-diskperf-plugin/ChangeLog9
-rw-r--r--xfce-extra/xfce4-diskperf-plugin/files/xfce4-diskperf-plugin-2.3.0-underlinking.patch21
-rw-r--r--xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.3.0.ebuild7
3 files changed, 33 insertions, 4 deletions
diff --git a/xfce-extra/xfce4-diskperf-plugin/ChangeLog b/xfce-extra/xfce4-diskperf-plugin/ChangeLog
index 32d72adbf976..3a07e1f8a4cb 100644
--- a/xfce-extra/xfce4-diskperf-plugin/ChangeLog
+++ b/xfce-extra/xfce4-diskperf-plugin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for xfce-extra/xfce4-diskperf-plugin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-diskperf-plugin/ChangeLog,v 1.10 2011/04/23 17:35:17 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-diskperf-plugin/ChangeLog,v 1.11 2011/12/07 15:43:53 ssuominen Exp $
+
+ 07 Dec 2011; Samuli Suominen <ssuominen@gentoo.org>
+ xfce4-diskperf-plugin-2.3.0.ebuild,
+ +files/xfce4-diskperf-plugin-2.3.0-underlinking.patch:
+ Explicitely link against -lm (as reported by Jeremy Olexa). Remove
+ USE="debug" because the package is still using libxfcegui4 and doesn't pass
+ with -DXFCE_DISABLE_DEPRECATED flag.
23 Apr 2011; Samuli Suominen <ssuominen@gentoo.org>
xfce4-diskperf-plugin-2.3.0.ebuild:
diff --git a/xfce-extra/xfce4-diskperf-plugin/files/xfce4-diskperf-plugin-2.3.0-underlinking.patch b/xfce-extra/xfce4-diskperf-plugin/files/xfce4-diskperf-plugin-2.3.0-underlinking.patch
new file mode 100644
index 000000000000..35a1209c509e
--- /dev/null
+++ b/xfce-extra/xfce4-diskperf-plugin/files/xfce4-diskperf-plugin-2.3.0-underlinking.patch
@@ -0,0 +1,21 @@
+http://bugzilla.xfce.org/show_bug.cgi?id=7982
+
+panel-plugin/main.c is using function round, so explicitely link against -lm. see below.
+
+/path/to/ld: xfce4_diskperf_plugin-main.o: undefined reference to symbol 'round@@GLIBC_2.2.5'
+/path/to/ld: note: 'round@@GLIBC_2.2.5' is defined in DSO /lib64/libm.so.6 so try adding it to the linker command line
+/lib64/libm.so.6: could not read symbols: Invalid operation
+collect2: ld returned 1 exit status
+
+--- panel-plugin/Makefile.am
++++ panel-plugin/Makefile.am
+@@ -25,7 +25,8 @@
+
+ xfce4_diskperf_plugin_LDADD= \
+ $(LIBXFCE4PANEL_LIBS) \
+- $(LIBXFCEGUI4_LIBS)
++ $(LIBXFCEGUI4_LIBS) \
++ -lm
+
+ #
+ # Desktop file
diff --git a/xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.3.0.ebuild b/xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.3.0.ebuild
index 4bcc5e7d2d0d..5236e08bc793 100644
--- a/xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.3.0.ebuild
+++ b/xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.3.0.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.3.0.ebuild,v 1.8 2011/05/19 21:30:45 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.3.0.ebuild,v 1.9 2011/12/07 15:43:53 ssuominen Exp $
EAPI=4
+EAUTORECONF=yes
inherit xfconf
DESCRIPTION="Xfce's disk usage and performance panel plugin"
@@ -12,7 +13,7 @@ SRC_URI="mirror://xfce/src/panel-plugins/${PN}/2.3/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~ia64-linux ~x86-linux"
-IUSE="debug"
+IUSE=""
RDEPEND=">=xfce-base/libxfcegui4-4.8
>=xfce-base/xfce4-panel-4.8"
@@ -21,6 +22,6 @@ DEPEND="${RDEPEND}
dev-util/intltool"
pkg_setup() {
- XFCONF=( $(xfconf_use_debug) )
+ PATCHES=( "${FILESDIR}"/${P}-underlinking.patch )
DOCS=( AUTHORS ChangeLog NEWS README )
}