summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-06-16 14:52:16 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-06-16 14:52:16 +0000
commit7fe8d0c2e494a7818cf0621a9f60137ec0d02b1e (patch)
treea2412e2211ee9a73f4f8073f70e2e70fcc59367b /xfce-extra
parentMask sys-kernel/cluster-sources for removal. (diff)
downloadgentoo-2-7fe8d0c2e494a7818cf0621a9f60137ec0d02b1e.tar.gz
gentoo-2-7fe8d0c2e494a7818cf0621a9f60137ec0d02b1e.tar.bz2
gentoo-2-7fe8d0c2e494a7818cf0621a9f60137ec0d02b1e.zip
Fix building with net-libs/gnutls >= 3 wrt #421407 by Diego Elio Pettenò
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-mailwatch-plugin/ChangeLog7
-rw-r--r--xfce-extra/xfce4-mailwatch-plugin/files/xfce4-mailwatch-plugin-1.1.0-gnutls-3.patch16
-rw-r--r--xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.1.0.ebuild5
3 files changed, 25 insertions, 3 deletions
diff --git a/xfce-extra/xfce4-mailwatch-plugin/ChangeLog b/xfce-extra/xfce4-mailwatch-plugin/ChangeLog
index 8a620801b3e1..50a34b68274d 100644
--- a/xfce-extra/xfce4-mailwatch-plugin/ChangeLog
+++ b/xfce-extra/xfce4-mailwatch-plugin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-extra/xfce4-mailwatch-plugin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-mailwatch-plugin/ChangeLog,v 1.6 2012/05/05 07:17:17 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-mailwatch-plugin/ChangeLog,v 1.7 2012/06/16 14:52:16 ssuominen Exp $
+
+ 16 Jun 2012; Samuli Suominen <ssuominen@gentoo.org>
+ xfce4-mailwatch-plugin-1.1.0.ebuild,
+ +files/xfce4-mailwatch-plugin-1.1.0-gnutls-3.patch:
+ Fix building with net-libs/gnutls >= 3 wrt #421407 by Diego Elio Pettenò
05 May 2012; Michał Górny <mgorny@gentoo.org>
xfce4-mailwatch-plugin-1.1.0.ebuild:
diff --git a/xfce-extra/xfce4-mailwatch-plugin/files/xfce4-mailwatch-plugin-1.1.0-gnutls-3.patch b/xfce-extra/xfce4-mailwatch-plugin/files/xfce4-mailwatch-plugin-1.1.0-gnutls-3.patch
new file mode 100644
index 000000000000..6737538d367a
--- /dev/null
+++ b/xfce-extra/xfce4-mailwatch-plugin/files/xfce4-mailwatch-plugin-1.1.0-gnutls-3.patch
@@ -0,0 +1,16 @@
+http://bugs.gentoo.org/421407
+http://bugzilla.xfce.org/show_bug.cgi?id=7998
+
+--- libmailwatch-core/mailwatch-net-conn.c
++++ libmailwatch-core/mailwatch-net-conn.c
+@@ -621,8 +621,10 @@
+ net_conn->gt_creds);
+ gnutls_transport_set_ptr(net_conn->gt_session,
+ (gnutls_transport_ptr_t)net_conn->fd);
++#if GNUTLS_VERSION_MAJOR == 2 && GNUTLS_VERSION_MINOR < 12
+ if(fcntl(net_conn->fd, F_GETFL) & O_NONBLOCK)
+ gnutls_transport_set_lowat(net_conn->gt_session, 0);
++#endif
+
+ if(!xfce_mailwatch_net_conn_tls_handshake(net_conn, error)) {
+ #if 0
diff --git a/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.1.0.ebuild b/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.1.0.ebuild
index f4eeac0269bb..0825f2f53ac9 100644
--- a/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.1.0.ebuild
+++ b/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.1.0.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.1.0.ebuild,v 1.8 2012/05/05 07:17:17 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.1.0.ebuild,v 1.9 2012/06/16 14:52:16 ssuominen Exp $
EAPI=4
EAUTORECONF=yes
inherit multilib xfconf
-DESCRIPTION="Mail notification panel plugin"
+DESCRIPTION="An mail notification panel plug-in for the Xfce desktop environment"
HOMEPAGE="http://spuriousinterrupt.org/projects/mailwatch"
SRC_URI="mirror://gentoo/${P}.tar.bz2"
@@ -31,6 +31,7 @@ pkg_setup() {
"${FILESDIR}"/${P}-no-ssl.patch
"${FILESDIR}"/${P}-link_to_libxfcegui4.patch
"${FILESDIR}"/${P}-link_to_libgcrypt.patch
+ "${FILESDIR}"/${P}-gnutls-3.patch
)
XFCONF=(