summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-05-07 18:44:52 +0000
committerMichał Górny <mgorny@gentoo.org>2015-05-07 18:44:52 +0000
commit7b72dc3c19a87f3f81d3d17cb23d56d24f3a15b6 (patch)
tree943d99ed3e2308f93c24eef263eeb6ca40f313e8 /xfce-extra
parentSome more defaults needed by mutter for being able to 'emerge gnome' (#547300) (diff)
downloadgentoo-2-7b72dc3c19a87f3f81d3d17cb23d56d24f3a15b6.tar.gz
gentoo-2-7b72dc3c19a87f3f81d3d17cb23d56d24f3a15b6.tar.bz2
gentoo-2-7b72dc3c19a87f3f81d3d17cb23d56d24f3a15b6.zip
Version bump, with few minor enhancements and bugfixes. Bug #548720.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-screenshooter/ChangeLog11
-rw-r--r--xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.8.2.ebuild41
2 files changed, 49 insertions, 3 deletions
diff --git a/xfce-extra/xfce4-screenshooter/ChangeLog b/xfce-extra/xfce4-screenshooter/ChangeLog
index 64c298bc53a7..e61a068c223a 100644
--- a/xfce-extra/xfce4-screenshooter/ChangeLog
+++ b/xfce-extra/xfce4-screenshooter/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/xfce4-screenshooter
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-screenshooter/ChangeLog,v 1.102 2013/04/25 08:52:42 ssuominen Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-screenshooter/ChangeLog,v 1.103 2015/05/07 18:44:52 mgorny Exp $
+
+*xfce4-screenshooter-1.8.2 (07 May 2015)
+
+ 07 May 2015; Michał Górny <mgorny@gentoo.org>
+ +xfce4-screenshooter-1.8.2.ebuild:
+ Version bump, with few minor enhancements and bugfixes. Bug #548720.
25 Apr 2013; Samuli Suominen <ssuominen@gentoo.org>
xfce4-screenshooter-1.8.1.ebuild:
@@ -448,4 +454,3 @@
21 Jan 2007; Joshua Nichols <nichoj@gentoo.org> +metadata.xml,
+xfce4-screenshooter-1.0.0.ebuild:
Initial import. Ebuild provided by Samuli Suominen <sasuomin@uusikaupunki.fi>.
-
diff --git a/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.8.2.ebuild b/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.8.2.ebuild
new file mode 100644
index 000000000000..6580ebb25534
--- /dev/null
+++ b/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.8.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.8.2.ebuild,v 1.1 2015/05/07 18:44:52 mgorny Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Xfce4 screenshooter application and panel plugin"
+HOMEPAGE="http://goodies.xfce.org/projects/applications/xfce4-screenshooter"
+SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.16:=
+ >=net-libs/libsoup-2.26:=
+ >=x11-libs/gdk-pixbuf-2.16:=
+ >=x11-libs/gtk+-2.16:2=
+ dev-libs/libxml2:=
+ x11-libs/libX11:=
+ x11-libs/libXext:=
+ x11-libs/libXfixes:=
+ >=xfce-base/exo-0.6:=
+ >=xfce-base/xfce4-panel-4.8:=
+ >=xfce-base/libxfce4util-4.8:=
+ >=xfce-base/libxfce4ui-4.8:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(xfconf_use_debug)
+ --enable-xfixes
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+}