summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-04-12 19:37:48 +0000
committerMichał Górny <mgorny@gentoo.org>2015-04-12 19:37:48 +0000
commit4d7a22c31a170b232ed4a22da8f4caf502e906a2 (patch)
tree591716f5e591edd8e36d56275b38ded60b9e2556 /xfce-extra
parentVersion bump with minor fixes. (diff)
downloadgentoo-2-4d7a22c31a170b232ed4a22da8f4caf502e906a2.tar.gz
gentoo-2-4d7a22c31a170b232ed4a22da8f4caf502e906a2.tar.bz2
gentoo-2-4d7a22c31a170b232ed4a22da8f4caf502e906a2.zip
Version bump with minor fixes.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-smartbookmark-plugin/ChangeLog10
-rw-r--r--xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.6.ebuild38
2 files changed, 46 insertions, 2 deletions
diff --git a/xfce-extra/xfce4-smartbookmark-plugin/ChangeLog b/xfce-extra/xfce4-smartbookmark-plugin/ChangeLog
index 13b2e38b96f1..42df3f85fe2e 100644
--- a/xfce-extra/xfce4-smartbookmark-plugin/ChangeLog
+++ b/xfce-extra/xfce4-smartbookmark-plugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/xfce4-smartbookmark-plugin
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-smartbookmark-plugin/ChangeLog,v 1.27 2013/05/05 17:17:45 ssuominen Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-smartbookmark-plugin/ChangeLog,v 1.28 2015/04/12 19:37:48 mgorny Exp $
+
+*xfce4-smartbookmark-plugin-0.4.6 (12 Apr 2015)
+
+ 12 Apr 2015; Michał Górny <mgorny@gentoo.org>
+ +xfce4-smartbookmark-plugin-0.4.6.ebuild:
+ Version bump with minor fixes.
05 May 2013; Samuli Suominen <ssuominen@gentoo.org>
-files/xfce4-smartbookmark-plugin-0.4.4-exo-open_and_argument_handling.patch,
diff --git a/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.6.ebuild b/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.6.ebuild
new file mode 100644
index 000000000000..e954afb68122
--- /dev/null
+++ b/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.6.ebuild,v 1.1 2015/04/12 19:37:48 mgorny Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Smart bookmark plug-in for the Xfce desktop environment"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-smartbookmark-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug"
+
+COMMON_DEPEND="x11-libs/gtk+:2=
+ x11-libs/libX11:=
+ >=xfce-base/libxfce4ui-4.10:=
+ >=xfce-base/xfce4-panel-4.10:="
+RDEPEND="${COMMON_DEPEND}
+ >=xfce-base/exo-0.8"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}
+src_prepare() {
+ sed -i -e '/bugs/s:debian:gentoo:' src/smartbookmark.c || die
+ xfconf_src_prepare
+}