summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2009-03-10 13:53:58 +0000
committerChristoph Mende <angelos@gentoo.org>2009-03-10 13:53:58 +0000
commit0f6cbb933dfef44cbd7252688a20d629a7f0167a (patch)
tree9cbaa922a31d6fd0bff107e61abef371902f301c /xfce-extra
parentXfce-4.6 bump (diff)
downloadgentoo-2-0f6cbb933dfef44cbd7252688a20d629a7f0167a.tar.gz
gentoo-2-0f6cbb933dfef44cbd7252688a20d629a7f0167a.tar.bz2
gentoo-2-0f6cbb933dfef44cbd7252688a20d629a7f0167a.zip
Xfce-4.6 bump
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/exo/ChangeLog7
-rw-r--r--xfce-extra/exo/exo-0.3.100.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/xfce-extra/exo/ChangeLog b/xfce-extra/exo/ChangeLog
index 27b5bd82f656..d401d8909a74 100644
--- a/xfce-extra/exo/ChangeLog
+++ b/xfce-extra/exo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-extra/exo
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/exo/ChangeLog,v 1.79 2009/02/09 19:45:21 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/exo/ChangeLog,v 1.80 2009/03/10 13:53:58 angelos Exp $
+
+*exo-0.3.100 (10 Mar 2009)
+
+ 10 Mar 2009; Christoph Mende <angelos@gentoo.org> +exo-0.3.100.ebuild:
+ Xfce-4.6 bump
09 Feb 2009; Christoph Mende <angelos@gentoo.org> -exo-0.3.4-r1.ebuild:
Removed old
diff --git a/xfce-extra/exo/exo-0.3.100.ebuild b/xfce-extra/exo/exo-0.3.100.ebuild
new file mode 100644
index 000000000000..a8706f03770a
--- /dev/null
+++ b/xfce-extra/exo/exo-0.3.100.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/exo/exo-0.3.100.ebuild,v 1.1 2009/03/10 13:53:58 angelos Exp $
+
+EAPI=1
+
+inherit xfce4 python
+
+XFCE_VERSION=4.6.0
+
+xfce4_core
+
+DESCRIPTION="Extensions, widgets and framework library with session management support"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc hal libnotify python"
+
+RDEPEND=">=dev-lang/perl-5.6
+ dev-perl/URI
+ >=dev-libs/glib-2.6:2
+ >=x11-libs/gtk+-2.6:2
+ >=xfce-base/libxfce4util-${XFCE_VERSION}
+ libnotify? ( x11-libs/libnotify )
+ hal? ( sys-apps/hal )
+ python? ( dev-python/pygtk )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ doc? ( dev-util/gtk-doc )"
+
+pkg_setup() {
+ XFCE_CONFIG+=" $(use_enable doc gtk-doc) $(use_enable hal)
+ $(use_enable libnotify notifications) $(use_enable python)"
+}
+
+pkg_postinst() {
+ xfce4_pkg_postinst
+ python_mod_optimize /usr/lib*/python*/site-packages
+}
+
+pkg_postrm() {
+ xfce4_pkg_postrm
+ python_mod_cleanup /usr/lib*/python*/site-packages
+}
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README THANKS TODO"