summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-25 11:10:38 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-25 11:10:38 +0000
commit245f96fd327262ebccc91bf7d394c0ea097f9de9 (patch)
tree39e0a7ed321c9348ecb3065bcc6743079510f778 /xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.5.3.3.ebuild
parentUse xfconf.eclass. (diff)
downloadgentoo-2-245f96fd327262ebccc91bf7d394c0ea097f9de9.tar.gz
gentoo-2-245f96fd327262ebccc91bf7d394c0ea097f9de9.tar.bz2
gentoo-2-245f96fd327262ebccc91bf7d394c0ea097f9de9.zip
Missing middle ebuild.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.5.3.3.ebuild')
-rw-r--r--xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.5.3.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.5.3.3.ebuild b/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.5.3.3.ebuild
new file mode 100644
index 000000000000..81f24c1225d4
--- /dev/null
+++ b/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.5.3.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.5.3.3.ebuild,v 1.1 2009/08/25 11:10:38 ssuominen Exp $
+
+EAPI=2
+inherit xfconf
+
+DESCRIPTION="XKB layout switching panel plugin"
+HOMEPAGE="http://www.xfce.org/"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/0.5/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+RDEPEND=">=x11-libs/gtk+-2.6:2
+ >=xfce-base/xfce4-panel-4.3.20
+ >=xfce-base/libxfce4util-4.3.90.2
+ >=xfce-base/libxfcegui4-4.3.90.2
+ <x11-libs/libxklavier-4
+ x11-libs/libwnck"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ x11-proto/kbproto
+ >=gnome-base/librsvg-2.18"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog README"
+ XFCONF="--disable-dependency-tracking
+ $(use_enable debug)"
+}