summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-08-01 01:38:14 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-08-01 01:38:14 +0000
commit8f5886f4de7db7ff4dad82e20392b56a93aa38fa (patch)
tree7d5dc9db60196b3307ea9259b5bf6b3afe768d46 /xfce-extra/xfce4-volstatus-icon
parentRespecting CC variable, closes bug #244042 (diff)
downloadgentoo-2-8f5886f4de7db7ff4dad82e20392b56a93aa38fa.tar.gz
gentoo-2-8f5886f4de7db7ff4dad82e20392b56a93aa38fa.tar.bz2
gentoo-2-8f5886f4de7db7ff4dad82e20392b56a93aa38fa.zip
Switch to EAPI=2 and xfce4.eclass. Add patch for duplicate variable names, bug 278976
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra/xfce4-volstatus-icon')
-rw-r--r--xfce-extra/xfce4-volstatus-icon/ChangeLog12
-rw-r--r--xfce-extra/xfce4-volstatus-icon/files/xfce4-volstatus-icon-0.1.0-dialogsegfault.diff24
-rw-r--r--xfce-extra/xfce4-volstatus-icon/xfce4-volstatus-icon-0.1.0-r1.ebuild28
3 files changed, 62 insertions, 2 deletions
diff --git a/xfce-extra/xfce4-volstatus-icon/ChangeLog b/xfce-extra/xfce4-volstatus-icon/ChangeLog
index 91f4e2091844..70f607d7b6b9 100644
--- a/xfce-extra/xfce4-volstatus-icon/ChangeLog
+++ b/xfce-extra/xfce4-volstatus-icon/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for xfce-extra/xfce4-volstatus-icon
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-volstatus-icon/ChangeLog,v 1.10 2008/03/26 02:06:41 ranger Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-volstatus-icon/ChangeLog,v 1.11 2009/08/01 01:38:14 darkside Exp $
+
+*xfce4-volstatus-icon-0.1.0-r1 (01 Aug 2009)
+
+ 01 Aug 2009; Jeremy Olexa <darkside@gentoo.org>
+ +files/xfce4-volstatus-icon-0.1.0-dialogsegfault.diff,
+ +xfce4-volstatus-icon-0.1.0-r1.ebuild:
+ Switch to EAPI=2 and xfce4.eclass. Add patch for duplicate variable names,
+ bug 278976
26 Mar 2008; Brent Baude <ranger@gentoo.org>
xfce4-volstatus-icon-0.1.0.ebuild:
diff --git a/xfce-extra/xfce4-volstatus-icon/files/xfce4-volstatus-icon-0.1.0-dialogsegfault.diff b/xfce-extra/xfce4-volstatus-icon/files/xfce4-volstatus-icon-0.1.0-dialogsegfault.diff
new file mode 100644
index 000000000000..45de47eac982
--- /dev/null
+++ b/xfce-extra/xfce4-volstatus-icon/files/xfce4-volstatus-icon-0.1.0-dialogsegfault.diff
@@ -0,0 +1,24 @@
+Index: xfce4-volstatus-icon/xfce-volstatus-dialog.c
+===================================================================
+--- xfce4-volstatus-icon/xfce-volstatus-dialog.c (wersja 3558)
++++ xfce4-volstatus-icon/xfce-volstatus-dialog.c (kopia robocza)
+@@ -287,7 +287,7 @@
+ xfce_volstatus_dialog_add_drive_to_list(XfceVolstatusDialog *dialog,
+ GHalDrive *drive)
+ {
+- GList *icon_list, *volumes, *l;
++ GList *icon_list, *volumes, *l, *m;
+ gchar *name;
+ gint w, h;
+ GdkPixbuf *pix = NULL;
+@@ -325,8 +325,8 @@
+
+ pix = NULL;
+ icon_list = ghal_volume_get_icon_list(volume);
+- for(l = icon_list; !pix && l; l = l->next)
+- pix = xfce_themed_icon_load((const gchar *)l->data, w);
++ for(m = icon_list; !pix && m; m = m->next)
++ pix = xfce_themed_icon_load((const gchar *)m->data, w);
+ g_list_foreach(icon_list, (GFunc)g_free, NULL);
+ g_list_free(icon_list);
+
diff --git a/xfce-extra/xfce4-volstatus-icon/xfce4-volstatus-icon-0.1.0-r1.ebuild b/xfce-extra/xfce4-volstatus-icon/xfce4-volstatus-icon-0.1.0-r1.ebuild
new file mode 100644
index 000000000000..2dd7c2d26ee8
--- /dev/null
+++ b/xfce-extra/xfce4-volstatus-icon/xfce4-volstatus-icon-0.1.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-volstatus-icon/xfce4-volstatus-icon-0.1.0-r1.ebuild,v 1.1 2009/08/01 01:38:14 darkside Exp $
+
+EAPI="2"
+
+inherit xfce4
+
+DESCRIPTION="Systray status icon for safe unmount/eject of volumes"
+HOMEPAGE="http://goodies.xfce.org"
+SRC_URI="http://goodies.xfce.org/releases/${PN}/${P}${COMPRESS}"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86"
+IUSE="debug"
+
+RDEPEND=">=x11-libs/gtk+-2.10
+ >=xfce-base/libxfce4util-${XFCE_VERSION}
+ >=xfce-base/libxfcegui4-${XFCE_VERSION}
+ >=xfce-extra/exo-0.3.2[hal]
+ >=sys-apps/hal-0.5.9
+ dev-libs/dbus-glib"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool"
+
+XFCE4_PATCHES="${FILESDIR}/xfce4-volstatus-icon-0.1.0-dialogsegfault.diff"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"