summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-01-14 13:41:49 +0000
committerPacho Ramos <pacho@gentoo.org>2015-01-14 13:41:49 +0000
commit8e1e48331892f55488db8bf38a8435270e1aec3e (patch)
tree8be79f1e5e36881da76d1c05c8ae321e867620e3 /xfce-extra/xfce4-vala
parentVersion bump, drop old (diff)
downloadgentoo-2-8e1e48331892f55488db8bf38a8435270e1aec3e.tar.gz
gentoo-2-8e1e48331892f55488db8bf38a8435270e1aec3e.tar.bz2
gentoo-2-8e1e48331892f55488db8bf38a8435270e1aec3e.zip
Work with newer vala version (#527864)
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'xfce-extra/xfce4-vala')
-rw-r--r--xfce-extra/xfce4-vala/ChangeLog9
-rw-r--r--xfce-extra/xfce4-vala/xfce4-vala-4.10.3-r1.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/xfce-extra/xfce4-vala/ChangeLog b/xfce-extra/xfce4-vala/ChangeLog
index 07947f111866..e8c47fe33580 100644
--- a/xfce-extra/xfce4-vala/ChangeLog
+++ b/xfce-extra/xfce4-vala/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-extra/xfce4-vala
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-vala/ChangeLog,v 1.14 2013/10/20 12:23:51 ssuominen Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-vala/ChangeLog,v 1.15 2015/01/14 13:41:49 pacho Exp $
+
+*xfce4-vala-4.10.3-r1 (14 Jan 2015)
+
+ 14 Jan 2015; Pacho Ramos <pacho@gentoo.org> +xfce4-vala-4.10.3-r1.ebuild:
+ Work with newer vala version (#527864)
20 Oct 2013; Samuli Suominen <ssuominen@gentoo.org> -xfce4-vala-4.10.2.ebuild:
old
diff --git a/xfce-extra/xfce4-vala/xfce4-vala-4.10.3-r1.ebuild b/xfce-extra/xfce4-vala/xfce4-vala-4.10.3-r1.ebuild
new file mode 100644
index 000000000000..c7d2dbfd799d
--- /dev/null
+++ b/xfce-extra/xfce4-vala/xfce4-vala-4.10.3-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-vala/xfce4-vala-4.10.3-r1.ebuild,v 1.1 2015/01/14 13:41:49 pacho Exp $
+
+EAPI=5
+MY_VALA_VERSION=0.26
+VALA_MIN_API_VERSION=${MY_VALA_VERSION}
+VALA_MAX_API_VERSION=${MY_VALA_VERSION}
+VALA_USE_DEPEND=vapigen
+inherit xfconf vala
+
+DESCRIPTION="Vala bindings for the Xfce desktop environment"
+HOMEPAGE="http://wiki.xfce.org/vala-bindings"
+SRC_URI="mirror://xfce/src/bindings/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="$(vala_depend)
+ >=xfce-base/exo-0.10
+ >=xfce-base/garcon-0.2
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/xfce4-panel-4.10
+ >=xfce-base/xfconf-4.10"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+ XFCONF=(
+ --with-vala-api=${MY_VALA_VERSION}
+ )
+}
+
+src_prepare() {
+ xfconf_src_prepare
+ vala_src_prepare
+}