summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-02-25 09:59:16 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-02-25 09:59:16 +0000
commitf2fa555b1ef53e16b51827e673011cb0caf61578 (patch)
treec3a2bd73eed95f524572d4c396eae5be197b6c0b /xfce-extra/xfce4-soundmenu-plugin
parentAdd ~arm-linux and ~x86-linux keywords. (diff)
downloadgentoo-2-f2fa555b1ef53e16b51827e673011cb0caf61578.tar.gz
gentoo-2-f2fa555b1ef53e16b51827e673011cb0caf61578.tar.bz2
gentoo-2-f2fa555b1ef53e16b51827e673011cb0caf61578.zip
Version bump.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'xfce-extra/xfce4-soundmenu-plugin')
-rw-r--r--xfce-extra/xfce4-soundmenu-plugin/ChangeLog10
-rw-r--r--xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.6.0.ebuild39
2 files changed, 47 insertions, 2 deletions
diff --git a/xfce-extra/xfce4-soundmenu-plugin/ChangeLog b/xfce-extra/xfce4-soundmenu-plugin/ChangeLog
index 26f758168860..3097e6e5fe6a 100644
--- a/xfce-extra/xfce4-soundmenu-plugin/ChangeLog
+++ b/xfce-extra/xfce4-soundmenu-plugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/xfce4-soundmenu-plugin
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-soundmenu-plugin/ChangeLog,v 1.19 2012/11/28 12:19:36 ssuominen Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-soundmenu-plugin/ChangeLog,v 1.20 2013/02/25 09:59:16 ssuominen Exp $
+
+*xfce4-soundmenu-plugin-0.6.0 (25 Feb 2013)
+
+ 25 Feb 2013; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-soundmenu-plugin-0.6.0.ebuild:
+ Version bump.
28 Nov 2012; Samuli Suominen <ssuominen@gentoo.org>
xfce4-soundmenu-plugin-0.4.10.ebuild:
diff --git a/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.6.0.ebuild b/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.6.0.ebuild
new file mode 100644
index 000000000000..9a5671faddce
--- /dev/null
+++ b/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.6.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.6.0.ebuild,v 1.1 2013/02/25 09:59:16 ssuominen Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="A panel plug-in to control MPRIS2 compatible players like Pragha (from the same authors)"
+HOMEPAGE="https://github.com/matiasdelellis/xfce4-soundmenu-plugin"
+SRC_URI="http://dissonance.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +glyr lastfm"
+
+RDEPEND=">=dev-libs/glib-2.28
+ >=dev-libs/keybinder-0.2.2:0
+ >=x11-libs/gtk+-2.20:2
+ x11-libs/libX11
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/xfce4-panel-4.10
+ glyr? ( >=media-libs/glyr-1.0.0 )
+ lastfm? ( >=media-libs/libclastfm-0.5 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(use_enable lastfm libclastfm)
+ $(use_enable glyr libglyr)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+}