summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-04-02 11:53:11 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-04-02 11:53:11 +0000
commit24765a865d85a9e5380e7274b8d5426bf1495813 (patch)
treed86b02ae8d185ca22db2ab9b313cd2079f698092 /xfce-extra/xfce4-smartbookmark-plugin
parentVersion bump. (diff)
downloadgentoo-2-24765a865d85a9e5380e7274b8d5426bf1495813.tar.gz
gentoo-2-24765a865d85a9e5380e7274b8d5426bf1495813.tar.bz2
gentoo-2-24765a865d85a9e5380e7274b8d5426bf1495813.zip
Use exo-open instead of xfbrowser4 for compability with Xfce 4.10.
(Portage version: 2.2.0_alpha96/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra/xfce4-smartbookmark-plugin')
-rw-r--r--xfce-extra/xfce4-smartbookmark-plugin/ChangeLog8
-rw-r--r--xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.4-r1.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/xfce-extra/xfce4-smartbookmark-plugin/ChangeLog b/xfce-extra/xfce4-smartbookmark-plugin/ChangeLog
index 3682b3b62b65..a68a0f1533b0 100644
--- a/xfce-extra/xfce4-smartbookmark-plugin/ChangeLog
+++ b/xfce-extra/xfce4-smartbookmark-plugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/xfce4-smartbookmark-plugin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-smartbookmark-plugin/ChangeLog,v 1.8 2012/02/13 22:01:42 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-smartbookmark-plugin/ChangeLog,v 1.9 2012/04/02 11:53:11 ssuominen Exp $
+
+*xfce4-smartbookmark-plugin-0.4.4-r1 (02 Apr 2012)
+
+ 02 Apr 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-smartbookmark-plugin-0.4.4-r1.ebuild:
+ Use exo-open instead of xfbrowser4 for compability with Xfce 4.10.
13 Feb 2012; Markus Meier <maekke@gentoo.org>
xfce4-smartbookmark-plugin-0.4.4.ebuild:
diff --git a/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.4-r1.ebuild b/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.4-r1.ebuild
new file mode 100644
index 000000000000..43d30c5eaa1c
--- /dev/null
+++ b/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.4-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.4-r1.ebuild,v 1.1 2012/04/02 11:53:11 ssuominen Exp $
+
+EAPI=4
+inherit xfconf
+
+DESCRIPTION="Smart bookmark plug-in for the Xfce desktop environment"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-smartbookmark-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/0.4/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug"
+
+COMMON_DEPEND="x11-libs/gtk+:2
+ x11-libs/libX11
+ >=xfce-base/libxfcegui4-4.8
+ >=xfce-base/xfce4-panel-4.8"
+RDEPEND="${COMMON_DEPEND}
+ >=xfce-base/exo-0.6"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ XFCONF=(
+ --disable-static
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}
+
+src_prepare() {
+ sed -i \
+ -e 's:xfbrowser4:exo-open --launch WebBrowser:' \
+ -e 's:bugs.debian:bugs.gentoo:' \
+ src/smartbookmark.c || die
+
+ xfconf_src_prepare
+}