summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-29 16:07:54 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-29 16:07:54 +0000
commitf651b29d0fc931f2707bca741f13d4e2d5e110ac (patch)
tree3cd9612f790eb64fce421f1cc9a3343d3bdbf3b3 /xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.2.ebuild
parentstable x86, bug 352808 (diff)
downloadgentoo-2-f651b29d0fc931f2707bca741f13d4e2d5e110ac.tar.gz
gentoo-2-f651b29d0fc931f2707bca741f13d4e2d5e110ac.tar.bz2
gentoo-2-f651b29d0fc931f2707bca741f13d4e2d5e110ac.zip
Link to libxfcegui4 and fix .desktop entry to be compatible with xfce4-panel >= 4.7.0.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.2.ebuild')
-rw-r--r--xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.2.ebuild27
1 files changed, 17 insertions, 10 deletions
diff --git a/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.2.ebuild b/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.2.ebuild
index 56b1cffc6419..55d45da293a3 100644
--- a/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.2.ebuild
+++ b/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.2.ebuild
@@ -1,12 +1,13 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.2.ebuild,v 1.2 2009/10/08 17:44:11 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.2.ebuild,v 1.3 2011/01/29 16:07:54 ssuominen Exp $
-EAPI=2
+EAPI=3
+EAUTORECONF=yes
inherit xfconf
-DESCRIPTION="Xfce panel smart-bookmark plugin"
-HOMEPAGE="http://www.xfce.org/"
+DESCRIPTION="Smart bookmark plug-in for the Xfce desktop environment"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-smartbookmark-plugin"
SRC_URI="mirror://xfce/src/panel-plugins/${PN}/0.4/${P}.tar.gz"
LICENSE="GPL-2"
@@ -14,7 +15,8 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
IUSE="debug"
-COMMON_DEPEND=">=xfce-base/xfce4-panel-4.3.20"
+COMMON_DEPEND=">=xfce-base/libxfcegui4-4.2
+ >=xfce-base/xfce4-panel-4.3.20"
RDEPEND="${COMMON_DEPEND}
xfce-base/xfce-utils"
DEPEND="${COMMON_DEPEND}
@@ -22,13 +24,18 @@ DEPEND="${COMMON_DEPEND}
dev-util/intltool"
pkg_setup() {
+ PATCHES=( "${FILESDIR}"/${P}-xfce48.patch )
+
+ XFCONF=(
+ --disable-dependency-tracking
+ --disable-static
+ $(xfconf_use_debug)
+ )
+
DOCS="AUTHORS ChangeLog README"
- XFCONF="--disable-dependency-tracking
- $(use_enable debug)"
}
src_prepare() {
- sed -i -e 's:bugs.debian:bugs.gentoo:g' \
- src/smartbookmark.c || die "sed failed"
+ sed -i -e 's:bugs.debian:bugs.gentoo:g' src/smartbookmark.c || die
xfconf_src_prepare
}