summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-04-18 09:37:20 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-04-18 09:37:20 +0000
commit85bfff5a902d11a0c47114a382580d38de1cc732 (patch)
treed477b91f02d22dfc90faf8e17d5e21fb4e206d30 /xfce-extra/xfce4-sensors-plugin
parentFix memory usage monitor, report and patch by wbk in bug #410093 (diff)
downloadgentoo-2-85bfff5a902d11a0c47114a382580d38de1cc732.tar.gz
gentoo-2-85bfff5a902d11a0c47114a382580d38de1cc732.tar.bz2
gentoo-2-85bfff5a902d11a0c47114a382580d38de1cc732.zip
Fix hddtemp sensors for Linux 3.x wrt #409343 by Balint SZENTE. Install to libdir instead of libexecdir.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra/xfce4-sensors-plugin')
-rw-r--r--xfce-extra/xfce4-sensors-plugin/ChangeLog10
-rw-r--r--xfce-extra/xfce4-sensors-plugin/files/xfce4-sensors-plugin-1.2.3-linux-3.x.patch14
-rw-r--r--xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.2.3-r1.ebuild60
3 files changed, 83 insertions, 1 deletions
diff --git a/xfce-extra/xfce4-sensors-plugin/ChangeLog b/xfce-extra/xfce4-sensors-plugin/ChangeLog
index 134c46a4cc13..5481ce79b766 100644
--- a/xfce-extra/xfce4-sensors-plugin/ChangeLog
+++ b/xfce-extra/xfce4-sensors-plugin/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for xfce-extra/xfce4-sensors-plugin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-sensors-plugin/ChangeLog,v 1.31 2012/01/06 11:08:15 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-sensors-plugin/ChangeLog,v 1.32 2012/04/18 09:37:20 ssuominen Exp $
+
+*xfce4-sensors-plugin-1.2.3-r1 (18 Apr 2012)
+
+ 18 Apr 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-sensors-plugin-1.2.3-r1.ebuild,
+ +files/xfce4-sensors-plugin-1.2.3-linux-3.x.patch:
+ Fix hddtemp sensors for Linux 3.x wrt #409343 by Balint SZENTE. Install to
+ libdir instead of libexecdir.
06 Jan 2012; Samuli Suominen <ssuominen@gentoo.org>
xfce4-sensors-plugin-1.2.3.ebuild, metadata.xml:
diff --git a/xfce-extra/xfce4-sensors-plugin/files/xfce4-sensors-plugin-1.2.3-linux-3.x.patch b/xfce-extra/xfce4-sensors-plugin/files/xfce4-sensors-plugin-1.2.3-linux-3.x.patch
new file mode 100644
index 000000000000..c969b1d50ce8
--- /dev/null
+++ b/xfce-extra/xfce4-sensors-plugin/files/xfce4-sensors-plugin-1.2.3-linux-3.x.patch
@@ -0,0 +1,14 @@
+http://bugs.gentoo.org/409343
+http://bugzilla.xfce.org/show_bug.cgi?id=8266
+
+--- lib/hddtemp.c
++++ lib/hddtemp.c
+@@ -421,7 +421,7 @@ initialize_hddtemp (GPtrArray *chips, gb
+ #ifdef HAVE_NETCAT
+ read_disks_netcat (chip);
+ #else
+- if (strcmp(p_uname->sysname, "Linux")==0 && major>=5)
++ if (strcmp(p_uname->sysname, "Linux")==0 && (generation>=3 || (generation==2 && major>=5)))
+ read_disks_linux26 (chip);
+ else
+ read_disks_fallback (chip); /* hopefully, that's a safe variant */
diff --git a/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.2.3-r1.ebuild b/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..79e5d8b7ce1f
--- /dev/null
+++ b/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.2.3-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.2.3-r1.ebuild,v 1.1 2012/04/18 09:37:20 ssuominen Exp $
+
+EAPI=4
+EAUTORECONF=yes
+inherit multilib xfconf
+
+DESCRIPTION="A panel plug-in for different sensors using acpi, lm_sensors and hddtemp"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-sensors-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+acpi debug hddtemp libnotify lm_sensors video_cards_nvidia"
+
+REQUIRED_USE="|| ( hddtemp lm_sensors acpi )"
+
+RDEPEND=">=x11-libs/gtk+-2.10:2
+ >=xfce-base/libxfce4ui-4.8
+ >=xfce-base/xfce4-panel-4.8
+ hddtemp? ( app-admin/hddtemp net-analyzer/gnu-netcat )
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ lm_sensors? ( >=sys-apps/lm_sensors-3.1.0 )
+ video_cards_nvidia? ( media-video/nvidia-settings )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ PATCHES=( "${FILESDIR}"/${P}-linux-3.x.patch )
+
+ XFCONF=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ --disable-static
+ $(use_enable acpi procacpi)
+ $(use_enable acpi sysfsacpi)
+ $(use_enable hddtemp netcat)
+ $(use_enable hddtemp)
+ $(use_enable libnotify notification)
+ $(use_enable lm_sensors libsensors)
+ $(use_enable video_cards_nvidia xnvctrl)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS NOTES README TODO )
+}
+
+src_prepare() {
+ sed -i -e '/-no-undefined/d' src/Makefile.am || die
+ # Use flags from xfce4-dev-tools instead of defining them again in
+ # configure.in wrt #386979
+ sed -i -e '/PLATFORM_CFLAGS/s:-Werror::' configure.in || die
+ # http://bugzilla.xfce.org/show_bug.cgi?id=8057
+ # value "Monitor" in key "Categories" in group "Desktop Entry" requires
+ # another category to be present among the following categories: System
+ sed -i -e 's:Monitor:System;&:' src/xfce4-sensors.desktop.in || die
+ xfconf_src_prepare
+}