summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-23 19:51:49 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-23 19:51:49 +0000
commitb0a95a6b029334de0d778180d8534f8fd9cda6fd (patch)
tree3d6a9b25730af01c617750f7939556c13e3c32cd /xfce-extra/xfce4-radio-plugin
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-b0a95a6b029334de0d778180d8534f8fd9cda6fd.tar.gz
gentoo-2-b0a95a6b029334de0d778180d8534f8fd9cda6fd.tar.bz2
gentoo-2-b0a95a6b029334de0d778180d8534f8fd9cda6fd.zip
Rename xfce4-radio to xfce4-radio-plugin.
(Portage version: 2.2_rc39/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'xfce-extra/xfce4-radio-plugin')
-rw-r--r--xfce-extra/xfce4-radio-plugin/ChangeLog11
-rw-r--r--xfce-extra/xfce4-radio-plugin/metadata.xml5
-rw-r--r--xfce-extra/xfce4-radio-plugin/xfce4-radio-plugin-0.3.1.ebuild28
-rw-r--r--xfce-extra/xfce4-radio-plugin/xfce4-radio-plugin-0.4.2.ebuild32
4 files changed, 76 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-radio-plugin/ChangeLog b/xfce-extra/xfce4-radio-plugin/ChangeLog
new file mode 100644
index 000000000000..a7c5656a32e5
--- /dev/null
+++ b/xfce-extra/xfce4-radio-plugin/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for xfce-extra/xfce4-radio-plugin
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-radio-plugin/ChangeLog,v 1.1 2009/08/23 19:51:49 ssuominen Exp $
+
+*xfce4-radio-plugin-0.4.2 (23 Aug 2009)
+*xfce4-radio-plugin-0.3.1 (23 Aug 2009)
+
+ 23 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-radio-plugin-0.3.1.ebuild, +xfce4-radio-plugin-0.4.2.ebuild:
+ Rename xfce4-radio to xfce4-radio-plugin.
+
diff --git a/xfce-extra/xfce4-radio-plugin/metadata.xml b/xfce-extra/xfce4-radio-plugin/metadata.xml
new file mode 100644
index 000000000000..d56729e92f8e
--- /dev/null
+++ b/xfce-extra/xfce4-radio-plugin/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>xfce</herd>
+</pkgmetadata>
diff --git a/xfce-extra/xfce4-radio-plugin/xfce4-radio-plugin-0.3.1.ebuild b/xfce-extra/xfce4-radio-plugin/xfce4-radio-plugin-0.3.1.ebuild
new file mode 100644
index 000000000000..2329fcbe3aec
--- /dev/null
+++ b/xfce-extra/xfce4-radio-plugin/xfce4-radio-plugin-0.3.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-radio-plugin/xfce4-radio-plugin-0.3.1.ebuild,v 1.1 2009/08/23 19:51:49 ssuominen Exp $
+
+inherit xfconf
+
+DESCRIPTION="Panel plugin to control V4L radio device"
+HOMEPAGE="http://www.xfce.org/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=xfce-base/xfce4-panel-4.3.22"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.40"
+
+# temp. hack, dropped in next version
+RESTRICT="test"
+
+pkg_setup() {
+ XFCONF="--disable-dependency-tracking
+ $(use_enable debug)"
+ DOCS="AUTHORS ChangeLog NEWS README"
+}
diff --git a/xfce-extra/xfce4-radio-plugin/xfce4-radio-plugin-0.4.2.ebuild b/xfce-extra/xfce4-radio-plugin/xfce4-radio-plugin-0.4.2.ebuild
new file mode 100644
index 000000000000..41ee46e741ae
--- /dev/null
+++ b/xfce-extra/xfce4-radio-plugin/xfce4-radio-plugin-0.4.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-radio-plugin/xfce4-radio-plugin-0.4.2.ebuild,v 1.1 2009/08/23 19:51:49 ssuominen Exp $
+
+EAPI=2
+inherit xfconf
+
+DESCRIPTION="Panel plugin to control V4L radio device"
+HOMEPAGE="http://www.xfce.org/"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/0.4/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=xfce-base/xfce4-panel-4.3.22"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.40"
+
+pkg_setup() {
+ XFCONF="--disable-dependency-tracking
+ $(use_enable debug)"
+ DOCS="AUTHORS ChangeLog NEWS README"
+}
+
+src_prepare() {
+ xfconf_src_prepare
+ echo panel-plugin/radio.desktop.in.in >> po/POTFILES.skip
+ echo panel-plugin/xfce4-radio.c >> po/POTFILES.skip
+}