summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-04-20 11:24:58 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-04-20 11:24:58 +0000
commitcff85f53ff1e9690381591a0b70f994e8928abe3 (patch)
treebe73d3b5d8467744317eb583b4e109fa07af532f /xfce-extra/xfce4-linelight-plugin
parentinherit eutils too for epatch (diff)
downloadgentoo-2-cff85f53ff1e9690381591a0b70f994e8928abe3.tar.gz
gentoo-2-cff85f53ff1e9690381591a0b70f994e8928abe3.tar.bz2
gentoo-2-cff85f53ff1e9690381591a0b70f994e8928abe3.zip
Version bump (to unofficial .orig.tar.gz from Debian) with patch for libxfce4util >= 4.9.0 compability wrt #411949
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra/xfce4-linelight-plugin')
-rw-r--r--xfce-extra/xfce4-linelight-plugin/ChangeLog12
-rw-r--r--xfce-extra/xfce4-linelight-plugin/files/xfce4-linelight-plugin-0.1.7-port-to-xfcerc.patch61
-rw-r--r--xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.7.ebuild38
3 files changed, 109 insertions, 2 deletions
diff --git a/xfce-extra/xfce4-linelight-plugin/ChangeLog b/xfce-extra/xfce4-linelight-plugin/ChangeLog
index ebcb2bb2e0b7..7d80f1dc9609 100644
--- a/xfce-extra/xfce4-linelight-plugin/ChangeLog
+++ b/xfce-extra/xfce4-linelight-plugin/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for xfce-extra/xfce4-linelight-plugin
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-linelight-plugin/ChangeLog,v 1.8 2011/05/19 20:37:31 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-linelight-plugin/ChangeLog,v 1.9 2012/04/20 11:24:58 ssuominen Exp $
+
+*xfce4-linelight-plugin-0.1.7 (20 Apr 2012)
+
+ 20 Apr 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-linelight-plugin-0.1.7.ebuild,
+ +files/xfce4-linelight-plugin-0.1.7-port-to-xfcerc.patch:
+ Version bump (to unofficial .orig.tar.gz from Debian) with patch for
+ libxfce4util >= 4.9.0 compability wrt #411949
19 May 2011; Samuli Suominen <ssuominen@gentoo.org>
xfce4-linelight-plugin-0.1.6-r1.ebuild:
diff --git a/xfce-extra/xfce4-linelight-plugin/files/xfce4-linelight-plugin-0.1.7-port-to-xfcerc.patch b/xfce-extra/xfce4-linelight-plugin/files/xfce4-linelight-plugin-0.1.7-port-to-xfcerc.patch
new file mode 100644
index 000000000000..2c7bb4795248
--- /dev/null
+++ b/xfce-extra/xfce4-linelight-plugin/files/xfce4-linelight-plugin-0.1.7-port-to-xfcerc.patch
@@ -0,0 +1,61 @@
+http://bugs.gentoo.org/411949
+http://bugs.ganymede.ch/
+http://lionel.lefolgoc.net/misc/01_port-to-xfcerc.patch
+
+--- panel-plugin/linelight.c
++++ panel-plugin/linelight.c
+@@ -207,7 +207,7 @@ void linelight_add_list_entry(LineLightD
+ remove_newline(entry);
+
+ GtkTreeIter iter;
+- char *icon;
++ const gchar *icon = NULL;
+ GdkPixbuf *pixbuf;
+
+ gtk_list_store_insert(data->list, &iter, data->listPointer[sec]);
+@@ -218,13 +218,15 @@ void linelight_add_list_entry(LineLightD
+ //icon
+ if (g_file_query_exists (file, NULL) && sec == BIN_SECTION )
+ {
+- XfceDesktopEntry* app = xfce_desktop_entry_new(entry,categories,3);
++ XfceRc* app = xfce_rc_simple_open(entry, TRUE);
+
+- if (app != NULL && xfce_desktop_entry_get_string(app, "Icon", TRUE, &icon) && NULL != (pixbuf= load_icon(icon)))
++ if (app != NULL)
+ {
+- gtk_list_store_set(data->list, &iter, ICON_COL, pixbuf, -1);
+- g_object_unref(app);
+- free(icon);
++ xfce_rc_set_group(app, G_KEY_FILE_DESKTOP_GROUP);
++ icon = xfce_rc_read_entry(app, G_KEY_FILE_DESKTOP_KEY_ICON, NULL);
++ if (icon != NULL && NULL != (pixbuf= load_icon(icon)))
++ gtk_list_store_set(data->list, &iter, ICON_COL, pixbuf, -1);
++ xfce_rc_close(app);
+ }
+ }
+ else if (file != NULL)
+--- panel-plugin/main.c
++++ panel-plugin/main.c
+@@ -155,14 +155,15 @@ static void cell_renderer(GtkTreeViewCol
+ }
+ else if (strstr(name,".desktop") != NULL) //Application names based on .desktop files
+ {
+- XfceDesktopEntry *application = xfce_desktop_entry_new(path,categories,3);
+- if (XFCE_IS_DESKTOP_ENTRY(application))
++ XfceRc *application = xfce_rc_simple_open(path, TRUE);
++ if (application != NULL)
+ {
+- char* app_name;
+- xfce_desktop_entry_get_string(application, "Name", TRUE, &app_name);
+- g_object_unref(application);
+- g_object_set(cell,"text", app_name,NULL);
+- free(app_name);
++ const gchar* app_name = NULL;
++ xfce_rc_set_group(application, G_KEY_FILE_DESKTOP_GROUP);
++ app_name = xfce_rc_read_entry(application, G_KEY_FILE_DESKTOP_KEY_NAME, NULL);
++ if (app_name != NULL)
++ g_object_set(cell,"text", app_name, NULL);
++ xfce_rc_close(application);
+ }
+ }
+ else
diff --git a/xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.7.ebuild b/xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.7.ebuild
new file mode 100644
index 000000000000..5f2a69998d19
--- /dev/null
+++ b/xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-linelight-plugin/xfce4-linelight-plugin-0.1.7.ebuild,v 1.1 2012/04/20 11:24:58 ssuominen Exp $
+
+EAPI=4
+EAUTORECONF=yes
+inherit multilib xfconf
+
+DESCRIPTION="A simple locate based search plug-in for the Xfce panel"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-linelight-plugin"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}.orig.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND=">=dev-libs/glib-2.18:2
+ >=x11-libs/gtk+-2.12:2
+ >=xfce-base/xfce4-panel-4.8
+ >=xfce-base/libxfcegui4-4.8"
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/mlocate"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ PATCHES=(
+ "${FILESDIR}"/${P}-port-to-xfcerc.patch
+ )
+
+ XFCONF=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS )
+}