summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2007-12-02 15:49:41 +0000
committerChristoph Mende <angelos@gentoo.org>2007-12-02 15:49:41 +0000
commit891ac0c286e3d6d3b5b1fe586fc67a2936bda3f8 (patch)
tree4f90ebec0759d35e9845d14e900a062616619568 /xfce-extra/thunar-volman/thunar-volman-0.2.0.ebuild
parentVersion bump, drop patch since it was applied upstream. (diff)
downloadgentoo-2-891ac0c286e3d6d3b5b1fe586fc67a2936bda3f8.tar.gz
gentoo-2-891ac0c286e3d6d3b5b1fe586fc67a2936bda3f8.tar.bz2
gentoo-2-891ac0c286e3d6d3b5b1fe586fc67a2936bda3f8.zip
Version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'xfce-extra/thunar-volman/thunar-volman-0.2.0.ebuild')
-rw-r--r--xfce-extra/thunar-volman/thunar-volman-0.2.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/xfce-extra/thunar-volman/thunar-volman-0.2.0.ebuild b/xfce-extra/thunar-volman/thunar-volman-0.2.0.ebuild
new file mode 100644
index 000000000000..40c1c2bb2074
--- /dev/null
+++ b/xfce-extra/thunar-volman/thunar-volman-0.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/thunar-volman/thunar-volman-0.2.0.ebuild,v 1.1 2007/12/02 15:49:40 angelos Exp $
+
+inherit eutils xfce44
+
+xfce44
+
+DESCRIPTION="Thunar volume management"
+HOMEPAGE="http://foo-projects.org/~benny/projects/thunar-volman"
+SRC_URI="mirror://berlios/xfce-goodies/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND="dev-libs/dbus-glib
+ sys-apps/hal
+ >=xfce-extra/exo-0.3.2
+ >=xfce-base/thunar-${THUNAR_MASTER_VERSION}"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ if ! built_with_use xfce-extra/exo hal; then
+ ewarn "Volume management requires exo with hal support. Enable"
+ ewarn "hal USE flag and re-emerge exo."
+ die "re-emerge exo with USE hal"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Fix make check.
+ echo thunar-volman-settings.desktop.in.in >> po/POTFILES.skip
+}
+
+DOCS="AUTHORS ChangeLog NEWS README THANKS"