summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-10-19 14:36:22 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-10-19 14:36:22 +0000
commiteedb4fdf4073bed56bb963fa297ea1fb814cb08b (patch)
tree7027b73aeaccaadb56470386c57fa0354abd747a /xfce-base
parentVersion bump,. Many bug fixes. http://releases.xfce.org/feeds/project/xfce4-p... (diff)
downloadgentoo-2-eedb4fdf4073bed56bb963fa297ea1fb814cb08b.tar.gz
gentoo-2-eedb4fdf4073bed56bb963fa297ea1fb814cb08b.tar.bz2
gentoo-2-eedb4fdf4073bed56bb963fa297ea1fb814cb08b.zip
Version bump for small bug fixes, including reading mount options from an rc file
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/exo/ChangeLog8
-rw-r--r--xfce-base/exo/exo-0.3.105.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/xfce-base/exo/ChangeLog b/xfce-base/exo/ChangeLog
index 1cc2c1f14fb2..5a04bc8c3395 100644
--- a/xfce-base/exo/ChangeLog
+++ b/xfce-base/exo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-base/exo
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/ChangeLog,v 1.13 2009/10/17 00:58:57 rich0 Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/ChangeLog,v 1.14 2009/10/19 14:36:22 darkside Exp $
+
+*exo-0.3.105 (19 Oct 2009)
+
+ 19 Oct 2009; Jeremy Olexa <darkside@gentoo.org> +exo-0.3.105.ebuild:
+ Version bump for small bug fixes, including reading mount options from an
+ rc file
17 Oct 2009; Richard Freeman <rich0@gentoo.org> exo-0.3.104.ebuild:
amd64 stable - 289179
diff --git a/xfce-base/exo/exo-0.3.105.ebuild b/xfce-base/exo/exo-0.3.105.ebuild
new file mode 100644
index 000000000000..11be829e6c70
--- /dev/null
+++ b/xfce-base/exo/exo-0.3.105.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/exo-0.3.105.ebuild,v 1.1 2009/10/19 14:36:22 darkside Exp $
+
+EAPI=2
+inherit xfconf python multilib
+
+DESCRIPTION="Extensions, widgets and framework library with session management support"
+HOMEPAGE="http://www.xfce.org/projects/exo"
+SRC_URI="mirror://xfce/src/xfce/exo/0.3/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="debug hal libnotify python"
+
+RDEPEND=">=dev-lang/perl-5.6
+ dev-perl/URI
+ >=dev-libs/glib-2.6:2
+ >=x11-libs/gtk+-2.6:2
+ >=xfce-base/libxfce4util-4.6.1
+ libnotify? ( x11-libs/libnotify )
+ hal? ( sys-apps/hal )
+ python? ( dev-python/pygtk )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ XFCONF="--disable-static
+ $(use_enable hal)
+ $(use_enable libnotify notifications)
+ $(use_enable python)"
+ DOCS="AUTHORS ChangeLog HACKING NEWS README THANKS TODO"
+ PATCHES=( "${FILESDIR}/${PN}-0.3.4-interix.patch" )
+}
+
+src_prepare() {
+ xfconf_src_prepare
+ rm py-compile
+ touch py-compile
+ chmod +x py-compile
+
+ if [[ ${CHOST} == *-interix* ]] ; then
+ # configure detects getmntent, which is false!
+ export ac_cv_func_getmntent=no
+ fi
+}
+
+pkg_postinst() {
+ xfconf_pkg_postinst
+ python_mod_optimize "$(python_get_sitedir)"
+}
+
+pkg_postrm() {
+ xfconf_pkg_postrm
+ python_mod_cleanup "$(python_get_sitedir)"
+}