summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2006-07-10 18:35:26 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2006-07-10 18:35:26 +0000
commitd167bed57b7d91e1f5e41b1e3994fbcab329d482 (patch)
tree8709cb0f822dff6fb832eeacbab58a48200bc3f3 /xfce-base
parentXfce beta 2 builds. (diff)
downloadgentoo-2-d167bed57b7d91e1f5e41b1e3994fbcab329d482.tar.gz
gentoo-2-d167bed57b7d91e1f5e41b1e3994fbcab329d482.tar.bz2
gentoo-2-d167bed57b7d91e1f5e41b1e3994fbcab329d482.zip
Xfce beta 2 builds.
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/thunar/ChangeLog7
-rw-r--r--xfce-base/thunar/files/digest-thunar-0.3.2_beta23
-rw-r--r--xfce-base/thunar/thunar-0.3.2_beta2.ebuild54
3 files changed, 63 insertions, 1 deletions
diff --git a/xfce-base/thunar/ChangeLog b/xfce-base/thunar/ChangeLog
index 6663ec119066..1493be45ef2d 100644
--- a/xfce-base/thunar/ChangeLog
+++ b/xfce-base/thunar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/thunar
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/ChangeLog,v 1.1 2006/04/20 05:36:12 dostrow Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/ChangeLog,v 1.2 2006/07/10 18:35:26 bcowan Exp $
+
+*thunar-0.3.2_beta2 (10 Jul 2006)
+
+ 10 Jul 2006; Brad Cowan <bcowan@gentoo.org> +thunar-0.3.2_beta2.ebuild:
+ Xfce beta 2 builds.
*thunar-0.3.0_beta1 (20 Apr 2006)
diff --git a/xfce-base/thunar/files/digest-thunar-0.3.2_beta2 b/xfce-base/thunar/files/digest-thunar-0.3.2_beta2
new file mode 100644
index 000000000000..8c9170486538
--- /dev/null
+++ b/xfce-base/thunar/files/digest-thunar-0.3.2_beta2
@@ -0,0 +1,3 @@
+MD5 53087545a5bf6bdac0174a4628722c21 Thunar-0.3.2beta2.tar.bz2 1680957
+RMD160 2839f5f80aed73699f229385364e98601e52a33b Thunar-0.3.2beta2.tar.bz2 1680957
+SHA256 b82a21a06a36a8d81d3d113778ae9cf9f05dfb68618895e077fbc2201a371f03 Thunar-0.3.2beta2.tar.bz2 1680957
diff --git a/xfce-base/thunar/thunar-0.3.2_beta2.ebuild b/xfce-base/thunar/thunar-0.3.2_beta2.ebuild
new file mode 100644
index 000000000000..35e36947e353
--- /dev/null
+++ b/xfce-base/thunar/thunar-0.3.2_beta2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/thunar-0.3.2_beta2.ebuild,v 1.1 2006/07/10 18:35:26 bcowan Exp $
+
+inherit xfce44 versionator
+
+xfce44_beta
+
+MY_PN="Thunar"
+MY_PV="$(replace_version_separator 3 '')"
+MY_P="${MY_PN}-${MY_PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Xfce 4 file manager"
+SRC_URI="http://www.xfce.org/archive/xfce-${XFCE_MASTER_VERSION}/src/${MY_P}${COMPRESS}"
+HOMEPAGE="http://thunar.xfce.org"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="dbus hal startup-notification thumbnail xslt"
+
+RDEPEND="virtual/fam
+ >=dev-libs/glib-2.6.4
+ >=x11-libs/gtk+-2.6.4
+ thumbnail? ( >=gnome-base/gconf-2.4 )
+ gnome-base/orbit
+ >=media-libs/jpeg-6b
+ >=media-libs/libpng-1.2
+ dbus? ( >=sys-apps/dbus-0.34 )
+ hal? ( >=sys-apps/hal-0.5
+ >=sys-apps/dbus-0.34 )
+ x11-libs/pango
+ startup-notification? ( >=x11-libs/startup-notification-0.4 )
+ xslt? ( dev-libs/libxslt )
+ >=dev-util/gtk-doc-1
+ >=x11-misc/shared-mime-info-0.15
+ >=dev-util/desktop-file-utils-0.10
+ >=xfce-base/libxfce4util-4.2.2
+ >=xfce-extra/exo-0.3.1.6_beta1"
+
+DEPEND="${RDEPEND}
+ || ( x11-proto/xproto virtual/x11 )"
+
+XFCE_CONFIG="$(use_enable dbus) $(use_enable thumbnail gnome-thumbnailers) \
+ $(use_enable startup-notification)"
+
+if use xslt; then
+ XFCE_CONFIG="${XFCE_CONFIG} --enable-xsltproc"
+fi
+
+if use hal; then
+ XFCE_CONFIG="${XFCE_CONFIG} --with-volume-manager=hal"
+else
+ XFCE_CONFIG="${XFCE_CONFIG} --with-volume-manager=none"
+fi