summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Weller <welp@gentoo.org>2007-01-28 15:17:41 +0000
committerPeter Weller <welp@gentoo.org>2007-01-28 15:17:41 +0000
commitce13aae892e868cbad2cb1ceabf551c0e6a92240 (patch)
tree66edaf6d7456fa09f95a9130b5caa6659467414d /xfce-base
parentDep fixes, various other fixes (diff)
downloadgentoo-2-ce13aae892e868cbad2cb1ceabf551c0e6a92240.tar.gz
gentoo-2-ce13aae892e868cbad2cb1ceabf551c0e6a92240.tar.bz2
gentoo-2-ce13aae892e868cbad2cb1ceabf551c0e6a92240.zip
Dep fixes, various other fixes
(Portage version: 2.1.2-r4)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfce-utils/ChangeLog5
-rw-r--r--xfce-base/xfce-utils/xfce-utils-4.4.0.ebuild25
2 files changed, 16 insertions, 14 deletions
diff --git a/xfce-base/xfce-utils/ChangeLog b/xfce-base/xfce-utils/ChangeLog
index 27850e18b216..21b715e643a0 100644
--- a/xfce-base/xfce-utils/ChangeLog
+++ b/xfce-base/xfce-utils/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for xfce-base/xfce-utils
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/ChangeLog,v 1.81 2007/01/23 17:23:48 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/ChangeLog,v 1.82 2007/01/28 15:17:41 welp Exp $
+
+ 28 Jan 2007; Peter Weller <welp@gentoo.org> xfce-utils-4.4.0.ebuild:
+ Dep fixes, various other fixes
23 Jan 2007; Peter Weller <welp@gentoo.org> xfce-utils-4.4.0.ebuild:
Removing usage of virtual/x11, and hardcoding in depends. Minor clean ups.
diff --git a/xfce-base/xfce-utils/xfce-utils-4.4.0.ebuild b/xfce-base/xfce-utils/xfce-utils-4.4.0.ebuild
index b333fff8a3ff..a3fe2b735131 100644
--- a/xfce-base/xfce-utils/xfce-utils-4.4.0.ebuild
+++ b/xfce-base/xfce-utils/xfce-utils-4.4.0.ebuild
@@ -1,36 +1,35 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/xfce-utils-4.4.0.ebuild,v 1.2 2007/01/23 17:23:48 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/xfce-utils-4.4.0.ebuild,v 1.3 2007/01/28 15:17:41 welp Exp $
inherit xfce44
xfce44
-DESCRIPTION="Utilities for Xfce4"
+DESCRIPTION="Utils package"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="doc debug"
+IUSE="dbus debug"
RDEPEND="x11-apps/xrdb
- >=dev-libs/glib-2.2
- >=x11-libs/gtk+-2.2
- media-libs/libpng
- >=xfce-base/libxfce4util-${XFCE_MASTER_VERSION}
+ x11-libs/libX11
+ >=dev-libs/glib-2.6
+ >=x11-libs/gtk+-2.6
>=xfce-base/libxfcegui4-${XFCE_MASTER_VERSION}
>=xfce-base/libxfce4mcs-${XFCE_MASTER_VERSION}
>=xfce-base/xfce-mcs-manager-${XFCE_MASTER_VERSION}"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
-XFCE_CONFIG="${XFCE_CONFIG} --enable-gdm --with-vendor-info=Gentoo"
+XFCE_CONFIG="${XFCE_CONFIG} $(use_enable dbus) --enable-gdm --with-vendor-info=Gentoo"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
xfce44_core_package
src_install() {
xfce44_src_install
+ # Install vendor info.
insinto /usr/share/xfce4
newins ${FILESDIR}/Gentoo Gentoo
-
- if use doc; then
- dodoc AUTHORS README ChangeLog HACKING NEWS THANKS TODO
- fi
}