summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-03-28 07:46:26 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-03-28 07:46:26 +0000
commitc5154b11cb3756dbc5a2e6f9140907bccf321664 (patch)
tree35b284e8bac28547a9fd971b1f702239b2e19fce /xfce-base
parentVersion bump. Should work with libpng 1.5+ api. (diff)
downloadgentoo-2-c5154b11cb3756dbc5a2e6f9140907bccf321664.tar.gz
gentoo-2-c5154b11cb3756dbc5a2e6f9140907bccf321664.tar.bz2
gentoo-2-c5154b11cb3756dbc5a2e6f9140907bccf321664.zip
Backport upstream commit "Tasklist: add button release event to proxy item" wrt #360153 by Daniel Gulotta.
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfce4-panel/ChangeLog9
-rw-r--r--xfce-base/xfce4-panel/files/xfce4-panel-4.8.2-tasklist.patch22
-rw-r--r--xfce-base/xfce4-panel/xfce4-panel-4.8.2-r1.ebuild45
3 files changed, 75 insertions, 1 deletions
diff --git a/xfce-base/xfce4-panel/ChangeLog b/xfce-base/xfce4-panel/ChangeLog
index ef98220c3d40..b5f91856c281 100644
--- a/xfce-base/xfce4-panel/ChangeLog
+++ b/xfce-base/xfce4-panel/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for xfce-base/xfce4-panel
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-panel/ChangeLog,v 1.190 2011/03/22 20:39:00 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-panel/ChangeLog,v 1.191 2011/03/28 07:46:25 ssuominen Exp $
+
+*xfce4-panel-4.8.2-r1 (28 Mar 2011)
+
+ 28 Mar 2011; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-panel-4.8.2-r1.ebuild, +files/xfce4-panel-4.8.2-tasklist.patch:
+ Backport upstream commit "Tasklist: add button release event to proxy item"
+ wrt #360153 by Daniel Gulotta.
22 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> xfce4-panel-4.8.2.ebuild:
ppc/ppc64 stable wrt #358407
diff --git a/xfce-base/xfce4-panel/files/xfce4-panel-4.8.2-tasklist.patch b/xfce-base/xfce4-panel/files/xfce4-panel-4.8.2-tasklist.patch
new file mode 100644
index 000000000000..2b0e1cfbe3c6
--- /dev/null
+++ b/xfce-base/xfce4-panel/files/xfce4-panel-4.8.2-tasklist.patch
@@ -0,0 +1,22 @@
+From f2abad09584e72c49f2064926d742e8cfab52698 Mon Sep 17 00:00:00 2001
+From: Nick Schermer <nick@xfce.org>
+Date: Sun, 27 Feb 2011 21:25:14 +0000
+Subject: Tasklist: add button release event to proxy item (bug #7362).
+
+(cherry picked from commit 8bb6d5f273053bc75d3a17cfdae26f7798e714d6)
+---
+diff --git a/plugins/tasklist/tasklist-widget.c b/plugins/tasklist/tasklist-widget.c
+index 0ff7db6..783618a 100644
+--- a/plugins/tasklist/tasklist-widget.c
++++ b/plugins/tasklist/tasklist-widget.c
+@@ -2664,6 +2664,8 @@ xfce_tasklist_button_proxy_menu_item (XfceTasklistChild *child,
+
+ g_signal_connect (G_OBJECT (mi), "button-press-event",
+ G_CALLBACK (xfce_tasklist_button_button_press_event), child);
++ g_signal_connect (G_OBJECT (mi), "button-release-event",
++ G_CALLBACK (xfce_tasklist_button_button_release_event), child);
+
+ /* TODO bold labels for urgent windows */
+ /* TODO item dnd */
+--
+cgit v0.8.3.4
diff --git a/xfce-base/xfce4-panel/xfce4-panel-4.8.2-r1.ebuild b/xfce-base/xfce4-panel/xfce4-panel-4.8.2-r1.ebuild
new file mode 100644
index 000000000000..ab86a8df4786
--- /dev/null
+++ b/xfce-base/xfce4-panel/xfce4-panel-4.8.2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-panel/xfce4-panel-4.8.2-r1.ebuild,v 1.1 2011/03/28 07:46:25 ssuominen Exp $
+
+EAPI=4
+inherit xfconf
+
+DESCRIPTION="Panel for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/xfce4-panel/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/4.8/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug"
+
+RDEPEND="x11-libs/libX11
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/garcon-0.1.5
+ >=xfce-base/libxfce4ui-4.8
+ >=xfce-base/xfconf-4.8
+ >=xfce-base/exo-0.6
+ >=x11-libs/gtk+-2.14:2
+ >=dev-libs/glib-2.18:2
+ >=dev-libs/dbus-glib-0.88
+ >=x11-libs/cairo-1
+ >=x11-libs/libwnck-2.22:1"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ PATCHES=( "${FILESDIR}"/${P}-tasklist.patch )
+
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --disable-static
+ $(xfconf_use_debug)
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ DOCS="AUTHORS ChangeLog NEWS THANKS"
+}