summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-05-05 16:40:12 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-05-05 16:40:12 +0000
commit9c019eceff35a2d84ffc4ca230a896fa0a578554 (patch)
tree45f5d0db862cd5941e3e0eaea97335cb0145ff98 /xfce-base
parentVersion bump. (diff)
downloadgentoo-2-9c019eceff35a2d84ffc4ca230a896fa0a578554.tar.gz
gentoo-2-9c019eceff35a2d84ffc4ca230a896fa0a578554.tar.bz2
gentoo-2-9c019eceff35a2d84ffc4ca230a896fa0a578554.zip
Version bump.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfce4-settings/ChangeLog11
-rw-r--r--xfce-base/xfce4-settings/xfce4-settings-4.10.1.ebuild49
2 files changed, 57 insertions, 3 deletions
diff --git a/xfce-base/xfce4-settings/ChangeLog b/xfce-base/xfce4-settings/ChangeLog
index 8a2c274e0de6..f8e26570ca03 100644
--- a/xfce-base/xfce4-settings/ChangeLog
+++ b/xfce-base/xfce4-settings/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-base/xfce4-settings
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-settings/ChangeLog,v 1.107 2012/11/28 12:27:44 ssuominen Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-settings/ChangeLog,v 1.108 2013/05/05 16:40:12 ssuominen Exp $
+
+*xfce4-settings-4.10.1 (05 May 2013)
+
+ 05 May 2013; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-settings-4.10.1.ebuild:
+ Version bump.
28 Nov 2012; Samuli Suominen <ssuominen@gentoo.org>
xfce4-settings-4.10.0.ebuild:
@@ -454,4 +460,3 @@
10 Mar 2009; Christoph Mende <angelos@gentoo.org> +metadata.xml,
+xfce4-settings-4.6.0.ebuild:
Xfce-4.6 bump
-
diff --git a/xfce-base/xfce4-settings/xfce4-settings-4.10.1.ebuild b/xfce-base/xfce4-settings/xfce4-settings-4.10.1.ebuild
new file mode 100644
index 000000000000..54c8a9deafdf
--- /dev/null
+++ b/xfce-base/xfce4-settings/xfce4-settings-4.10.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-settings/xfce4-settings-4.10.1.ebuild,v 1.1 2013/05/05 16:40:12 ssuominen Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Configuration system for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug libcanberra libnotify +xklavier"
+
+RDEPEND=">=dev-libs/dbus-glib-0.100
+ >=dev-libs/glib-2.24
+ media-libs/fontconfig
+ >=x11-libs/gtk+-2.20:2
+ x11-libs/libX11
+ >=x11-libs/libXcursor-1.1
+ >=x11-libs/libXi-1.3
+ >=x11-libs/libXrandr-1.2
+ >=xfce-base/garcon-0.2
+ >=xfce-base/exo-0.8
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/xfconf-4.10
+ libcanberra? ( >=media-libs/libcanberra-0.25[sound] )
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ xklavier? ( >=x11-libs/libxklavier-5 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext
+ >=x11-proto/inputproto-1.4
+ x11-proto/xproto"
+
+pkg_setup() {
+ XFCONF=(
+ $(use_enable libnotify)
+ $(use_enable xklavier libxklavier)
+ $(use_enable libcanberra sound-settings)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS TODO )
+}