summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2009-03-13 07:12:14 +0000
committerChristoph Mende <angelos@gentoo.org>2009-03-13 07:12:14 +0000
commit5c736b6f40503a0310364234b97370ad3d365305 (patch)
tree70b90d0a508568a66f4b44bfd569fc5354da9752 /xfce-base
parentVersion bump (diff)
downloadgentoo-2-5c736b6f40503a0310364234b97370ad3d365305.tar.gz
gentoo-2-5c736b6f40503a0310364234b97370ad3d365305.tar.bz2
gentoo-2-5c736b6f40503a0310364234b97370ad3d365305.zip
Don't install perllocal.pod (bug 262017)
(Portage version: 2.2_rc25/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfconf/ChangeLog5
-rw-r--r--xfce-base/xfconf/xfconf-4.6.0.ebuild10
2 files changed, 13 insertions, 2 deletions
diff --git a/xfce-base/xfconf/ChangeLog b/xfce-base/xfconf/ChangeLog
index 06d485e427f1..7cf2b0d420ee 100644
--- a/xfce-base/xfconf/ChangeLog
+++ b/xfce-base/xfconf/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for xfce-base/xfconf
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfconf/ChangeLog,v 1.2 2009/03/12 16:19:29 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfconf/ChangeLog,v 1.3 2009/03/13 07:12:14 angelos Exp $
+
+ 13 Mar 2009; Christoph Mende <angelos@gentoo.org> xfconf-4.6.0.ebuild:
+ Don't install perllocal.pod (bug 262017)
12 Mar 2009; Christoph Mende <angelos@gentoo.org> xfconf-4.6.0.ebuild:
Added USE=perl to install perl bindings
diff --git a/xfce-base/xfconf/xfconf-4.6.0.ebuild b/xfce-base/xfconf/xfconf-4.6.0.ebuild
index 6c71c2cf4052..8866f7631f2c 100644
--- a/xfce-base/xfconf/xfconf-4.6.0.ebuild
+++ b/xfce-base/xfconf/xfconf-4.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfconf/xfconf-4.6.0.ebuild,v 1.2 2009/03/12 16:19:29 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfconf/xfconf-4.6.0.ebuild,v 1.3 2009/03/13 07:12:14 angelos Exp $
EAPI=1
@@ -30,4 +30,12 @@ src_compile() {
emake OTHERLDFLAGS="${LDFLAGS}" || die "emake failed"
}
+src_install() {
+ xfce4_src_install
+
+ # stolen from perl-module.eclass
+ find "${D}" -type f -name perllocal.pod -delete
+ find "${D}" -depth -mindepth 1 -type d -empty -delete
+}
+
DOCS="AUTHORS ChangeLog NEWS README TODO"