summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2010-05-22 15:16:00 +0000
committerChristoph Mende <angelos@gentoo.org>2010-05-22 15:16:00 +0000
commit53bad4475fd3a2be02be0925d64448ead7eab9db (patch)
treef69708ec6a794f2b149788ab308b15b121667860 /xfce-base
parentVarious cleanups. (diff)
downloadgentoo-2-53bad4475fd3a2be02be0925d64448ead7eab9db.tar.gz
gentoo-2-53bad4475fd3a2be02be0925d64448ead7eab9db.tar.bz2
gentoo-2-53bad4475fd3a2be02be0925d64448ead7eab9db.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/exo/ChangeLog7
-rw-r--r--xfce-base/exo/exo-0.3.107.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/xfce-base/exo/ChangeLog b/xfce-base/exo/ChangeLog
index 2788e832f6e3..a264003b0119 100644
--- a/xfce-base/exo/ChangeLog
+++ b/xfce-base/exo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/exo
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/ChangeLog,v 1.30 2010/04/14 17:42:17 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/ChangeLog,v 1.31 2010/05/22 15:16:00 angelos Exp $
+
+*exo-0.3.107 (22 May 2010)
+
+ 22 May 2010; Christoph Mende <angelos@gentoo.org> +exo-0.3.107.ebuild:
+ Version bump
14 Apr 2010; Jeroen Roovers <jer@gentoo.org> exo-0.3.106.ebuild:
Stable for HPPA (bug #305657).
diff --git a/xfce-base/exo/exo-0.3.107.ebuild b/xfce-base/exo/exo-0.3.107.ebuild
new file mode 100644
index 000000000000..f63e8bbd3f2c
--- /dev/null
+++ b/xfce-base/exo/exo-0.3.107.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/exo-0.3.107.ebuild,v 1.1 2010/05/22 15:16:00 angelos Exp $
+
+EAPI=2
+inherit xfconf python multilib
+
+DESCRIPTION="Extensions, widgets and framework library with session management support"
+HOMEPAGE="http://www.xfce.org/projects/exo"
+SRC_URI="mirror://xfce/src/xfce/exo/0.3/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="debug hal libnotify python"
+
+RDEPEND=">=dev-lang/perl-5.6
+ dev-perl/URI
+ >=dev-libs/glib-2.6:2
+ >=x11-libs/gtk+-2.6:2
+ >=xfce-base/libxfce4util-4.6.1
+ libnotify? ( x11-libs/libnotify )
+ hal? ( sys-apps/hal )
+ python? ( dev-python/pygtk )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ XFCONF="--disable-static
+ $(use_enable hal)
+ $(use_enable libnotify notifications)
+ $(use_enable python)"
+ DOCS="AUTHORS ChangeLog NEWS README THANKS TODO"
+ PATCHES=( "${FILESDIR}/${PN}-0.3.4-interix.patch" )
+}
+
+src_prepare() {
+ xfconf_src_prepare
+ rm py-compile
+ touch py-compile
+ chmod +x py-compile
+
+ if [[ ${CHOST} == *-interix* ]] ; then
+ # configure detects getmntent, which is false!
+ export ac_cv_func_getmntent=no
+ fi
+}
+
+pkg_postinst() {
+ xfconf_pkg_postinst
+ python_mod_optimize "$(python_get_sitedir)"
+}
+
+pkg_postrm() {
+ xfconf_pkg_postrm
+ python_mod_cleanup "$(python_get_sitedir)"
+}