summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-30 17:00:07 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-30 17:00:07 +0000
commit3ddb352201c2869716cb72e555f22091acf1d37e (patch)
tree62ad9e783588f4d9147e19c41ac97b1ffb3202af /xfce-base
parentAdd ~alpha/~ia64/~sparc wrt #347744 (diff)
downloadgentoo-2-3ddb352201c2869716cb72e555f22091acf1d37e.tar.gz
gentoo-2-3ddb352201c2869716cb72e555f22091acf1d37e.tar.bz2
gentoo-2-3ddb352201c2869716cb72e555f22091acf1d37e.zip
Version bump.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfce4-settings/ChangeLog8
-rw-r--r--xfce-base/xfce4-settings/xfce4-settings-4.8.1.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/xfce-base/xfce4-settings/ChangeLog b/xfce-base/xfce4-settings/ChangeLog
index 8482f7280dd0..03bcabf2a2e1 100644
--- a/xfce-base/xfce4-settings/ChangeLog
+++ b/xfce-base/xfce4-settings/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-base/xfce4-settings
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-settings/ChangeLog,v 1.65 2011/01/25 20:28:09 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-settings/ChangeLog,v 1.66 2011/01/30 17:00:07 ssuominen Exp $
+
+*xfce4-settings-4.8.1 (30 Jan 2011)
+
+ 30 Jan 2011; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-settings-4.8.1.ebuild:
+ Version bump.
25 Jan 2011; Jeroen Roovers <jer@gentoo.org> xfce4-settings-4.8.0.ebuild:
Stable for HPPA (bug #349053).
diff --git a/xfce-base/xfce4-settings/xfce4-settings-4.8.1.ebuild b/xfce-base/xfce4-settings/xfce4-settings-4.8.1.ebuild
new file mode 100644
index 000000000000..91d7d1faa252
--- /dev/null
+++ b/xfce-base/xfce4-settings/xfce4-settings-4.8.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-settings/xfce4-settings-4.8.1.ebuild,v 1.1 2011/01/30 17:00:07 ssuominen Exp $
+
+EAPI=3
+inherit xfconf
+
+DESCRIPTION="Configuration system for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/xfce4-settings/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/4.8/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug +keyboard libnotify sound"
+
+RDEPEND=">=dev-libs/glib-2.16:2
+ >=dev-libs/dbus-glib-0.88
+ >=gnome-base/libglade-2
+ >=x11-libs/gtk+-2.14:2
+ >=x11-libs/libX11-1
+ >=x11-libs/libXcursor-1.1
+ >=x11-libs/libXi-1.3
+ >=x11-libs/libXrandr-1.2
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/libxfce4ui-4.8
+ >=xfce-base/xfconf-4.8
+ >=xfce-base/exo-0.6
+ libnotify? ( >=x11-libs/libnotify-0.1.3 )
+ keyboard? ( >=x11-libs/libxklavier-0.3 )
+ sound? ( >=media-libs/libcanberra-0.25[sound] )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext
+ >=x11-proto/inputproto-1.4
+ x11-proto/xproto"
+
+pkg_setup() {
+ XFCONF=(
+ --disable-dependency-tracking
+ --disable-static
+ $(use_enable libnotify)
+ $(use_enable keyboard libxklavier)
+ $(use_enable sound sound-settings)
+ $(xfconf_use_debug)
+ )
+
+ DOCS="AUTHORS ChangeLog NEWS TODO"
+}