summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2010-02-10 15:54:50 +0000
committerJeremy Olexa <darkside@gentoo.org>2010-02-10 15:54:50 +0000
commit287f198e3d5dbf5a0f9b54d4721def75a989d06b (patch)
treebe26852de70c190ec8fbe01e9689469e09c0d93e /xfce-base
parentMarked ppc64 stable for bug #303305. (diff)
downloadgentoo-2-287f198e3d5dbf5a0f9b54d4721def75a989d06b.tar.gz
gentoo-2-287f198e3d5dbf5a0f9b54d4721def75a989d06b.tar.bz2
gentoo-2-287f198e3d5dbf5a0f9b54d4721def75a989d06b.zip
Version bump with many small bug fixes http://releases.xfce.org/feeds/project/xfconf - also convert to EAPI3
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfconf/ChangeLog8
-rw-r--r--xfce-base/xfconf/xfconf-4.7.2.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/xfce-base/xfconf/ChangeLog b/xfce-base/xfconf/ChangeLog
index 9ff138b849af..a72f37761533 100644
--- a/xfce-base/xfconf/ChangeLog
+++ b/xfce-base/xfconf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-base/xfconf
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfconf/ChangeLog,v 1.22 2010/02/09 20:49:54 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfconf/ChangeLog,v 1.23 2010/02/10 15:54:50 darkside Exp $
+
+*xfconf-4.7.2 (10 Feb 2010)
+
+ 10 Feb 2010; Jeremy Olexa <darkside@gentoo.org> +xfconf-4.7.2.ebuild:
+ Version bump with many small bug fixes
+ http://releases.xfce.org/feeds/project/xfconf - also convert to EAPI3
09 Feb 2010; Fabian Groffen <grobian@gentoo.org> xfconf-4.7.0.ebuild:
Marked ~x64-solaris
diff --git a/xfce-base/xfconf/xfconf-4.7.2.ebuild b/xfce-base/xfconf/xfconf-4.7.2.ebuild
new file mode 100644
index 000000000000..c23dd69b0a4d
--- /dev/null
+++ b/xfce-base/xfconf/xfconf-4.7.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfconf/xfconf-4.7.2.ebuild,v 1.1 2010/02/10 15:54:50 darkside Exp $
+
+EAPI=3
+inherit xfconf
+
+DESCRIPTION="Xfce configuration daemon and utilities"
+HOMEPAGE="http://www.xfce.org/"
+SRC_URI="mirror://xfce/src/xfce/xfconf/4.7/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~x64-solaris"
+IUSE="debug -perl profile"
+
+RDEPEND=">=dev-libs/dbus-glib-0.72
+ >=dev-libs/glib-2.12:2
+ >=xfce-base/libxfce4util-4.6
+ perl? ( dev-perl/glib-perl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext
+ perl? ( dev-perl/extutils-depends
+ dev-perl/extutils-pkgconfig )"
+
+RESTRICT="test"
+
+pkg_setup() {
+ XFCONF="--disable-dependency-tracking
+ --disable-static
+ --with-perl-options=INSTALLDIRS=vendor
+ $(use_enable perl perl-bindings)
+ --disable-gtk-doc
+ --disable-gtk-doc-html
+ --disable-gtk-doc-pdf
+ $(use_enable debug)
+ $(use_enable debug checks)
+ --with-html-dir=${EPREFIX}/usr/share/doc/${PF}/html"
+
+ use profile && XFCONF="${XFCONF} --enable-profiling"
+
+ DOCS="AUTHORS ChangeLog NEWS TODO"
+}
+
+src_compile() {
+ emake OTHERLDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ xfconf_src_install
+
+ if use perl; then
+ find "${ED}" -type f -name perllocal.pod -delete
+ find "${ED}" -depth -mindepth 1 -type d -empty -delete
+ fi
+}