summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-05-05 16:35:05 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-05-05 16:35:05 +0000
commit00a29deb8bc8f4d6118e1e6f99f7479eaff6aa4b (patch)
treef9601a0bb018e45aa54d509173d23a32a5a6547f /xfce-base
parentVersion bump. (diff)
downloadgentoo-2-00a29deb8bc8f4d6118e1e6f99f7479eaff6aa4b.tar.gz
gentoo-2-00a29deb8bc8f4d6118e1e6f99f7479eaff6aa4b.tar.bz2
gentoo-2-00a29deb8bc8f4d6118e1e6f99f7479eaff6aa4b.zip
Version bump.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfwm4/ChangeLog7
-rw-r--r--xfce-base/xfwm4/xfwm4-4.10.1.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/xfce-base/xfwm4/ChangeLog b/xfce-base/xfwm4/ChangeLog
index cdc75d95f5f7..aac1b2451ff4 100644
--- a/xfce-base/xfwm4/ChangeLog
+++ b/xfce-base/xfwm4/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/xfwm4
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfwm4/ChangeLog,v 1.213 2013/04/13 07:20:11 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfwm4/ChangeLog,v 1.214 2013/05/05 16:35:05 ssuominen Exp $
+
+*xfwm4-4.10.1 (05 May 2013)
+
+ 05 May 2013; Samuli Suominen <ssuominen@gentoo.org> +xfwm4-4.10.1.ebuild:
+ Version bump.
13 Apr 2013; Agostino Sarubbo <ago@gentoo.org> xfwm4-4.10.0-r1.ebuild:
Stable for sparc, wrt bug #465286
diff --git a/xfce-base/xfwm4/xfwm4-4.10.1.ebuild b/xfce-base/xfwm4/xfwm4-4.10.1.ebuild
new file mode 100644
index 000000000000..50dadd228fe8
--- /dev/null
+++ b/xfce-base/xfwm4/xfwm4-4.10.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfwm4/xfwm4-4.10.1.ebuild,v 1.1 2013/05/05 16:35:05 ssuominen Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Window manager for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug startup-notification +xcomposite"
+
+RDEPEND=">=dev-libs/glib-2.20
+ >=x11-libs/gtk+-2.24:2
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/pango
+ >=x11-libs/libwnck-2.30:1
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/xfconf-4.10
+ startup-notification? ( x11-libs/startup-notification )
+ xcomposite? (
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable startup-notification)
+ --enable-xsync
+ --enable-render
+ --enable-randr
+ $(use_enable xcomposite compositor)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog COMPOSITOR NEWS README TODO )
+}