summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-11-04 10:51:20 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-11-04 10:51:20 +0000
commit7eeea278985c7c32a8d3a33a52ca243da45d7c65 (patch)
treee205e2eeebd1b1e83c2973f35ae5539da1ec1648 /xfce-base/xfdesktop
parentx86 stable wrt bug #343491 (diff)
downloadgentoo-2-7eeea278985c7c32a8d3a33a52ca243da45d7c65.tar.gz
gentoo-2-7eeea278985c7c32a8d3a33a52ca243da45d7c65.tar.bz2
gentoo-2-7eeea278985c7c32a8d3a33a52ca243da45d7c65.zip
Version bump.
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base/xfdesktop')
-rw-r--r--xfce-base/xfdesktop/ChangeLog8
-rw-r--r--xfce-base/xfdesktop/xfdesktop-4.7.1.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/xfce-base/xfdesktop/ChangeLog b/xfce-base/xfdesktop/ChangeLog
index 9f05a4d0f1cf..ff9b7c4a5fba 100644
--- a/xfce-base/xfdesktop/ChangeLog
+++ b/xfce-base/xfdesktop/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-base/xfdesktop
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfdesktop/ChangeLog,v 1.173 2010/09/06 23:42:58 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfdesktop/ChangeLog,v 1.174 2010/11/04 10:51:20 ssuominen Exp $
+
+*xfdesktop-4.7.1 (04 Nov 2010)
+
+ 04 Nov 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +xfdesktop-4.7.1.ebuild:
+ Version bump.
06 Sep 2010; Samuli Suominen <ssuominen@gentoo.org>
xfdesktop-4.6.2.ebuild:
diff --git a/xfce-base/xfdesktop/xfdesktop-4.7.1.ebuild b/xfce-base/xfdesktop/xfdesktop-4.7.1.ebuild
new file mode 100644
index 000000000000..c314e4f9c450
--- /dev/null
+++ b/xfce-base/xfdesktop/xfdesktop-4.7.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfdesktop/xfdesktop-4.7.1.ebuild,v 1.1 2010/11/04 10:51:20 ssuominen Exp $
+
+EAPI=3
+inherit xfconf
+
+DESCRIPTION="Desktop manager for Xfce4"
+HOMEPAGE="http://www.xfce.org/projects/xfdesktop"
+SRC_URI="mirror://xfce/src/xfce/${PN}/4.7/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug libnotify thunar"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libSM
+ >=x11-libs/libwnck-2.12
+ >=dev-libs/glib-2.18:2
+ >=x11-libs/gtk+-2.14:2
+ >=xfce-base/libxfce4util-4.6
+ >=xfce-base/libxfce4ui-4.7
+ >=xfce-base/garcon-0.1.2
+ >=xfce-base/xfconf-4.6
+ libnotify? ( >=x11-libs/libnotify-0.4 )
+ thunar? ( >=xfce-base/exo-0.5
+ >=xfce-base/thunar-1.1.3
+ dev-libs/dbus-glib )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --disable-dependency-tracking
+ --disable-static
+ $(use_enable thunar file-icons)
+ $(use_enable thunar thunarx)
+ $(use_enable thunar exo)
+ $(use_enable libnotify notifications)
+ $(xfconf_use_debug)
+ )
+
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+}