summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-11-08 19:30:42 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-11-08 19:30:42 +0000
commit0606e22931f73e0694947814b542864fed58ee57 (patch)
treeee756d673d61b5b9db5c05877001093689a5be1a /xfce-base/xfce4-session
parentSwitch to virtual/jpeg. (diff)
downloadgentoo-2-0606e22931f73e0694947814b542864fed58ee57.tar.gz
gentoo-2-0606e22931f73e0694947814b542864fed58ee57.tar.bz2
gentoo-2-0606e22931f73e0694947814b542864fed58ee57.zip
Fix logout with sudo.
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base/xfce4-session')
-rw-r--r--xfce-base/xfce4-session/ChangeLog9
-rw-r--r--xfce-base/xfce4-session/files/xfce4-session-4.7.1-fix_logout_with_sudo.patch45
-rw-r--r--xfce-base/xfce4-session/xfce4-session-4.7.1-r1.ebuild48
3 files changed, 101 insertions, 1 deletions
diff --git a/xfce-base/xfce4-session/ChangeLog b/xfce-base/xfce4-session/ChangeLog
index 2f1873ce850c..85b7e0fcc060 100644
--- a/xfce-base/xfce4-session/ChangeLog
+++ b/xfce-base/xfce4-session/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for xfce-base/xfce4-session
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-session/ChangeLog,v 1.121 2010/11/03 21:28:18 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-session/ChangeLog,v 1.122 2010/11/08 19:30:42 ssuominen Exp $
+
+*xfce4-session-4.7.1-r1 (08 Nov 2010)
+
+ 08 Nov 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-session-4.7.1-r1.ebuild,
+ +files/xfce4-session-4.7.1-fix_logout_with_sudo.patch:
+ Fix logout with sudo.
*xfce4-session-4.7.1 (03 Nov 2010)
diff --git a/xfce-base/xfce4-session/files/xfce4-session-4.7.1-fix_logout_with_sudo.patch b/xfce-base/xfce4-session/files/xfce4-session-4.7.1-fix_logout_with_sudo.patch
new file mode 100644
index 000000000000..8b0a6efdf075
--- /dev/null
+++ b/xfce-base/xfce4-session/files/xfce4-session-4.7.1-fix_logout_with_sudo.patch
@@ -0,0 +1,45 @@
+From 6f8746b55cbbe1687c4978da55905177cc860968 Mon Sep 17 00:00:00 2001
+From: Landry Breuil <landry@openbsd.org>
+Date: Sun, 07 Nov 2010 11:59:01 +0000
+Subject: Fix logout with sudo.
+
+---
+diff --git a/xfce4-session/xfsm-shutdown-helper.c b/xfce4-session/xfsm-shutdown-helper.c
+index e0a65e8..e6c2817 100644
+--- a/xfce4-session/xfsm-shutdown-helper.c
++++ b/xfce4-session/xfsm-shutdown-helper.c
+@@ -1331,13 +1331,20 @@ xfsm_shutdown_helper_init (XfsmShutdownHelper *helper)
+ xfsm_shutdown_helper_check_backends (helper);
+ }
+ else
+- /* Unable to connect to the system bus, just try sudo*/
+ {
+- g_critical ("Failed to connect to the system bus : %s", error->message);
++ g_warning ("Failed to connect to the system bus : %s", error->message);
+ g_error_free (error);
+
++ /* Unable to connect to the system bus, just try sudo */
+ if (xfsm_shutdown_helper_check_sudo (helper))
+- helper->shutdown_backend = XFSM_SHUTDOWN_BACKEND_SUDO;
++ {
++ helper->shutdown_backend = XFSM_SHUTDOWN_BACKEND_SUDO;
++
++ helper->can_shutdown = TRUE;
++ helper->can_restart = TRUE;
++ helper->auth_shutdown = TRUE;
++ helper->auth_restart = TRUE;
++ }
+ }
+ }
+
+@@ -1645,7 +1652,7 @@ xfsm_shutdown_helper_sudo_send (XfsmShutdownHelper *helper,
+ fprintf (helper->outfile, "%s\n", action);
+ fflush (helper->outfile);
+
+- g_message (G_STRLOC ": Using ConsoleKit to %s",action);
++ g_message (G_STRLOC ": Using sudo to %s", action);
+
+ if (ferror (helper->outfile))
+ {
+--
+cgit v0.8.3.4
diff --git a/xfce-base/xfce4-session/xfce4-session-4.7.1-r1.ebuild b/xfce-base/xfce4-session/xfce4-session-4.7.1-r1.ebuild
new file mode 100644
index 000000000000..efa08b691cd2
--- /dev/null
+++ b/xfce-base/xfce4-session/xfce4-session-4.7.1-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-session/xfce4-session-4.7.1-r1.ebuild,v 1.1 2010/11/08 19:30:42 ssuominen Exp $
+
+EAPI=3
+inherit xfconf
+
+DESCRIPTION="Session manager for Xfce4"
+HOMEPAGE="http://www.xfce.org/projects/xfce4-session/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/4.7/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug gnome gnome-keyring +xfce_plugins_logout"
+
+RDEPEND=">=dev-libs/dbus-glib-0.73
+ x11-apps/iceauth
+ x11-libs/libSM
+ >=x11-libs/libwnck-2.22
+ x11-libs/libX11
+ >=xfce-base/libxfce4util-4.7
+ >=xfce-base/libxfce4ui-4.7
+ >=xfce-base/xfconf-4.7
+ >=xfce-base/xfce-utils-4.7
+ gnome? ( gnome-base/gconf )
+ gnome-keyring? ( gnome-base/libgnome-keyring )
+ xfce_plugins_logout? ( >=xfce-base/xfce4-panel-4.7.2 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ PATCHES=( "${FILESDIR}"/${P}-fix_logout_with_sudo.patch )
+
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --disable-dependency-tracking
+ --disable-static
+ $(use_enable xfce_plugins_logout panel-plugin)
+ $(use_enable gnome)
+ $(use_enable gnome-keyring libgnome-keyring)
+ $(xfconf_use_debug)
+ )
+
+ DOCS="AUTHORS BUGS ChangeLog NEWS README TODO"
+}