summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-10-27 22:40:52 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-10-27 22:40:52 +0000
commit35cded542a5a3e0d1aa04d64493afb8672ccba09 (patch)
tree7dcf71922df63e37731c8f9fff5c3944d91c57bc /xfce-base/thunar
parentAdd thunar-1.0.1-r1 to exo mask. (diff)
downloadgentoo-2-35cded542a5a3e0d1aa04d64493afb8672ccba09.tar.gz
gentoo-2-35cded542a5a3e0d1aa04d64493afb8672ccba09.tar.bz2
gentoo-2-35cded542a5a3e0d1aa04d64493afb8672ccba09.zip
Port Thunar to xfce-base/exo >= 0.5.1 API.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base/thunar')
-rw-r--r--xfce-base/thunar/ChangeLog8
-rw-r--r--xfce-base/thunar/thunar-1.0.1-r1.ebuild80
2 files changed, 87 insertions, 1 deletions
diff --git a/xfce-base/thunar/ChangeLog b/xfce-base/thunar/ChangeLog
index f753159e6462..9a84ad8b2831 100644
--- a/xfce-base/thunar/ChangeLog
+++ b/xfce-base/thunar/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-base/thunar
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/ChangeLog,v 1.82 2009/10/24 16:56:42 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/ChangeLog,v 1.83 2009/10/27 22:40:52 ssuominen Exp $
+
+*thunar-1.0.1-r1 (27 Oct 2009)
+
+ 27 Oct 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +thunar-1.0.1-r1.ebuild:
+ Port Thunar to xfce-base/exo >= 0.5.1 API.
24 Oct 2009; Samuli Suominen <ssuominen@gentoo.org> thunar-1.0.1.ebuild:
Restrict depend to <xfce-base/exo-0.5 because of API change.
diff --git a/xfce-base/thunar/thunar-1.0.1-r1.ebuild b/xfce-base/thunar/thunar-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..ca391f8eea7a
--- /dev/null
+++ b/xfce-base/thunar/thunar-1.0.1-r1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/thunar-1.0.1-r1.ebuild,v 1.1 2009/10/27 22:40:52 ssuominen Exp $
+
+EAPI=2
+MY_P=${P/t/T}
+EAUTORECONF=yes
+inherit virtualx xfconf
+
+DESCRIPTION="File manager for Xfce4"
+HOMEPAGE="http://thunar.xfce.org"
+SRC_URI="mirror://xfce/src/xfce/${PN}/1.0/${MY_P}.tar.bz2
+ http://dev.gentoo.org/~ssuominen/thunar-1.0.1-exo.patch.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="dbus debug doc exif gnome hal pcre startup-notification +trash-plugin"
+
+RDEPEND=">=dev-lang/perl-5.6
+ >=dev-libs/glib-2.6:2
+ >=dev-util/desktop-file-utils-0.14
+ >=media-libs/freetype-2
+ >=media-libs/jpeg-6b
+ >=media-libs/libpng-1.2.0
+ virtual/fam
+ >=x11-libs/gtk+-2.6:2
+ x11-libs/libSM
+ >=x11-misc/shared-mime-info-0.20
+ >=xfce-base/exo-0.5.1[hal?]
+ >=xfce-base/libxfce4util-4.6
+ dbus? ( dev-libs/dbus-glib )
+ exif? ( >=media-libs/libexif-0.6 )
+ hal? ( dev-libs/dbus-glib
+ sys-apps/hal )
+ gnome? ( gnome-base/gconf )
+ pcre? ( >=dev-libs/libpcre-6 )
+ startup-notification? ( x11-libs/startup-notification )
+ trash-plugin? ( dev-libs/dbus-glib
+ >=xfce-base/xfce4-panel-4.6 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext
+ doc? ( dev-libs/libxslt )"
+
+pkg_setup() {
+ PATCHES=( "${WORKDIR}/${P}-exo.patch" )
+ XFCONF="--disable-dependency-tracking
+ $(use_enable dbus)
+ $(use_enable gnome gnome-thumbnailers)
+ $(use_enable startup-notification)
+ $(use_enable doc xsltproc)
+ $(use_enable exif)
+ $(use_enable pcre)
+ $(use_enable debug)"
+
+ if use hal; then
+ XFCONF="${XFCONF} --enable-dbus --with-volume-manager=hal"
+ else
+ XFCONF="${XFCONF} --with-volume-manager=none"
+ fi
+
+ if use trash-plugin; then
+ XFCONF="${XFCONF} --enable-dbus"
+ else
+ XFCONF="${XFCONF} --disable-tpa-plugin"
+ fi
+ DOCS="AUTHORS ChangeLog FAQ HACKING NEWS README THANKS TODO"
+}
+
+src_test() {
+ Xemake check || die "Xemake check failed"
+}
+
+pkg_postinst() {
+ xfconf_pkg_postinst
+ elog "If you are seeing some odd dbus error, make sure your user is in the"
+ elog "plugdev group. See Gentoo bug #279077 for more info"
+}