summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-12-03 16:57:40 +0000
committerSamuli Suominen <drac@gentoo.org>2007-12-03 16:57:40 +0000
commit22e3501c04e1618e5e27e7691fd0bea64ff9e3ce (patch)
tree9c060143c32709ccc07c65428cf267a3c3e2bf80 /xfce-base/thunar
parentStable on amd64 wrt bug #201079 (diff)
downloadgentoo-2-22e3501c04e1618e5e27e7691fd0bea64ff9e3ce.tar.gz
gentoo-2-22e3501c04e1618e5e27e7691fd0bea64ff9e3ce.tar.bz2
gentoo-2-22e3501c04e1618e5e27e7691fd0bea64ff9e3ce.zip
Upstream patch to fix audio cd support with thunar-volman.
(Portage version: 2.1.4_rc4)
Diffstat (limited to 'xfce-base/thunar')
-rw-r--r--xfce-base/thunar/ChangeLog9
-rw-r--r--xfce-base/thunar/files/digest-thunar-0.9.0-r13
-rw-r--r--xfce-base/thunar/files/thunar-0.9.0-missing-audio-cds-for-volman.patch84
-rw-r--r--xfce-base/thunar/thunar-0.9.0-r1.ebuild87
4 files changed, 182 insertions, 1 deletions
diff --git a/xfce-base/thunar/ChangeLog b/xfce-base/thunar/ChangeLog
index 0ec1eecbc0b9..9ae6869472ae 100644
--- a/xfce-base/thunar/ChangeLog
+++ b/xfce-base/thunar/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for xfce-base/thunar
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/ChangeLog,v 1.40 2007/12/02 16:28:48 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/ChangeLog,v 1.41 2007/12/03 16:57:39 drac Exp $
+
+*thunar-0.9.0-r1 (03 Dec 2007)
+
+ 03 Dec 2007; Samuli Suominen <drac@gentoo.org>
+ +files/thunar-0.9.0-missing-audio-cds-for-volman.patch,
+ +thunar-0.9.0-r1.ebuild:
+ Upstream patch to fix audio cd support with thunar-volman.
*thunar-0.9.0 (02 Dec 2007)
diff --git a/xfce-base/thunar/files/digest-thunar-0.9.0-r1 b/xfce-base/thunar/files/digest-thunar-0.9.0-r1
new file mode 100644
index 000000000000..089803d3630e
--- /dev/null
+++ b/xfce-base/thunar/files/digest-thunar-0.9.0-r1
@@ -0,0 +1,3 @@
+MD5 0fc5008858661c0abd0399acbe30ef28 Thunar-0.9.0.tar.bz2 6403785
+RMD160 ebb744aa107d4def06c8c805ee6936d1acf2d4d7 Thunar-0.9.0.tar.bz2 6403785
+SHA256 26c833b0bdf3281c61e03f1fb985feced88cf4a5cebce7bd055f05e025460037 Thunar-0.9.0.tar.bz2 6403785
diff --git a/xfce-base/thunar/files/thunar-0.9.0-missing-audio-cds-for-volman.patch b/xfce-base/thunar/files/thunar-0.9.0-missing-audio-cds-for-volman.patch
new file mode 100644
index 000000000000..d2fa9e7ffbe4
--- /dev/null
+++ b/xfce-base/thunar/files/thunar-0.9.0-missing-audio-cds-for-volman.patch
@@ -0,0 +1,84 @@
+diff -ur Thunar-0.9.0.orig/thunar-vfs/thunar-vfs-volume-hal.c Thunar-0.9.0/thunar-vfs/thunar-vfs-volume-hal.c
+--- Thunar-0.9.0.orig/thunar-vfs/thunar-vfs-volume-hal.c 2007-12-02 15:46:33.000000000 +0200
++++ Thunar-0.9.0/thunar-vfs/thunar-vfs-volume-hal.c 2007-12-03 18:45:48.000000000 +0200
+@@ -1007,9 +1007,7 @@
+ hv = libhal_volume_from_udi (context, udi);
+
+ /* HAL might want us to ignore this volume for some reason */
+- if (G_UNLIKELY (hv != NULL
+- && (libhal_volume_should_ignore (hv)
+- || libhal_volume_get_fsusage (hv) != LIBHAL_VOLUME_USAGE_MOUNTABLE_FILESYSTEM)))
++ if (G_UNLIKELY (hv != NULL && libhal_volume_should_ignore (hv)))
+ {
+ libhal_volume_free (hv);
+ return;
+@@ -1020,38 +1018,42 @@
+
+ if (G_LIKELY (hv != NULL))
+ {
+- /* determine the UDI of the drive to which this volume belongs */
+- drive_udi = libhal_volume_get_storage_device_udi (hv);
+- if (G_LIKELY (drive_udi != NULL))
++ /* check if we have a mountable file system here */
++ if (libhal_volume_get_fsusage (hv) == LIBHAL_VOLUME_USAGE_MOUNTABLE_FILESYSTEM)
+ {
+- /* determine the drive for the volume */
+- hd = libhal_drive_from_udi (context, drive_udi);
+- if (G_LIKELY (hd != NULL))
++ /* determine the UDI of the drive to which this volume belongs */
++ drive_udi = libhal_volume_get_storage_device_udi (hv);
++ if (G_LIKELY (drive_udi != NULL))
+ {
+- /* check if we already have a volume object for the UDI */
+- volume_hal = thunar_vfs_volume_manager_hal_get_volume_by_udi (manager_hal, udi);
+- if (G_LIKELY (volume_hal == NULL))
++ /* determine the drive for the volume */
++ hd = libhal_drive_from_udi (context, drive_udi);
++ if (G_LIKELY (hd != NULL))
+ {
+- /* otherwise, we allocate a new volume object */
+- volume_hal = g_object_new (THUNAR_VFS_TYPE_VOLUME_HAL, NULL);
+- volume_hal->udi = g_strdup (udi);
+- }
+-
+- /* update the volume object with the new data from the HAL volume/drive */
+- thunar_vfs_volume_hal_update (volume_hal, context, hv, hd);
++ /* check if we already have a volume object for the UDI */
++ volume_hal = thunar_vfs_volume_manager_hal_get_volume_by_udi (manager_hal, udi);
++ if (G_LIKELY (volume_hal == NULL))
++ {
++ /* otherwise, we allocate a new volume object */
++ volume_hal = g_object_new (THUNAR_VFS_TYPE_VOLUME_HAL, NULL);
++ volume_hal->udi = g_strdup (udi);
++ }
++
++ /* update the volume object with the new data from the HAL volume/drive */
++ thunar_vfs_volume_hal_update (volume_hal, context, hv, hd);
++
++ /* add the volume object to our list if we allocated a new one */
++ if (g_list_find (THUNAR_VFS_VOLUME_MANAGER (manager_hal)->volumes, volume_hal) == NULL)
++ {
++ /* add the volume to the volume manager */
++ thunar_vfs_volume_manager_add (THUNAR_VFS_VOLUME_MANAGER (manager_hal), THUNAR_VFS_VOLUME (volume_hal));
++
++ /* release the reference on the volume */
++ g_object_unref (G_OBJECT (volume_hal));
++ }
+
+- /* add the volume object to our list if we allocated a new one */
+- if (g_list_find (THUNAR_VFS_VOLUME_MANAGER (manager_hal)->volumes, volume_hal) == NULL)
+- {
+- /* add the volume to the volume manager */
+- thunar_vfs_volume_manager_add (THUNAR_VFS_VOLUME_MANAGER (manager_hal), THUNAR_VFS_VOLUME (volume_hal));
+-
+- /* release the reference on the volume */
+- g_object_unref (G_OBJECT (volume_hal));
++ /* release the HAL drive */
++ libhal_drive_free (hd);
+ }
+-
+- /* release the HAL drive */
+- libhal_drive_free (hd);
+ }
+ }
+
diff --git a/xfce-base/thunar/thunar-0.9.0-r1.ebuild b/xfce-base/thunar/thunar-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..2fb95fa64bc5
--- /dev/null
+++ b/xfce-base/thunar/thunar-0.9.0-r1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/thunar-0.9.0-r1.ebuild,v 1.1 2007/12/03 16:57:39 drac Exp $
+
+EAPI=1
+
+inherit eutils virtualx xfce44
+
+MY_P=${P/t/T}
+S=${WORKDIR}/${MY_P}
+
+XFCE_VERSION=4.4.2
+xfce44
+
+DESCRIPTION="File manager"
+HOMEPAGE="http://thunar.xfce.org"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc dbus debug exif gnome hal pcre startup-notification +trash-plugin"
+
+RDEPEND=">=dev-lang/perl-5.6
+ x11-libs/libSM
+ >=x11-libs/gtk+-2.6
+ >=dev-libs/glib-2.6
+ >=xfce-extra/exo-0.3.4
+ >=x11-misc/shared-mime-info-0.20
+ >=dev-util/desktop-file-utils-0.14
+ >=xfce-base/libxfce4util-${XFCE_MASTER_VERSION}
+ virtual/fam
+ dbus? ( dev-libs/dbus-glib )
+ hal? ( dev-libs/dbus-glib
+ sys-apps/hal )
+ >=media-libs/freetype-2
+ gnome? ( gnome-base/gconf )
+ exif? ( >=media-libs/libexif-0.6 )
+ >=media-libs/jpeg-6b
+ startup-notification? ( x11-libs/startup-notification )
+ pcre? ( >=dev-libs/libpcre-6 )
+ trash-plugin? ( dev-libs/dbus-glib
+ >=xfce-base/xfce4-panel-${XFCE_MASTER_VERSION} )
+ gnome-base/librsvg"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ doc? ( dev-util/gtk-doc )"
+
+XFCE_CONFIG="${XFCE_CONFIG} $(use_enable exif) $(use_enable gnome gnome-thumbnailers) \
+ $(use_enable dbus) $(use_enable pcre)"
+
+pkg_setup() {
+ local fail="Re-emerge xfce-extra/exo with USE hal."
+
+ if use hal; then
+ XFCE_CONFIG="${XFCE_CONFIG} --enable-dbus --with-volume-manager=hal"
+ else
+ XFCE_CONFIG="${XFCE_CONFIG} --with-volume-manager=none"
+ fi
+
+ if use trash-plugin && ! use dbus; then
+ XFCE_CONFIG="${XFCE_CONFIG} --enable-dbus"
+ ewarn "USE trash-plugin detected, enabling dbus for you."
+ fi
+
+ use trash-plugin || XFCE_CONFIG="${XFCE_CONFIG} --disable-tpa-plugin"
+
+ if use hal && ! use dbus; then
+ ewarn "USE hal detected, enabling dbus for you."
+ fi
+
+ if use hal && ! built_with_use xfce-extra/exo hal; then
+ eerror "${fail}"
+ die "${fail}"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-missing-audio-cds-for-volman.patch
+}
+
+src_test() {
+ Xemake check || die "emake check failed."
+}
+
+DOCS="AUTHORS ChangeLog HACKING FAQ THANKS TODO README NEWS"
+
+xfce44_extra_package