summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-03-11 13:14:20 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-03-11 13:14:20 +0000
commit6021af2de57faae9b712de013cc54a7d1eb1aa93 (patch)
tree0e42f266dac7b96554a35f9368cae5c0077338f8 /xfce-base/libxfce4util/libxfce4util-4.11.0.ebuild
parentPrerelease version bump. (diff)
downloadgentoo-2-6021af2de57faae9b712de013cc54a7d1eb1aa93.tar.gz
gentoo-2-6021af2de57faae9b712de013cc54a7d1eb1aa93.tar.bz2
gentoo-2-6021af2de57faae9b712de013cc54a7d1eb1aa93.zip
Prerelease version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'xfce-base/libxfce4util/libxfce4util-4.11.0.ebuild')
-rw-r--r--xfce-base/libxfce4util/libxfce4util-4.11.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/xfce-base/libxfce4util/libxfce4util-4.11.0.ebuild b/xfce-base/libxfce4util/libxfce4util-4.11.0.ebuild
new file mode 100644
index 000000000000..35ee7e1e7d68
--- /dev/null
+++ b/xfce-base/libxfce4util/libxfce4util-4.11.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfce4util/libxfce4util-4.11.0.ebuild,v 1.1 2014/03/11 13:14:20 ssuominen Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="A basic utility library for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.24"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(xfconf_use_debug)
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ [[ ${CHOST} == *-darwin* ]] && XFCONF+=( --disable-visibility ) #366857
+
+ DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+}