summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-03-30 20:29:58 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-03-30 20:29:58 +0000
commit53f358bfcfa7b645db7d451fe724eccdc903ebb7 (patch)
treef014cf0a48df270358d7aafa457beaf04616dcf4 /xfce-base/libxfce4ui
parentVersion bump to development release. (diff)
downloadgentoo-2-53f358bfcfa7b645db7d451fe724eccdc903ebb7.tar.gz
gentoo-2-53f358bfcfa7b645db7d451fe724eccdc903ebb7.tar.bz2
gentoo-2-53f358bfcfa7b645db7d451fe724eccdc903ebb7.zip
Version bump to development series.
(Portage version: 2.2.0_alpha96/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base/libxfce4ui')
-rw-r--r--xfce-base/libxfce4ui/ChangeLog7
-rw-r--r--xfce-base/libxfce4ui/libxfce4ui-4.9.1.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/xfce-base/libxfce4ui/ChangeLog b/xfce-base/libxfce4ui/ChangeLog
index 1205fe36b7d4..70284af1e6fb 100644
--- a/xfce-base/libxfce4ui/ChangeLog
+++ b/xfce-base/libxfce4ui/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/libxfce4ui
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfce4ui/ChangeLog,v 1.33 2012/03/23 21:17:04 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfce4ui/ChangeLog,v 1.34 2012/03/30 20:29:58 ssuominen Exp $
+
+*libxfce4ui-4.9.1 (30 Mar 2012)
+
+ 30 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> +libxfce4ui-4.9.1.ebuild:
+ Version bump to development series.
23 Mar 2012; Christoph Mende <angelos@gentoo.org> libxfce4ui-4.8.1.ebuild,
libxfce4ui-4.9.0.ebuild:
diff --git a/xfce-base/libxfce4ui/libxfce4ui-4.9.1.ebuild b/xfce-base/libxfce4ui/libxfce4ui-4.9.1.ebuild
new file mode 100644
index 000000000000..d601b0687d78
--- /dev/null
+++ b/xfce-base/libxfce4ui/libxfce4ui-4.9.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfce4ui/libxfce4ui-4.9.1.ebuild,v 1.1 2012/03/30 20:29:58 ssuominen Exp $
+
+EAPI=4
+inherit xfconf
+
+DESCRIPTION="Unified widgets and session management libraries for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/libxfce4"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug glade startup-notification"
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=x11-libs/gtk+-2.14:2
+ x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ >=xfce-base/libxfce4util-4.9
+ >=xfce-base/xfconf-4.9
+ glade? ( dev-util/glade:3 )
+ startup-notification? ( x11-libs/startup-notification )
+ !<xfce-base/xfce-utils-4.9"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ XFCONF=(
+ $(use_enable startup-notification)
+ $(use_enable glade gladeui)
+ $(xfconf_use_debug)
+ --with-vendor-info=Gentoo
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ [[ ${CHOST} == *-darwin* ]] && XFCONF+=( --disable-visibility ) #366857
+
+ DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+}