summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-02 15:11:34 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-02 15:11:34 +0000
commitdcf5e428432c307d0ec7077e506317487a34ab3e (patch)
treeb712cf486cad04c6f5704894332ed6783718e080 /xfce-base/exo
parentx86 stable wrt bug #350187 (diff)
downloadgentoo-2-dcf5e428432c307d0ec7077e506317487a34ab3e.tar.gz
gentoo-2-dcf5e428432c307d0ec7077e506317487a34ab3e.tar.bz2
gentoo-2-dcf5e428432c307d0ec7077e506317487a34ab3e.zip
Version bump.
(Portage version: 2.2.0_alpha10/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base/exo')
-rw-r--r--xfce-base/exo/ChangeLog9
-rw-r--r--xfce-base/exo/exo-0.5.6.ebuild64
2 files changed, 71 insertions, 2 deletions
diff --git a/xfce-base/exo/ChangeLog b/xfce-base/exo/ChangeLog
index e739f97c200b..1df2109de5c4 100644
--- a/xfce-base/exo/ChangeLog
+++ b/xfce-base/exo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/exo
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/ChangeLog,v 1.46 2010/11/24 14:17:43 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/ChangeLog,v 1.47 2011/01/02 15:11:34 ssuominen Exp $
+
+*exo-0.5.6 (02 Jan 2011)
+
+ 02 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> +exo-0.5.6.ebuild:
+ Version bump.
24 Nov 2010; Samuli Suominen <ssuominen@gentoo.org> exo-0.5.5.ebuild:
Missing USE python for byte compiling wrt #346597 by Peter Volkov.
diff --git a/xfce-base/exo/exo-0.5.6.ebuild b/xfce-base/exo/exo-0.5.6.ebuild
new file mode 100644
index 000000000000..ab5f5dc55ff5
--- /dev/null
+++ b/xfce-base/exo/exo-0.5.6.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/exo-0.5.6.ebuild,v 1.1 2011/01/02 15:11:34 ssuominen Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="python? 2"
+
+inherit python xfconf
+
+DESCRIPTION="Extensions, widgets and framework library with session management support"
+HOMEPAGE="http://www.xfce.org/projects/exo/"
+SRC_URI="mirror://xfce/src/xfce/exo/0.5/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="debug python"
+
+RDEPEND=">=dev-lang/perl-5.6
+ dev-perl/URI
+ >=dev-libs/glib-2.18:2
+ >=x11-libs/gtk+-2.14:2
+ xfce-base/libxfce4util
+ python? ( >=dev-python/pygtk-2.4 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --disable-dependency-tracking
+ --disable-static
+ $(use_enable python)
+ $(xfconf_use_debug)
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ DOCS="AUTHORS ChangeLog HACKING NEWS README THANKS TODO"
+}
+
+src_prepare() {
+ rm -f py-compile
+ ln -s $(type -P true) py-compile
+
+ xfconf_src_prepare
+}
+
+pkg_postinst() {
+ xfconf_pkg_postinst
+ use python && python_mod_optimize exo-0.5 pyexo.py
+}
+
+pkg_postrm() {
+ xfconf_pkg_postrm
+ use python && python_mod_cleanup exo-0.5 pyexo.py
+}