summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMatt Keadle <mkeadle@gentoo.org>2003-05-08 03:04:49 +0000
committerMatt Keadle <mkeadle@gentoo.org>2003-05-08 03:04:49 +0000
commitf7dcf28f5e64b8444bff6d98db788b369f9f7ce5 (patch)
tree2dae3ecd00a97fac2d875ffb2bcfcc89087d9ea8 /x11-wm
parentCommented out kerberos support -- generates compile errors (diff)
downloadgentoo-2-f7dcf28f5e64b8444bff6d98db788b369f9f7ce5.tar.gz
gentoo-2-f7dcf28f5e64b8444bff6d98db788b369f9f7ce5.tar.bz2
gentoo-2-f7dcf28f5e64b8444bff6d98db788b369f9f7ce5.zip
and this little piggy goes to 2.3.1
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/openbox/files/digest-openbox-2.3.11
-rw-r--r--x11-wm/openbox/files/openbox-2.3.1-epist.patch14
-rw-r--r--x11-wm/openbox/openbox-2.3.1.ebuild51
3 files changed, 66 insertions, 0 deletions
diff --git a/x11-wm/openbox/files/digest-openbox-2.3.1 b/x11-wm/openbox/files/digest-openbox-2.3.1
new file mode 100644
index 000000000000..93068a976007
--- /dev/null
+++ b/x11-wm/openbox/files/digest-openbox-2.3.1
@@ -0,0 +1 @@
+MD5 4905d17fd84314485b56e7e8a3195314 openbox-2.3.1.tar.gz 408418
diff --git a/x11-wm/openbox/files/openbox-2.3.1-epist.patch b/x11-wm/openbox/files/openbox-2.3.1-epist.patch
new file mode 100644
index 000000000000..fc044bf6cb12
--- /dev/null
+++ b/x11-wm/openbox/files/openbox-2.3.1-epist.patch
@@ -0,0 +1,14 @@
+*** util/epist/epist.cc.~1.44.12.1.~ Sat Apr 5 12:28:03 2003
+--- util/epist/epist.cc Fri Apr 25 08:48:21 2003
+***************
+*** 52,57 ****
+--- 52,61 ----
+ # include <sys/stat.h>
+ #endif // HAVE_SYS_STAT_H
+
++ #ifdef HAVE_STDIO_H
++ # include <stdio.h>
++ #endif // HAVE_STDIO_H
++
+ #include <sys/wait.h>
+ }
diff --git a/x11-wm/openbox/openbox-2.3.1.ebuild b/x11-wm/openbox/openbox-2.3.1.ebuild
new file mode 100644
index 000000000000..7d3d511da56b
--- /dev/null
+++ b/x11-wm/openbox/openbox-2.3.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-2.3.1.ebuild,v 1.1 2003/05/08 03:04:49 mkeadle Exp $
+
+IUSE="nls"
+
+inherit commonbox eutils
+
+S=${WORKDIR}/${P}
+DESCRIPTION=" Openbox is a window manager with an enhanced Blackbox style-engine that supports the KDE and GNOME2 desktop environments and their applications. It provides a familiar environment to Blackbox users with added customizability."
+SRC_URI="http://icculus.org/openbox/releases/${P}.tar.gz"
+HOMEPAGE="http://icculus.org/openbox/"
+
+SLOT="2"
+LICENSE="BSD"
+KEYWORDS="~x86 ppc sparc"
+
+DEPEND="$DEPEND
+ virtual/xft"
+
+mydoc="CHANGE* TODO LICENSE data/README*"
+myconf="--enable-xinerama"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-epist.patch
+
+}
+
+#src_compile() {
+
+# commonbox_src_compile
+
+#}
+
+src_install() {
+
+ commonbox_src_install
+
+ rm -f ${D}/usr/share/man/man1/xftlsfonts*
+ mv ${D}/usr/share/commonbox/openbox/epistrc \
+ ${D}/usr/share/commonbox/epistrc.default
+ rmdir ${D}/usr/share/commonbox/${PN}
+ rmdir ${D}/usr/share/commonbox/${MYBIN}
+
+ insinto /usr/share/commonbox/buttons
+ doins ${S}/data/buttons/*.xbm
+
+}