summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-05-26 13:58:04 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-05-26 13:58:04 +0000
commitdc223158f71eca3c1e54939bff24dfbb9c103375 (patch)
tree47a3aee228d9481ea22d48d01f17a12a794dd5c9 /x11-wm
parentversion bump (diff)
downloadgentoo-2-dc223158f71eca3c1e54939bff24dfbb9c103375.tar.gz
gentoo-2-dc223158f71eca3c1e54939bff24dfbb9c103375.tar.bz2
gentoo-2-dc223158f71eca3c1e54939bff24dfbb9c103375.zip
prettification patch applied
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/fvwm/ChangeLog11
-rw-r--r--x11-wm/fvwm/files/digest-fvwm-2.4.7-r12
-rw-r--r--x11-wm/fvwm/fvwm-2.4.7-r1.ebuild48
3 files changed, 60 insertions, 1 deletions
diff --git a/x11-wm/fvwm/ChangeLog b/x11-wm/fvwm/ChangeLog
index 176c8ae9ae69..363e2a03ae6d 100644
--- a/x11-wm/fvwm/ChangeLog
+++ b/x11-wm/fvwm/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-wm/fvwm
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/ChangeLog,v 1.4 2002/05/26 07:10:23 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/ChangeLog,v 1.5 2002/05/26 13:58:04 seemant Exp $
+
+*fvwm-2.4.7-r1 (26 May 2002)
+
+ 26 May 2002; Seemant Kulleen <seemant@gentoo.org> fvwm-2.4.7-r1.ebuild
+ files/digest-fvwm-2.4.7-r1 :
+
+ Tristan pointed me to a patch which prettifies the window dressings. The
+ code is already in fvwm's developmental (2.5.x) branch, but a patch has
+ been made for this release as well.
*fvwm-2.4.7 (26 May 2002)
diff --git a/x11-wm/fvwm/files/digest-fvwm-2.4.7-r1 b/x11-wm/fvwm/files/digest-fvwm-2.4.7-r1
new file mode 100644
index 000000000000..5f7f95223758
--- /dev/null
+++ b/x11-wm/fvwm/files/digest-fvwm-2.4.7-r1
@@ -0,0 +1,2 @@
+MD5 57a5b11d57d551aef2c5ae385eb31050 fvwm-2.4.7.tar.bz2 1322700
+MD5 6eb8083a4f5468bf5685002266c1efc0 fvwm-patch 17761
diff --git a/x11-wm/fvwm/fvwm-2.4.7-r1.ebuild b/x11-wm/fvwm/fvwm-2.4.7-r1.ebuild
new file mode 100644
index 000000000000..9d2ae2077610
--- /dev/null
+++ b/x11-wm/fvwm/fvwm-2.4.7-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Prakash Shetty <crux@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.4.7-r1.ebuild,v 1.1 2002/05/26 13:58:04 seemant Exp $
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="an extremely powerful ICCCM-compliant multiple virtual desktop window manager"
+SRC_URI="ftp://ftp.fvwm.org/pub/fvwm/version-2/${P}.tar.bz2
+ http://www.igs.net/~tril/fvwm/configs/fvwm-patch"
+HOMEPAGE="http://www.fvwm.org/"
+
+DEPEND=">=dev-libs/libstroke-0.4
+ gtk? ( =x11-libs/gtk+-1.2* )
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 )
+ ncurses? ( >=sys-libs/readline-4.1 )"
+
+src_unpack() {
+
+ unpack ${P}.tar.bz2
+ cd ${S}
+ patch -p0 < ${DISTDIR}/${PN}-patch
+}
+
+src_compile() {
+ local myconf
+
+ use gnome \
+ && myconf="--with-gnome" \
+ || myconf="--without-gnome" \
+
+ ./configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ --libexecdir=/usr/lib \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ exeinto /etc/X11/Sessions
+ doexe $FILESDIR/fvwm2
+}