summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-12 14:09:13 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-12 14:09:13 +0000
commitd5ff1ce97c6cad1beed69397ac9f4f2ca5f728b5 (patch)
treee315fb967924900ff884d46cff8a2813162541e9 /x11-wm
parentVersion bump (diff)
downloadgentoo-2-d5ff1ce97c6cad1beed69397ac9f4f2ca5f728b5.tar.gz
gentoo-2-d5ff1ce97c6cad1beed69397ac9f4f2ca5f728b5.tar.bz2
gentoo-2-d5ff1ce97c6cad1beed69397ac9f4f2ca5f728b5.zip
Fix graphical corruption in window decorations with gtk+-3.4 (bug #411723, thanks to Juergen Rose for reporting).
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/mutter/ChangeLog10
-rw-r--r--x11-wm/mutter/files/mutter-3.2.2-frame-initialize-style-contexts.patch30
-rw-r--r--x11-wm/mutter/mutter-3.2.2-r1.ebuild84
3 files changed, 123 insertions, 1 deletions
diff --git a/x11-wm/mutter/ChangeLog b/x11-wm/mutter/ChangeLog
index 58bd762a7561..b9ece2bbfdf4 100644
--- a/x11-wm/mutter/ChangeLog
+++ b/x11-wm/mutter/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-wm/mutter
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/mutter/ChangeLog,v 1.6 2012/02/04 20:33:03 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/mutter/ChangeLog,v 1.7 2012/04/12 14:09:13 tetromino Exp $
+
+*mutter-3.2.2-r1 (12 Apr 2012)
+
+ 12 Apr 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +mutter-3.2.2-r1.ebuild,
+ +files/mutter-3.2.2-frame-initialize-style-contexts.patch:
+ Fix graphical corruption in window decorations with gtk+-3.4 (bug #411723,
+ thanks to Juergen Rose for reporting).
04 Feb 2012; Alexandre Rostovtsev <tetromino@gentoo.org> mutter-3.2.2.ebuild,
+files/mutter-3.2.2-disable-introspection.patch:
diff --git a/x11-wm/mutter/files/mutter-3.2.2-frame-initialize-style-contexts.patch b/x11-wm/mutter/files/mutter-3.2.2-frame-initialize-style-contexts.patch
new file mode 100644
index 000000000000..650501513cf6
--- /dev/null
+++ b/x11-wm/mutter/files/mutter-3.2.2-frame-initialize-style-contexts.patch
@@ -0,0 +1,30 @@
+From 7253a75b18452f71db3f2d58d0b0e5ccc6ff16cc Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
+Date: Sat, 10 Mar 2012 21:28:13 +0100
+Subject: [PATCH] frames: Explicitly initialize style contexts
+
+We were relying on GTK+ emitting GtkWidget::style-updated during
+widget initialization to create the GtkStyleContexts used for
+window decorations. A recent GTK+ update broke this assumption,
+so do the necessary initialization ourselves.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=671796
+---
+ src/ui/frames.c | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/src/ui/frames.c b/src/ui/frames.c
+index 0204f1a..1b4ef8d 100644
+--- a/src/ui/frames.c
++++ b/src/ui/frames.c
+@@ -273,6 +273,7 @@ meta_frames_init (MetaFrames *frames)
+
+ frames->style_variants = g_hash_table_new_full (g_str_hash, g_str_equal,
+ g_free, g_object_unref);
++ update_style_contexts (frames);
+
+ gtk_widget_set_double_buffered (GTK_WIDGET (frames), FALSE);
+
+--
+1.7.8.5
+
diff --git a/x11-wm/mutter/mutter-3.2.2-r1.ebuild b/x11-wm/mutter/mutter-3.2.2-r1.ebuild
new file mode 100644
index 000000000000..59915443037e
--- /dev/null
+++ b/x11-wm/mutter/mutter-3.2.2-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/mutter/mutter-3.2.2-r1.ebuild,v 1.1 2012/04/12 14:09:13 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="GNOME 3 compositing window manager based on Clutter"
+HOMEPAGE="http://git.gnome.org/browse/mutter/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+introspection test xinerama"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND=">=x11-libs/pango-1.2[X,introspection?]
+ >=x11-libs/cairo-1.10[X]
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.91.7:3[introspection?]
+ >=gnome-base/gconf-2:2
+ >=dev-libs/glib-2.14:2
+ >=media-libs/clutter-1.7.5:1.0
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=x11-libs/startup-notification-0.7
+ >=x11-libs/libXcomposite-0.2
+
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libXrender
+
+ gnome-extra/zenity
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMON_DEPEND}
+ >=app-text/gnome-doc-utils-0.8
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ test? ( app-text/docbook-xml-dtd:4.5 )
+ xinerama? ( x11-proto/xineramaproto )
+ x11-proto/xextproto
+ x11-proto/xproto"
+RDEPEND="${COMMON_DEPEND}
+ !x11-misc/expocity"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README *.txt doc/*.txt"
+ G2CONF="${G2CONF}
+ --disable-static
+ --enable-gconf
+ --enable-shape
+ --enable-sm
+ --enable-startup-notification
+ --enable-xsync
+ --enable-verbose-mode
+ --enable-compile-warnings=maximum
+ --with-libcanberra
+ $(use_enable introspection)
+ $(use_enable xinerama)"
+}
+
+src_prepare() {
+ # Compat with Ubuntu metacity themes (e.g. x11-themes/light-themes)
+ epatch "${FILESDIR}/${PN}-3.2.1-ignore-shadow-and-padding.patch"
+
+ # Patch from 3.3.x, fixes building without introspection
+ epatch "${FILESDIR}/${P}-disable-introspection.patch"
+
+ # Patch from 3.3.92, fixes window decorations with gtk+-3.4
+ epatch "${FILESDIR}/${P}-frame-initialize-style-contexts.patch"
+
+ gnome2_src_prepare
+}