summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2015-06-01 10:55:52 +0000
committerMichael Weber <xmw@gentoo.org>2015-06-01 10:55:52 +0000
commitc2455cc3d125918423843802b1763b4c7fd0df76 (patch)
tree741727074c3f83974b0a4ce984d5dbe30555f281 /x11-wm
parentRemove old. (diff)
downloadgentoo-2-c2455cc3d125918423843802b1763b4c7fd0df76.tar.gz
gentoo-2-c2455cc3d125918423843802b1763b4c7fd0df76.tar.bz2
gentoo-2-c2455cc3d125918423843802b1763b4c7fd0df76.zip
Add .desktop file (thanks Andrew Hamilton, bug 489012) and version bump (thanks Sarah Salzstein).
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/spectrwm/ChangeLog9
-rw-r--r--x11-wm/spectrwm/files/spectrwm.desktop7
-rw-r--r--x11-wm/spectrwm/spectrwm-2.7.2.ebuild47
3 files changed, 62 insertions, 1 deletions
diff --git a/x11-wm/spectrwm/ChangeLog b/x11-wm/spectrwm/ChangeLog
index 6f3abd3e3edc..ff1e716c1a7d 100644
--- a/x11-wm/spectrwm/ChangeLog
+++ b/x11-wm/spectrwm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-wm/spectrwm
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/spectrwm/ChangeLog,v 1.14 2015/02/27 12:50:58 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/spectrwm/ChangeLog,v 1.15 2015/06/01 10:55:52 xmw Exp $
+
+*spectrwm-2.7.2 (01 Jun 2015)
+
+ 01 Jun 2015; Michael Weber <xmw@gentoo.org> +files/spectrwm.desktop,
+ +spectrwm-2.7.2.ebuild:
+ Add .desktop file (thanks Andrew Hamilton, bug 489012) and version bump
+ (thanks Sarah Salzstein).
*spectrwm-2.5.0 (27 Feb 2015)
*spectrwm-2.4.0 (27 Feb 2015)
diff --git a/x11-wm/spectrwm/files/spectrwm.desktop b/x11-wm/spectrwm/files/spectrwm.desktop
new file mode 100644
index 000000000000..ca9a5b6337e4
--- /dev/null
+++ b/x11-wm/spectrwm/files/spectrwm.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=spectrwm
+Comment=A lighweight tiling window manager
+Exec=/etc/X11/Sessions/spectrwm
+TryExec=spectrwm
+Icon=
+Type=Application
diff --git a/x11-wm/spectrwm/spectrwm-2.7.2.ebuild b/x11-wm/spectrwm/spectrwm-2.7.2.ebuild
new file mode 100644
index 000000000000..348e3e26c3df
--- /dev/null
+++ b/x11-wm/spectrwm/spectrwm-2.7.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/spectrwm/spectrwm-2.7.2.ebuild,v 1.1 2015/06/01 10:55:52 xmw Exp $
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Small dynamic tiling window manager for X11"
+HOMEPAGE="https://opensource.conformal.com/wiki/spectrwm"
+SRC_URI="http://opensource.conformal.com/snapshots/${PN}/${P}.tgz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-misc/dmenu"
+DEPEND="${DEPEND}
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXrandr
+ x11-libs/libXtst
+ x11-libs/xcb-util
+ !x11-wm/scrotwm"
+
+S=${WORKDIR}/${P}/linux
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.6.2-Makefile.patch
+ tc-export CC
+}
+
+src_install() {
+ emake PREFIX="${D}"/usr LIBDIR="${D}usr/$(get_libdir)" install
+
+ cd "${WORKDIR}"/${P} || die
+
+ insinto /etc
+ doins ${PN}.conf
+ dodoc ${PN}_*.conf {initscreen,screenshot}.sh
+
+ make_session_desktop ${PN} ${PN}
+
+ elog "Example keyboard config and helpful scripts can be found"
+ elog "in ${ROOT}usr/share/doc/${PF}"
+}