summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJosé María Alonso <nimiux@gentoo.org>2015-01-06 13:27:35 +0000
committerJosé María Alonso <nimiux@gentoo.org>2015-01-06 13:27:35 +0000
commita0ab347f127d5b0c400db763ec857add67239058 (patch)
tree94dfd8dad74f8a3036763d94e32188874df1747b /x11-wm
parentConvert to python-single-r1, enforce a match on Python version used by vim. (diff)
downloadgentoo-2-a0ab347f127d5b0c400db763ec857add67239058.tar.gz
gentoo-2-a0ab347f127d5b0c400db763ec857add67239058.tar.bz2
gentoo-2-a0ab347f127d5b0c400db763ec857add67239058.zip
Fix bug 534592. Use require instead of asdf:load-op
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key F253DB15)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/stumpwm/ChangeLog7
-rw-r--r--x11-wm/stumpwm/stumpwm-0.9.9.ebuild18
2 files changed, 17 insertions, 8 deletions
diff --git a/x11-wm/stumpwm/ChangeLog b/x11-wm/stumpwm/ChangeLog
index 9732f1ca352a..2cc2a3fca59c 100644
--- a/x11-wm/stumpwm/ChangeLog
+++ b/x11-wm/stumpwm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-wm/stumpwm
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/stumpwm/ChangeLog,v 1.11 2014/12/24 12:04:04 ulm Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/stumpwm/ChangeLog,v 1.12 2015/01/06 13:27:35 nimiux Exp $
+
+ 06 Jan 2015; Chema Alonso <nimiux@gentoo.org> stumpwm-0.9.9.ebuild:
+ Fix bug 534592. Use require instead of asdf:load-op
24 Dec 2014; Ulrich Müller <ulm@gentoo.org> stumpwm-0.9.9.ebuild:
Fix typo in variable name.
diff --git a/x11-wm/stumpwm/stumpwm-0.9.9.ebuild b/x11-wm/stumpwm/stumpwm-0.9.9.ebuild
index a69f36357f91..9aa562667256 100644
--- a/x11-wm/stumpwm/stumpwm-0.9.9.ebuild
+++ b/x11-wm/stumpwm/stumpwm-0.9.9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/stumpwm/stumpwm-0.9.9.ebuild,v 1.2 2014/12/24 12:04:04 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/stumpwm/stumpwm-0.9.9.ebuild,v 1.3 2015/01/06 13:27:35 nimiux Exp $
EAPI=5
@@ -12,17 +12,17 @@ SRC_URI="http://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+KEYWORDS="~amd64 ~x86"
IUSE="doc clisp ecl +sbcl emacs"
RESTRICT="strip mirror"
RDEPEND="dev-lisp/cl-ppcre
+ sbcl? ( >=dev-lisp/sbcl-1.0.32 )
sbcl? ( >=dev-lisp/clx-0.7.4 )
!sbcl? ( !clisp? ( !ecl? ( >=dev-lisp/sbcl-1.0.32 ) ) )
!sbcl? ( !clisp? ( ecl? ( >=dev-lisp/ecls-10.4.1 ) ) )
!sbcl? ( clisp? ( >=dev-lisp/clisp-2.44[X,new-clx] ) )
- sbcl? ( >=dev-lisp/sbcl-1.0.32 )
emacs? ( virtual/emacs app-emacs/slime )"
DEPEND="${RDEPEND}
sys-apps/texinfo
@@ -32,6 +32,7 @@ SITEFILE=70${PN}-gentoo.el
get_lisp() {
local lisp
+
for lisp in "$@" ; do
use ${lisp} && echo ${lisp} && return
done
@@ -41,16 +42,21 @@ do_doc() {
local pdffile="${PN}.pdf"
texi2pdf -o "${pdffile}" "${PN}.texi.in" && dodoc "${pdffile}" || die
- cp "${FILESDIR}"/README.Gentoo . && sed -i "s:@VERSION@:${PV}:" README.Gentoo || die
+ cp "${FILESDIR}/README.Gentoo" . && sed -i "s:@VERSION@:${PV}:" README.Gentoo || die
dodoc AUTHORS NEWS README.md README.Gentoo
- doinfo ${PN}.info
+ doinfo "${PN}.info"
docinto examples ; dodoc sample-stumpwmrc.lisp
}
src_prepare() {
# Upstream didn't change the version before packaging
sed -i "${S}/${PN}.asd" -e 's/:version "0.9.8"/:version "0.9.9"/' || die
+ # Bug 534592. Does not build with asdf:oos, using require to load the package
+ sed -i "${S}/load-${PN}.lisp.in" -e "s/asdf:oos 'asdf:load-op/require/" || die
eautoreconf
+}
+
+src_configure() {
econf --with-lisp=$(get_lisp sbcl clisp ecl)
}