summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-01-04 19:09:29 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-01-04 19:09:29 +0000
commita09a6f535026b19de8d5996f53a856afa9a1317d (patch)
tree025f6df6fae92fbd8684d3d76fd70a1810998141 /x11-wm
parentStable on sparc wrt #159445 (diff)
downloadgentoo-2-a09a6f535026b19de8d5996f53a856afa9a1317d.tar.gz
gentoo-2-a09a6f535026b19de8d5996f53a856afa9a1317d.tar.bz2
gentoo-2-a09a6f535026b19de8d5996f53a856afa9a1317d.zip
Fix broken autotools handling.
(Portage version: 2.1.2_rc4-r5)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/ratpoison/ChangeLog7
-rw-r--r--x11-wm/ratpoison/ratpoison-1.4.0.ebuild16
2 files changed, 14 insertions, 9 deletions
diff --git a/x11-wm/ratpoison/ChangeLog b/x11-wm/ratpoison/ChangeLog
index 916ca44aaf84..0c2911a0e923 100644
--- a/x11-wm/ratpoison/ChangeLog
+++ b/x11-wm/ratpoison/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-wm/ratpoison
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ChangeLog,v 1.39 2006/12/11 22:45:30 weeve Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ChangeLog,v 1.40 2007/01/04 19:09:29 flameeyes Exp $
+
+ 04 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> ratpoison-1.4.0.ebuild:
+ Fix broken autotools handling.
11 Dec 2006; Jason Wever <weeve@gentoo.org> ratpoison-1.4.0.ebuild:
Fixed PodParser dependency, resolves bug #157680.
diff --git a/x11-wm/ratpoison/ratpoison-1.4.0.ebuild b/x11-wm/ratpoison/ratpoison-1.4.0.ebuild
index 37246452e5f3..f409b14461e1 100644
--- a/x11-wm/ratpoison/ratpoison-1.4.0.ebuild
+++ b/x11-wm/ratpoison/ratpoison-1.4.0.ebuild
@@ -1,8 +1,11 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ratpoison-1.4.0.ebuild,v 1.4 2006/12/11 22:45:30 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ratpoison-1.4.0.ebuild,v 1.5 2007/01/04 19:09:29 flameeyes Exp $
-inherit elisp-common eutils
+WANT_AUTOMAKE=latest
+WANT_AUTOCONF=latest
+
+inherit elisp-common eutils autotools
MY_P=${P/_beta/-beta}
S=${WORKDIR}/${MY_P}
@@ -26,13 +29,12 @@ src_unpack() {
unpack ${A}
cd ${S}/contrib
epatch ${FILESDIR}/ratpoison.el-gentoo.patch
+
+ cd "${S}"
+ eautoreconf
}
src_compile() {
- if [ "${ARCH}" = "amd64" ]
- then
- libtoolize -c -f
- fi
econf || die "econf failed"
emake CFLAGS="${CFLAGS} -I/usr/X11R6/include" || die
if use emacs; then