summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2007-06-06 22:01:05 +0000
committerJim Ramsay <lack@gentoo.org>2007-06-06 22:01:05 +0000
commit8b65afd60e1f70951b248bd93ba5f87d06e359c8 (patch)
treeec870f0570f9ec0bafe2202f46124c502d0b104b /x11-wm
parent Revision including a bunch of patches from scipy-svn. Now also includes (diff)
downloadgentoo-2-8b65afd60e1f70951b248bd93ba5f87d06e359c8.tar.gz
gentoo-2-8b65afd60e1f70951b248bd93ba5f87d06e359c8.tar.bz2
gentoo-2-8b65afd60e1f70951b248bd93ba5f87d06e359c8.zip
Fix for Bug 181039 - patches 'startfluxbox' script so it actually starts fluxbox on your first ever run
(Portage version: 2.1.2.7)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/fluxbox/ChangeLog9
-rw-r--r--x11-wm/fluxbox/files/1.0_rc3/startfluxbox_doesnt.patch16
-rw-r--r--x11-wm/fluxbox/files/digest-fluxbox-1.0_rc3-r33
-rw-r--r--x11-wm/fluxbox/fluxbox-1.0_rc3-r3.ebuild178
4 files changed, 205 insertions, 1 deletions
diff --git a/x11-wm/fluxbox/ChangeLog b/x11-wm/fluxbox/ChangeLog
index 55301485a350..28c626f5869c 100644
--- a/x11-wm/fluxbox/ChangeLog
+++ b/x11-wm/fluxbox/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-wm/fluxbox
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/ChangeLog,v 1.217 2007/05/23 23:01:54 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/ChangeLog,v 1.218 2007/06/06 22:01:05 lack Exp $
+
+*fluxbox-1.0_rc3-r3 (06 Jun 2007)
+
+ 06 Jun 2007; Jim Ramsay <lack@gentoo.org>
+ +files/1.0_rc3/startfluxbox_doesnt.patch, +fluxbox-1.0_rc3-r3.ebuild:
+ Fix for Bug 181039 - patches 'startfluxbox' script so it actually starts
+ fluxbox on your first ever run
23 May 2007; Jim Ramsay <lack@gentoo.org>
+files/0.9.13/fluxbox-0.9.13-our-styles-go-over-here.patch,
diff --git a/x11-wm/fluxbox/files/1.0_rc3/startfluxbox_doesnt.patch b/x11-wm/fluxbox/files/1.0_rc3/startfluxbox_doesnt.patch
new file mode 100644
index 000000000000..fceafaa60923
--- /dev/null
+++ b/x11-wm/fluxbox/files/1.0_rc3/startfluxbox_doesnt.patch
@@ -0,0 +1,16 @@
+--- fluxbox-1.0rc3/util/startfluxbox.in 2007-03-19 13:57:15.000000000 -0600
++++ fluxbox-1.0rc3-svn-4917/util/startfluxbox.in 2007-03-27 20:56:21.000000000 -0600
+@@ -1,5 +1,5 @@
+ #!/bin/sh
+-# $Id: startfluxbox_doesnt.patch,v 1.1 2007/06/06 22:01:05 lack Exp $
++# $Id: startfluxbox_doesnt.patch,v 1.1 2007/06/06 22:01:05 lack Exp $
+
+ command="`basename \"$0\"`"
+ startup="$HOME/.fluxbox/startup"
+@@ -86,5 +86,5 @@
+ ) > "$startup"
+ fi
+ chmod 644 "$startup"
+- exec "$startup"
++ exec sh "$startup"
+ fi
diff --git a/x11-wm/fluxbox/files/digest-fluxbox-1.0_rc3-r3 b/x11-wm/fluxbox/files/digest-fluxbox-1.0_rc3-r3
new file mode 100644
index 000000000000..a68891bf80b5
--- /dev/null
+++ b/x11-wm/fluxbox/files/digest-fluxbox-1.0_rc3-r3
@@ -0,0 +1,3 @@
+MD5 8ed52d10d7de72efab0948eaaa4a6a50 fluxbox-1.0rc3.tar.bz2 780622
+RMD160 5086545ea2c2b0dd71f17d314838d04f197a1294 fluxbox-1.0rc3.tar.bz2 780622
+SHA256 cf1e2aa77716e42b2457b19989c2b2d2fc5f7d900cc16a3621a2e42372f474b6 fluxbox-1.0rc3.tar.bz2 780622
diff --git a/x11-wm/fluxbox/fluxbox-1.0_rc3-r3.ebuild b/x11-wm/fluxbox/fluxbox-1.0_rc3-r3.ebuild
new file mode 100644
index 000000000000..367604a1ed3f
--- /dev/null
+++ b/x11-wm/fluxbox/fluxbox-1.0_rc3-r3.ebuild
@@ -0,0 +1,178 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/fluxbox-1.0_rc3-r3.ebuild,v 1.1 2007/06/06 22:01:05 lack Exp $
+
+inherit eutils
+
+IUSE="nls xinerama truetype kde gnome imlib disableslit disabletoolbar"
+
+DESCRIPTION="Fluxbox is an X11 window manager featuring tabs and an iconbar"
+MY_P="fluxbox-1.0rc3"
+
+S="${WORKDIR}/${MY_P}"
+SRC_URI="mirror://sourceforge/fluxbox/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.fluxbox.org"
+
+# Please note that USE="kde gnome" simply adds support for the respective
+# protocols, and does not depend on external libraries. They do, however,
+# make the binary a fair bit bigger, so we don't want to turn them on unless
+# the user actually wants them.
+
+RDEPEND="|| ( ( x11-libs/libXpm
+ x11-libs/libXrandr
+ xinerama? ( x11-libs/libXinerama )
+ x11-apps/xmessage
+ )
+ virtual/x11
+ )
+ virtual/xft
+ truetype? ( media-libs/freetype )
+ imlib? ( >=media-libs/imlib2-1.2.0 )
+ !<x11-themes/fluxbox-styles-fluxmod-20040809-r1"
+DEPEND="!<=x11-misc/fluxconf-0.9.9
+ >=sys-devel/autoconf-2.52
+ nls? ( sys-devel/gettext )
+ || ( ( x11-proto/xextproto
+ xinerama? ( x11-proto/xineramaproto )
+ )
+ virtual/x11
+ )
+ ${RDEPEND}"
+PROVIDE="virtual/blackbox"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+pkg_setup() {
+ if use imlib ; then
+ if ! built_with_use media-libs/imlib2 X ; then
+ eerror "To build fluxbox with imlib in USE, you need an X enabled"
+ eerror "media-libs/imlib2 . Either recompile imlib2 with the X"
+ eerror "USE flag turned on or disable the imlib USE flag for fluxbox."
+ die "USE=imlib requires imlib2 with USE=X"
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # We need to be able to include directories rather than just plain
+ # files in menu [include] items. This patch will allow us to do clever
+ # things with style ebuilds.
+ epatch "${FILESDIR}/${PV}/${P}-our-styles-go-over-here.patch" || die "Patch failed"
+
+ # Bug 177114 - Segfault for certain locales
+ epatch "${FILESDIR}/${PV}/${P}-textproperties_segfault.patch" || die "Patch failed"
+
+ # Some "bottom" windows, notably ROX Filer's panel, cause a flicker sometimes
+ epatch "${FILESDIR}/${PV}/${P}-flicker.patch" || die "Patch failed"
+
+ # Bug 176476 - Missing icons from fluxbox-generate_menu
+ epatch "${FILESDIR}/${PV}/${P}-generate_menu_icon_fix.patch" || die "Patch failed"
+
+ # Bug 181039 - Startup fails on first run
+ epatch "${FILESDIR}/${PV}/startfluxbox_doesnt.patch" || die "Patch failed"
+
+ # Add in the Gentoo -r number to fluxbox -version output.
+ if [[ "${PR}" == "r0" ]] ; then
+ suffix="gentoo"
+ else
+ suffix="gentoo-${PR}"
+ fi
+ sed -i \
+ -e "s~\(__fluxbox_version .@VERSION@\)~\1-${suffix}~" \
+ version.h.in || die "version sed failed"
+
+ # Turn on aa by default if possible. Fluxbox fonts are really frickin'
+ # broken, we'll do what we can to make it less painful by default.
+ use truetype 1>/dev/null && \
+ echo "session.screen0.antialias: true" >> data/init.in
+
+ # Fix broken styles
+ ebegin "Fixing backgrounds..."
+ for style in "${S}/data/styles/"* ; do
+ [[ -f "${style}" ]] || continue
+ sed -i -e 's,\([^f]\)bsetroot,\1fbsetroot,' "${style}" \
+ || die "styles sed failed on ${style}"
+ done
+ eend 0
+}
+
+src_compile() {
+ export PKG_CONFIG_PATH=/usr/X11R6/lib/pkgconfig:/usr/lib/pkgconfig
+
+ econf \
+ $(use_enable nls) \
+ $(use_enable xinerama) \
+ $(use_enable truetype xft) \
+ $(use_enable kde) \
+ $(use_enable gnome) \
+ $(use_enable imlib imlib2) \
+ $(use_enable !disableslit slit ) \
+ $(use_enable !disabletoolbar toolbar ) \
+ --sysconfdir=/etc/X11/${PN} \
+ --with-style=/usr/share/fluxbox/styles/Emerge \
+ ${myconf} || die "configure failed"
+
+ emake || die "make failed"
+
+ ebegin "Creating a menu file (may take a while)"
+ mkdir -p "${T}/home/.fluxbox" || die "mkdir home failed"
+ MENUFILENAME="${S}/data/menu" MENUTITLE="Fluxbox ${PV}" \
+ CHECKINIT="no. go away." HOME="${T}/home" \
+ "${S}/util/fluxbox-generate_menu" -is -ds \
+ || die "menu generation failed"
+ eend $?
+}
+
+src_install() {
+ dodir /usr/share/fluxbox
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc README* AUTHORS TODO* ChangeLog NEWS
+
+ dodir /usr/share/xsessions
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}/${PN}.desktop"
+
+ dodir /etc/X11/Sessions
+ echo "/usr/bin/startfluxbox" > "${D}/etc/X11/Sessions/fluxbox"
+ fperms a+x /etc/X11/Sessions/fluxbox
+
+ dodir /usr/share/fluxbox/menu.d
+
+ # Styles menu framework
+ dodir /usr/share/fluxbox/menu.d/styles
+ insinto /usr/share/fluxbox/menu.d/styles
+ doins "${FILESDIR}/styles-menu-fluxbox" || die
+ doins "${FILESDIR}/styles-menu-commonbox" || die
+ doins "${FILESDIR}/styles-menu-user" || die
+}
+
+pkg_postinst() {
+ einfo "As of fluxbox 0.9.10-r3, we are using an improved layout for"
+ einfo "styles to avoid problems with huge menus. Use the following"
+ einfo "in the menu for your menu styles section:"
+ echo
+ einfo " [submenu] (Styles) {Select a Style}"
+ einfo " [include] (/usr/share/fluxbox/menu.d/styles/)"
+ einfo " [end]"
+ echo
+ einfo "If you use fluxbox-generate_menu or the default global fluxbox"
+ einfo "menu file, this will already be present."
+ echo
+ einfo "Note that menumaker and similar utilities do *not* support"
+ einfo "this out of the box."
+ echo
+ einfo "As of fluxbox 0.9.14_pre1, Fluxbox uses XFT for font rendering. If"
+ einfo "you experience font problems, try tinkering with your theme files."
+ einfo "You can check the validity of a font name using:"
+ echo
+ einfo " XFT_DEBUG=1 xfd -fa 'whatever-12:bold'"
+ echo
+ einfo "The slow startup issues in previous versions should now be fixed;"
+ einfo "if you still encounter problems, please report bugs upstream."
+}
+